Results 1 to 7 of 7

Thread: New USB devices not detected (10.3)

  1. #1

    Default New USB devices not detected (10.3)

    My current USB stuff works fine (mouse/keyboard/external hdd etc) but anything new that I plug in, like my camera (canon 400d) or a usb stick, isn't detected.

    I can go into digikam/picasa and it sees the camera, but spends an eternity trying to connect to it (the camera even looks as if it's being talked to) before timing out. The usb stick draws power (it's light comes on) but the computer fails to see it.

    Here's the "ahh here's his problem" part - I was trying to get usb working in virtualbox, followed a tutorial and still didn't get it to work. I figure that this corresponds with around the time this usb weirdness started to happen, so it's something I've done. I also handily lost the tutorial and can't find it now.

    In fstab, I have usb listed as:
    Code:
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    Is that unusual? If not, can somebody help me fix this?

    Oh and I'm not trying to fix the virtualbox problem, I just want my usb working again.

  2. #2

    Smile Re: New USB devices not detected (10.3)

    Just had this problem, see the following:-

    Virtualbox USB options greyed out - openSUSE Forums

  3. #3

    Default Re: New USB devices not detected (10.3)

    Mmm no that's not my problem - I've somehow killed auto-detection in linux, I'm not concerned with usb in virtualbox now.

  4. #4

    Default Re: New USB devices not detected (10.3)

    Did you solve this?
    I'm having similar problems with 11.0

  5. #5

    Default Re: New USB devices not detected (10.3)

    Not yet no.

  6. #6

    Default Re: New USB devices not detected (10.3)

    Bump. Still having the same problem, although my error logs report this:

    Code:
    Jun 23 19:54:19 linux-y218 kernel: usb 3-3: new high speed USB device using ehci_hcd and address 17
    Jun 23 19:54:19 linux-y218 kernel: usb 3-3: new device found, idVendor=0781, idProduct=5406
    Jun 23 19:54:19 linux-y218 kernel: usb 3-3: new device strings: Mfr=1, Product=2, SerialNumber=3
    Jun 23 19:54:19 linux-y218 kernel: usb 3-3: Product: U3 Cruzer Micro
    Jun 23 19:54:19 linux-y218 kernel: usb 3-3: Manufacturer: SanDisk Corporation
    Jun 23 19:54:19 linux-y218 kernel: usb 3-3: SerialNumber: 0000162B537062CB
    Jun 23 19:54:19 linux-y218 kernel: usb 3-3: configuration #1 chosen from 1 choice
    Jun 23 19:54:19 linux-y218 kernel: scsi9 : SCSI emulation for USB Mass Storage devices
    Jun 23 19:54:19 linux-y218 kernel: usb-storage: device found at 17
    Jun 23 19:54:19 linux-y218 kernel: usb-storage: waiting for device to settle before scanning
    Jun 23 19:54:20 linux-y218 kernel: scsi 9:0:0:0: Direct-Access     SanDisk  U3 Cruzer Micro  3.27 PQ: 0 ANSI: 2
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] 8015502 512-byte hardware sectors (4104 MB)
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] Write Protect is off
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] Mode Sense: 03 00 00 00
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] Assuming drive cache: write through
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] 8015502 512-byte hardware sectors (4104 MB)
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] Write Protect is off
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] Mode Sense: 03 00 00 00
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] Assuming drive cache: write through
    Jun 23 19:54:20 linux-y218 kernel:  sde: sde1
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: [sde] Attached SCSI removable disk
    Jun 23 19:54:20 linux-y218 kernel: sd 9:0:0:0: Attached scsi generic sg5 type 0
    Jun 23 19:54:20 linux-y218 kernel: usb-storage: device scan complete
    I can manually mount it at the commandline, but automatic mounting seems to be turned off. Can somebody help?

  7. #7

    Default Re: New USB devices not detected (10.3)

    The 'noauto' is in my config too, but it generally detects new USB devices without a problem.

    There's another thread I just commented on about getting USB working in Virtualbox.

    One of the methods someone had mentioned for getting it to work was to add "mount -a" to a script that automatically gets run. You might try that out, though I'm a bit skeptical that's your problem.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •