Results 1 to 3 of 3

Thread: using OSS drivers instead of ALSA for Amarok

  1. #1
    shubu000 NNTP User

    Default using OSS drivers instead of ALSA for Amarok

    Hi guys,
    i'm pretty new to opensuse, so i'm just wondering how can i change the driver for amarok from alsa to OSS, as OSS is much better for my soundcard.

    cheers

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: using OSS drivers instead of ALSA for Amarok

    Quote Originally Posted by shubu000 View Post
    i'm pretty new to opensuse, so i'm just wondering how can i change the driver for amarok from alsa to OSS, as OSS is much better for my soundcard.
    Welcome to openSUSE.

    I don't have this requirement, but IF I did, what I would do is check out the sound driver that xine uses. Amarok can use xine as a sound engine, and so if you can get xine using OSS, then you can get Amarok using oss. Take a good look at the xine setup options (you may have to select the "master of the universe" permissions setting in xine).

    I also recommend you install the packman packaged version of libxine1, as opposed to using the Novell/SuSE-GmbH packaged version. And also with libxine1 install the packman packaged "mad" and packman packaged "xine-ui". xine-ui is useful for directly checking out xine's functionality with various multimedia files.

  3. #3
    shubu000 NNTP User

    Default Re: using OSS drivers instead of ALSA for Amarok

    Thanks for the reply, i'll certain try that once i get into suse again, but at least it works.. unlike ubuntu.. everything looks very structured in suse which i like

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •