Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Desktop effects must be re-enabled each reboot

  1. #1

    Default Desktop effects must be re-enabled each reboot

    Hi all,

    I have Opensuse 11.0 running with Compiz under the default settings. All my plugins work fine.

    Every time I reboot (or kill the X server), I need to go to simple-ccsm and re-enable the desktop effects on login.

    How do I stop this?

    Cheers

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Desktop effects must be re-enabled each reboot

    This was an issue with the first beta's but should be fixed by now.

    Are you running the final version? and which DE (KDE/GNOME) are you using?
    Also, have you installed extra items for compiz or left things default?

    Cheers,
    Wj
    Have a lot of fun!

  3. #3

    Default Re: Desktop effects must be re-enabled each reboot

    I am running the release version of 11.0, with some extra plug-ins. I am using KDE.

    To be honest, I'm not even sure whether this effect occurred before I installed the extra plug-ins; it might have.

    I haven't done anything to the system but install the compiz-extra, emerald, etc plug-ins. Perhaps it's worth doing a clean re-install and seeing what happens without any modification?

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Desktop effects must be re-enabled each reboot

    It's an old workaround and I will be re-installing using the 11 final next week, so will have more to share then, but try auto loading compiz-manager or the fusion-icon when logging in. That should fire up compiz for your session.

    Cheers,
    Wj
    Have a lot of fun!

  5. #5
    p34cekeeper NNTP User

    Default Re: Desktop effects must be re-enabled each reboot

    openSUSE 11.0 64 bit, with KDE 4 and Compiz

    Right, I had this problem as well, using KDE4 in conjunction with Compiz fusion. When i first boot in i get the disappearing title bar/focus problem.


    I found that the workaround for the problem is this:

    1: After booting in, even with emerald set as the window decorator, it does not register. I have to open a terminal and type 'emerald --replace'.

    2: I close the terminal window I typed that into and it will go buggy again.

    3: I activate the "Compiz Fusion Icon" utility and right click, selecting the KDE4 window decorator, click off, then re select Emerald.

    4: usually at this point the last emerald theme i used pops back into existence until i log out or reboot.

    I've given up at this point and removed all compiz resources, no "Burn" menus for me

    EDIT: Also tried creating a startup script that contains 'compiz --replace' and 'emerald --replace' in it, but that just gets rid of all window borders completely.

  6. #6
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Desktop effects must be re-enabled each reboot

    You could open a bug report over at opensuse.org as you have very specific (and valuable) info!
    It will help get this issue cleared

    Cheers,
    Wj
    Have a lot of fun!

  7. #7

    Default Re: Desktop effects must be re-enabled each reboot

    I have found a work-around, to my issue anyway.

    I place a script in ~/.kde4/Autostart with chmod +x, containing
    #!/bin/bash
    sleep 5
    compiz-manager --replace &

    This seems to fix it, although obviously it's not ideal.

  8. #8

    Default Re: Desktop effects must be re-enabled each reboot

    This seems to be a problem with the kde3/4 implementation, it works perfectly on gnome
    "If it ain't broke, find something wrong with it"

  9. #9

    Default Re: Desktop effects must be re-enabled each reboot

    see my experience
    ( OpenSuSE 11.0 - Upgrade or Clean Install? - Page 5 - openSUSE Forums )


    i had the same problem

    --usernorth

  10. #10

    Default Re: Desktop effects must be re-enabled each reboot


Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •