Results 1 to 3 of 3

Thread: Need help with zmd error

  1. #1
    Shivaji Samanta NNTP User

    Default Need help with zmd error

    My web server, running Open Suse 10.1 has been giving an error window every
    time I open a session "ZMD does not appear to be running". Today I checked
    from a ssh session and it gives me the following :
    Susan:~ # zed -no
    19 Jun 2008 17:57:26 INFO Daemon Starting ZED version 7.1.1
    19 Jun 2008 17:57:26 INFO Daemon Using Mono 1.1.13.8
    19 Jun 2008 17:57:26 INFO WebCache Expiring cached files...
    19 Jun 2008 17:57:26 INFO KeyManager Loading key whitelist
    19 Jun 2008 17:57:26 INFO Daemon Loading trusted
    certificates...
    19 Jun 2008 17:57:26 WARN NetworkManagerModule Failed to connect to
    NetworkManager

    =================================================================
    Got a SIGSEGV while executing native code. This usually indicates
    a fatal error in the mono runtime or one of the native libraries
    used by your application.
    =================================================================

    Stacktrace:

    in (wrapper managed-to-native) Mono.Data.SqliteClient.Sqlite:sqlite3_step
    (intptr) <0xb>
    in (wrapper managed-to-native) Mono.Data.SqliteClient.Sqlite:sqlite3_step
    (intptr) <0x147b>
    in Mono.Data.SqliteClient.SqliteDataReader:ExecuteNonQuery
    (Mono.Data.SqliteClient.SqliteCommand,intptr) <0x43>
    in Mono.Data.SqliteClient.SqliteCommand:ExecuteNonQuery () <0x1e>
    in Novell.Zenworks.Zmd.Packaging.Database:ExecNonQuery (string,bool) <0x80>
    in Novell.Zenworks.Zmd.Packaging.Database:ExecNonQueryIgnoreErrors (string)
    <0x15>
    in Novell.Zenworks.Zmd.Packaging.Database:Clean () <0x1c>
    in Novell.Zenworks.Zmd.Packaging.RedCarpetBackend:.ctor () <0xab>
    in Novell.Zenworks.Zmd.Packaging.PackageManagementModule:ModuleInit ()
    <0x1c6>
    in (wrapper runtime-invoke) System.Object:runtime_invoke_ModuleInfo
    (object,intptr,intptr,intptr) <0xffffffffbf97c805>
    in (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke
    (object,object[]) <0xb>
    in (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke
    (object,object[]) <0xfffffffffffffeb2>
    in System.Reflection.MonoMethod:Invoke
    (object,System.Reflection.BindingFlags,System.Reflection.Binder,object[],System.Globalization.CultureInfo)
    <0xda>
    in System.Reflection.MethodBase:Invoke (object,object[]) <0x34>
    in Novell.Zenworks.Zmd.ModuleLoader:Init (System.Reflection.Assembly)
    <0x29e>
    in Novell.Zenworks.Zmd.ModuleLoader:Load (string) <0x6b>
    in Novell.Zenworks.Zmd.ModuleLoader:Load () <0xfc>
    in Novell.Zenworks.Zmd.Daemon:Run (string[]) <0x5df>
    in Novell.Zenworks.Zmd.ZmdStart:Main (string[]) <0x10>
    in (wrapper runtime-invoke) System.Object:runtime_invoke_void_string[]
    (object,intptr,intptr,intptr) <0xffffffffc04397cb>

    Native stacktrace:

    zmd(mono_handle_native_sigsegv+0x8d) [0x503b1d]
    zmd [0x4d1928]
    /lib64/libpthread.so.0 [0x2af28904f0d0]
    /usr/lib64/libsqlite3.so.0(sqlite3VdbeCursorMoveto+0x15)
    [0x2aaaac650095]
    /usr/lib64/libsqlite3.so.0(sqlite3VdbeExec+0x1655) [0x2aaaac64baa5]
    /usr/lib64/libsqlite3.so.0(sqlite3_step+0x11a) [0x2aaaac64f34a]
    [0x40adf32d]
    Aborted
    ===========================================================

    Any ideas what is going on, and what I can do to fix it ?

    Thanks for any help.

    --
    Shivaji Samanta
    Wytheville Community College


  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Need help with zmd error

    There is a troubleshooting page you could look at here : Troubleshooting zmd - openSUSE

    Also make sure the service is up and running (sudo rczmd status)
    Have a lot of fun!

  3. #3
    Shivaji Samanta NNTP User

    Default Re: Need help with zmd error

    Thanks for the pointer, I used the instructions there to zap the database
    and re-initialize, which may have fixed the issue. Incidentally, I also
    found some good zmd trouble shooting tips at
    https://secure-support.novell.com/Ka...AL_Public.html

    "Magic31" <Magic31@no-mx.forums.opensuse.org> wrote in message
    news:Magic31.3bafor@no-mx.forums.opensuse.org...
    >
    > There is a troubleshooting page you could look at here :
    > 'Troubleshooting zmd - openSUSE'
    > (http://en.opensuse.org/ZMD/Libzypp_Troubleshooting)
    >
    > Also make sure the service is up and running (sudo rczmd status)
    >
    >
    > --
    > Novell is dead? Been hearing that line for 10 years now... And
    > fortunately been quite deaf to hear it. Still gives a kick to
    > experience the innovations & combined with Linux & its community, it
    > makes my era a more fun time to be living in, got to love it!
    > ------------------------------------------------------------------------
    > Magic31's Profile: http://forums.opensuse.org/member.php?userid=289
    > View this thread: http://forums.opensuse.org/showthread.php?t=386386
    >



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •