Results 1 to 10 of 10

Thread: Proxy

  1. #1
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Proxy

    I have been testing openSUSE on a work computer. We use bluecoat for a proxy. I can configure the proxy and open a web browser, and that works. Or I can set the web browser to auto-detect the proxy, and that works as well. However, I can't use YaST to install software. If I put the proxy information in YaST, it prompts for user/password, which I provide, but I can't get it to work. I am using the same user/password for the proxy in the web browser, and on another box at the same time.

    I've got YaST configured to use the same proxy information for all protocals, yet isn't the package manager just using http for http repositories?

    Is there something I'm missing?

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Proxy

    Do you have any characters that might be special to the shell in your user or password, like ! $ \ and so forth?

    Can you get anything via wget, like this (all on one line)?

    Code:
    http_proxy=http://proxy.domain.name:3128/  wget --proxy-user=user --proxy-password=password http://some.resource.site/somepath/foo.html

  3. #3
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: Proxy

    wget worked, and Firefox works. When I'm behind the proxy, YaST will prompt for user and password, but it won't take it.

    I've tried just username, and domain\username and domain/username, but it doesn't seem to work.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Proxy

    You didn't answer the question whether there are any special characters in your name or password.

  5. #5
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: Proxy

    Nope, just plain letters and numbers.

    I did try that wget command, substituing obviously all my pertinent info, and I was able to download Google's logo and Microsoft's default.aspx home page.

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Proxy

    Try putting your details manually in /etc/sysconfig/proxy, variable HTTP_PROXY. The format is:

    Code:
    http://user:password@proxyhost:port/

  7. #7
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: Proxy

    That did the trick!

    Thanks!

  8. #8

    Default Re: Proxy

    Quote Originally Posted by ken_yap View Post
    Try putting your details manually in /etc/sysconfig/proxy, variable HTTP_PROXY. The format is:

    Code:
    http://user:password@proxyhost:port/

    I've tried this, and it's still not working for me. I've even tried setting the proxy to "no" in the file and going out directly after opening up ports, and openSuSE 10.3 still insists on trying to use the proxy and nagging me that I need authentication. I have the number "1" in my password, but that shouldn't be an issue

    Do you have to do anything after you edit the proxy file? I tried SuSEconfig, rcnetwork restart, etc. nothing seems to help.

    Thanks.

    Danita

  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Proxy

    I don't think anything extra is needed, but this problem hasn't happened to me.

    You could check if there's an ~/.curlrc or /etc/curlrc that's overriding YaST but I think YaST takes care to ignore config files. Or maybe not.

  10. #10

    Default Re: Proxy

    I ended up rebooting the PC and things started working with the new settings, but I still couldn't get an nvidia driver to intall without a slew of dependency problems, so I'm going to move this to 10.2 for now. My ultimate goal is to put 11 on it, but it's taking awhile to download. I'm not the most patient person in the world

    Thanks!

    Danita

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •