Results 1 to 8 of 8

Thread: Mount Problems with 11.0 RC1

  1. #1

    Default Mount Problems with 11.0 RC1

    I've updated to the most current software, but this did not help. I have an external harddrive connected via USB with two NTFS partitions. When I try to mount the partitions under KDE 3.5, then I get the following error message:

    Code:
    mount: wrong fs type, bad option, bad superblock on /dev/sdc1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so
    I could mount the same harddrive under 10.3 without any problems and a run with chkdsk /f under Windows XP doesn't show any errors on the harddrive itself. Can anyone can help me there?

    Another question: Does 11.0 mount NTFS partitions writable? If not, how do I change the default? AFAIK, NTFS partition write access is stable now, so I'D like to use it.

  2. #2
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: Mount Problems with 11.0 RC1

    Quote Originally Posted by jluber View Post
    I've updated to the most current software, but this did not help.
    Then, why does the title say 'RC1'? Should I believe the title or the text?

  3. #3

    Default Re: Mount Problems with 11.0 RC1

    Quote Originally Posted by cookdav View Post
    Then, why does the title say 'RC1'? Should I believe the title or the text?
    Believe the text. I wasn't sure how to add that fact into the title (nor do I seem to be able to edit my post to account for that). Sorry about the confusion.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Mount Problems with 11.0 RC1

    Another question: Does 11.0 mount NTFS partitions writable? If not, how do I change the default? AFAIK, NTFS partition write access is stable now, so I'D like to use it.
    No.
    To mount them writable create a place to mount them like /windows/C and /windows/D then use like these in a console:
    Code:
    sudo ntfs-3g /dev/sdc1 /windows/C
    sudo ntfs-3g /dev/sdc2 /windows/D
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5

    Default Re: Mount Problems with 11.0 RC1

    Quote Originally Posted by swerdna View Post
    No.
    To mount them writable create a place to mount them like /windows/C and /windows/D then use like these in a console:
    Code:
    sudo ntfs-3g /dev/sdc1 /windows/C
    sudo ntfs-3g /dev/sdc2 /windows/D
    Thanks! Trying these commands showed that mount complained actually that these partitions were marked as in use. It seems simply shutting down the computer isn't enough to change that flag once it got set...

    In any case, I could solve my problem with the force option which means that in my case the error message is wrong and misleading. Any chance to add that possibility? The same goes to the automatic write-enabling when mounting. If writing is OK for USB sticks why not for external NTFS partitions?

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Mount Problems with 11.0 RC1

    Quote Originally Posted by jluber View Post
    Any chance to add that (force) possibility?
    Not sure what you mean, you might mean -- adding force into a permanent entry in fstab which you could try like this and see if it works:
    /dev/sdc1 /windows/C ntfs-3g defaults,force 0 0
    Quote Originally Posted by jluber View Post
    If writing is OK for USB sticks why not for external NTFS partitions?
    Because a usb stick has the FAT filesystem by default, not NTFS.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7

    Default Re: Mount Problems with 11.0 RC1

    Quote Originally Posted by swerdna View Post
    Not sure what you mean, you might mean -- adding force into a permanent entry in fstab which you could try like this and see if it works:
    Yes, I meant it as you interpret it. But does the automount feature read fstab?

    Quote Originally Posted by swerdna View Post
    Because a usb stick has the FAT filesystem by default, not NTFS.
    And why is writing to NTFS bad? It works, doesn't it?

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Mount Problems with 11.0 RC1

    Quote Originally Posted by jluber View Post
    Yes, I meant it as you interpret it. But does the automount feature read fstab?
    Sorry, misunderstanding. In Suse you cannot automount extenal ntfs partitons read/wriet, just read-only. To get them reda write you have to do two commands like this:
    Code:
    umount /dev/whatever
    ntfs-3g /dev/whatever /path_to/mount -o force
    or put like that in a script and run it each time you plug drive in. It would be fun to write such a script to simulate such an automount.
    And why is writing to NTFS bad? It works, doesn't it?
    It's great -- ntfs is a truly splendid piece of technology -- I'm just saying that "writing is ok for external usb sticks" because they don't use ntfs and so they automount ok.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •