Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: ATI + Desktop Effects = White

  1. #1

    Default ATI + Desktop Effects = White

    Just installed 11.0 a few hours ago, installed the latest, or I assume latest ATI drivers via one click method, enabled Desktop Effects and I now have a pure white desktop.

    How do I, or can I, disable Desktop Effects from the terminal?

    I restored the automatically saved xorg.conf but it didn't help.

    I have an X1800XT btw, should Desktop Effects work under that?

    Oh and what command line text editors are available for Suse? I'd love nano or something mildly usable unlike vi or vim. Is there a way to list all present editors?

  2. #2

    Default Re: ATI + Desktop Effects = White

    I assume you're using KDE, as the 'white screen of death' seems to be more common with KDE. Am I right?

    Does the x-server start at all? When do you get the wsod?


  3. #3

    Default Re: ATI + Desktop Effects = White

    No I'm using Gnome. X starts, for a few seconds you can see glorious green and the Gnome loading splash screen, the screen flickers a bit while desktop effects are trying to start then everything goes white.

  4. #4

    Default Re: ATI + Desktop Effects = White

    I ran sax2 from the terminal which made some edits to the configuration by itself and now alls working fine, although the effects do seem a slight be glitchy.

  5. #5
    Join Date
    Jun 2008
    Seattle, WA

    Default Re: ATI + Desktop Effects = White

    I also have the same problem you had. Is there any way you could give me some more details on how to fix this? I'm new to the openSUSE desktop.


  6. #6

    Default Re: ATI + Desktop Effects = White

    When it boots into the white desktop press Alt+Ctrl+F1 to open a terminal, and type "su -" and enter your root password. Now type "sax2". This will open the graphics and monitor properties. It will hopefully tell you that it has decided on a configuration and all you do is accept the changes, reboot your system.

  7. #7
    Join Date
    Jun 2008
    finland and raisio is the town

    Default Re: ATI + Desktop Effects = White

    i have too same problem that atis fglrx dont work its same with kde4 and gnome getting only white screen when enable desktop effects how i can fix the problem or can i fix it ?

  8. #8
    Join Date
    Jun 2008
    Provo, UT

    Default Re: ATI + Desktop Effects = White

    Same problem here (except with KDE).

  9. #9

    Default Re: ATI + Desktop Effects = White

    Same problem here. All of the desktop controls still work, just can't seem them. Running Gnome on Mobility Raedon x1600. Fortunately the setting is profile dependent so you can log in as root and either create another account or delete/recreate the one with the issues. I have to say that it is good to see others having the same issue. I also downloaded and installed the ATI drivers from ATI, and still have the issue.

  10. #10

    Default Re: ATI + Desktop Effects = White

    My card is an ATI x1800 Mobility Radeon. Although the default radeonhd drivers work on all Live CDs and on the Gnome Install they fail on the KDE4 Install. Leaving me with a blank black (sometimes white) screen.

    The 0=ati; 0=fglrx; 0=vesa settings do not work either. Although 0=vesa does respond to startX but fails on reboot.

    I have tried installing the latest Catalyst 8.6 drivers dated 18th June from the command prompt but that, too, fails. It balks at the point of Post Processing the Kernel Module.

    With the error message There were errors during the installation. Details can be found in

    The contents of the log:
    [Message] Kernel Module : Trying to install a precompiled kernel module.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
    ATI module generator V 2.0
    kernel includes at /usr/src/linux/include not found or incomplete
    file: /usr/src/linux/include/linux/version.h
    [Error] Kernel Module : Failed to compile kernel module - please consult readme.

    I have tried every which way now and am at the point of giving up and moving on. Everything has been tried many times over, three installs of the Catalyst 8.6 in case there was a corruption in the file, and so on.

    I have installed from the Live CD three times and from the DVD twice. The md5sums are correct for the install iso's.

    If anyone has any suggestions then I should love to hear them.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts