Results 1 to 3 of 3

Thread: How to install firefox 3.0 32bit on 64 bit machine

  1. #1
    ericchile NNTP User

    Default How to install firefox 3.0 32bit on 64 bit machine

    So I am trying to use yast to install firefox 3.0 on a 64 bit 10.3 machine.

    I setup the repository correct and when I go to install it I get all sorts of conflicts...

    Code:
    #### YaST2 conflicts list - generated 2008-06-18 09:54:00 ####
    
    MozillaFirefox cannot be installed due to missing dependencies
        There are no installable providers of libxul.so for MozillaFirefox-3.0-1.1.i586[Mozilla]
        === MozillaFirefox-3.0-1.1.i586[Mozilla] ===
            MozillaFirefox-3.0-1.1.i586[Mozilla] will be installed by the user.
            atk-32bit-1.20.0-5.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libatk-1.0.so.0)
            libgcc42-32bit-4.2.1_20070724-17.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libgcc_s.so.1(GLIBC_2.0))
        18 more...
                gtk2-32bit-2.12.0-5.4.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libgdk-x11-2.0.so.0)
                pango-32bit-1.18.2-4.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libpango-1.0.so.0)
                bash-3.2-61.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (/bin/sh)
                glibc-32bit-2.6.1-18.3.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libc.so.6)
                coreutils-6.9-43.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (coreutils == 6.9-43)
                libstdc++42-32bit-4.2.1_20070724-17.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libstdc++.so.6)
                glib2-32bit-2.14.1-4.2.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libglib-2.0.so.0)
                gconf2-2.20.0-4.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (/usr/bin/gconftool-2)
                cairo-32bit-1.4.10-25.2.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libcairo.so.2)
                desktop-file-utils-0.13-38.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (desktop-file-utils == 0.13-38)
                shared-mime-info-0.22-14.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (shared-mime-info == 0.22-14)
                nspluginwrapper-0.9.91.4-58.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libxpcom.so)
                atom:MozillaFirefox-2.0.0.14-0.1.x86_64[10.3] will be evaluated for installation (freshened) by MozillaFirefox-3.0-1.1.i586[Mozilla] (MozillaFirefox == 3.0-1.1)
                MozillaFirefox-3.0-1.1.i586[Mozilla] is needed by atom:MozillaFirefox-2.0.0.14-0.1.x86_64[10.3] (MozillaFirefox == 3.0-1.1)
                mozilla-xulrunner181-32bit-1.8.1.14-2.2.x86_64[Mozilla] provides libxul.so, but it is uninstallable.  Try installing it on its own for more details.
                mozilla-xulrunner190-1.9.0-1.1.x86_64[Mozilla] is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (mozilla-xulrunner190 >= 1.9.0-1.1)
                mozilla-nspr-32bit-4.7.1-14.1.x86_64[Mozilla] is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (libplds4.so)
            (null)
        Conflict Resolution:
            ( ) do not install MozillaFirefox
            ( ) Ignore this requirement just here
    
    #### YaST2 conflicts list END ###
    I see that all these are needed... but it looks like they are already installed when I go to install them. Any ideas?

    I can install the 64 bit version fine.. but I want JRE and Flash to work...

  2. #2
    google01103 NNTP User

    Default Re: How to install firefox 3.0 32bit on 64 bit machine

    ericchile wrote:

    >
    > So I am trying to use yast to install firefox 3.0 on a 64 bit 10.3
    > machine.
    >
    > I setup the repository correct and when I go to install it I get all
    > sorts of conflicts...
    >
    >
    > Code:
    > --------------------
    >
    > #### YaST2 conflicts list - generated 2008-06-18 09:54:00 ####
    >
    > MozillaFirefox cannot be installed due to missing dependencies
    > There are no installable providers of libxul.so for
    > MozillaFirefox-3.0-1.1.i586[Mozilla] ===
    > MozillaFirefox-3.0-1.1.i586[Mozilla] ===
    > MozillaFirefox-3.0-1.1.i586[Mozilla] will be installed by the user.
    > atk-32bit-1.20.0-5.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libatk-1.0.so.0)
    > libgcc42-32bit-4.2.1_20070724-17.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libgcc_s.so.1(GLIBC_2.0)) 18
    > more... gtk2-32bit-2.12.0-5.4.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libgdk-x11-2.0.so.0)
    > pango-32bit-1.18.2-4.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libpango-1.0.so.0)
    > bash-3.2-61.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla]
    > (/bin/sh) glibc-32bit-2.6.1-18.3.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libc.so.6) coreutils-6.9-43.x86_64
    > is needed by MozillaFirefox-3.0-1.1.i586[Mozilla] (coreutils == 6.9-43)
    > libstdc++42-32bit-4.2.1_20070724-17.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libstdc++.so.6)
    > glib2-32bit-2.14.1-4.2.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libglib-2.0.so.0)
    > gconf2-2.20.0-4.x86_64 is needed by MozillaFirefox-3.0-1.1.i586[Mozilla]
    > (/usr/bin/gconftool-2) cairo-32bit-1.4.10-25.2.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libcairo.so.2)
    > desktop-file-utils-0.13-38.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (desktop-file-utils == 0.13-38)
    > shared-mime-info-0.22-14.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (shared-mime-info == 0.22-14)
    > nspluginwrapper-0.9.91.4-58.x86_64 is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libxpcom.so)
    > atom:MozillaFirefox-2.0.0.14-0.1.x86_64[10.3] will be evaluated for
    > installation (freshened) by MozillaFirefox-3.0-1.1.i586[Mozilla]
    > (MozillaFirefox == 3.0-1.1) MozillaFirefox-3.0-1.1.i586[Mozilla] is
    > needed by atom:MozillaFirefox-2.0.0.14-0.1.x86_64[10.3] (MozillaFirefox
    > == 3.0-1.1)
    > mozilla-xulrunner181-32bit-1.8.1.14-2.2.x86_64[Mozilla] provides
    > libxul.so, but it is uninstallable. Try installing it on its own for
    > more details. mozilla-xulrunner190-1.9.0-1.1.x86_64[Mozilla] is needed
    > by MozillaFirefox-3.0-1.1.i586[Mozilla] (mozilla-xulrunner190 >=
    > 1.9.0-1.1) mozilla-nspr-32bit-4.7.1-14.1.x86_64[Mozilla] is needed by
    > MozillaFirefox-3.0-1.1.i586[Mozilla] (libplds4.so) (null) Conflict
    > Resolution: ( ) do not install MozillaFirefox ( ) Ignore this
    > requirement just here
    >
    > #### YaST2 conflicts list END ###
    >
    > --------------------
    >
    >
    > I see that all these are needed... but it looks like they are already
    > installed when I go to install them. Any ideas?
    >
    > I can install the 64 bit version fine.. but I want JRE and Flash to
    > work...
    >
    >

    2 suggestions
    1) use the tar and place it either in your home or in /opt
    2) dl the rpm and try installing it with "rpm -U Mozilla.....rpm" (no yast)
    I think you've maybe added a 586 repo on a 64bit install and yast is really
    confused

    ps - ain't no reason (other than java) to not use 64bit FF
    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

  3. #3

    Default Re: How to install firefox 3.0 32bit on 64 bit machine

    Do you have mozilla-xul-runtime-32bit installed? I had a similar problem and installation of that package solved it. I'm running 3.0 32bit right now on a 10.3 64bit installation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •