Results 1 to 4 of 4

Thread: upgrade from 10.2 to 11.0

  1. #1

    Default upgrade from 10.2 to 11.0

    I know this is a stupid question, but I'm gonna ask it anyway. I'm currently running 10.2. Would it be possible to upgrade to 11.0 by simply changing the repos in YAST to point to the 11.0 repos instead of the 10.2 repos?

  2. #2

    Default Re: upgrade from 10.2 to 11.0

    There is probably some difficult, acrane way to upgrade everything using repositories, but it's likely to be much more effort than just grabbing the torrent and re-installing. Unless you don't have a separate /home partition, in which case you'll have to back up all your data before doing an upgrade, which would be a big pain.

  3. #3
    Will Honea NNTP User

    Default Re: upgrade from 10.2 to 11.0

    oddball33 wrote:

    >
    > I know this is a stupid question, but I'm gonna ask it anyway. I'm
    > currently running 10.2. Would it be possible to upgrade to 11.0 by
    > simply changing the repos in YAST to point to the 11.0 repos instead of
    > the 10.2 repos?


    I started to do this with a machine that basically runs as a DB2 server
    here, figuring it was the safest way to keep from hosing the databases.
    Changed repos and ran zypper ref to sync. When I ran zypper dup it gave
    some unreasonable number of packages it proposed to d/l and update so I
    went to the DVD and did an update installation. There were a number of
    dependency problems with the proposed update but I took a chance
    and "ignored" them where possible and the result worked just fine. I had
    the GM DVD so I ran zypper dup on the result after adding a couple of new
    repos to coverge the dependency issues - they had changed from what I
    originally had - and the server is up and chugging. If you MUST update
    from 10.2 the basic packages will work fine but look to re-install some
    add-on apps.

    Oh, one recurring glitch in 10.2 -> 11.0 here has been Samba. If you use
    it, be prepared to uninstall the Samba packages and re-install them clean
    as the CFS module will be screwed up and unconfigurable - something is not
    getting updated in the update.

    --
    Will Honea

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: upgrade from 10.2 to 11.0

    Here's a whole bunch of opinions:
    OpenSUSE 10.3 > 11.0 - openSUSE Forums
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •