Results 1 to 6 of 6

Thread: firefox 3 has gtk+ error

  1. #1
    kevjin NNTP User

    Default firefox 3 has gtk+ error

    I just installed Firefox 3 and I keep getting this error.
    Any suggestions?

    We're sorry, this application requires a version of the GTK+ library that is not installed on your computer.

    You have GTK+ 2.8.
    This application requires GTK+ 2.10 or newer.

    Please upgrade your GTK+ library if you wish to use this application.

  2. #2
    ab@novell.com NNTP User

    Default Re: firefox 3 has gtk+ error

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Firefox doesn't have this error, it has this dependency. I am in the
    same boat on SLED 10 SP2 currently. either you will need to upgrade
    from .8 to .10 gtk2 or you will need to try a later version of opensuse
    entirely. I haven't bothered to research the gtk update because this is
    my do-everything-box and I can't risk it right now. opensuse 11
    (released tomorrow) will work with Firefox 3, though.

    Good luck.





    kevjin wrote:
    | I just installed Firefox 3 and I keep getting this error.
    | Any suggestions?
    |
    | We're sorry, this application requires a version of the GTK+ library
    | that is not installed on your computer.
    |
    | You have GTK+ 2.8.
    | This application requires GTK+ 2.10 or newer.
    |
    | Please upgrade your GTK+ library if you wish to use this application.
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIWYw/3s42bA80+9kRArJlAJ90CYCLVA/5x8HiPFPXsV7NlgCqfACfYeBa
    /No3g91IZh18NZjE1w4YwUo=
    =0tgy
    -----END PGP SIGNATURE-----

  3. #3
    kevjin NNTP User

    Default Re: firefox 3 has gtk+ error

    Thanks.
    I tried the GTK upgrades but that just caused too many other dependancy issues.
    Since I would have to upgrade the entire OS I decided to drop back to FireFox 2 since I am away from home right now.

    I hope that FF3 can ease off on the strict dependecies.

    FF3 looks good but I guess I will have to wait until upgrade my OS......why do I suddenly have flashbacks of that other O$ with all those issues.


    ---closed---

  4. #4

    Default Re: firefox 3 has gtk+ error

    Firefox now uses GTK for theme support, hence the depends hell because GTK has tons of them. No clue why the Opensuse guys backported Firefox 3 to you guys, yea it's 100% better than 2.0, but 2.0 is still stable and will have support for another year. Anyways I suggest if you can update to 11 at some time. Once you get everything set back up you would regret it.

  5. #5
    aecsysadmin NNTP User

    Default Re: firefox 3 has gtk+ error

    One workaround is to install local copies of the required libraries. You can find detailed instructions on how to do this here:

    Firefox 3, GTK and a downside of Enterprise Linux distros., 17/06/08, Mike's blag

    Ferdinand

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: firefox 3 has gtk+ error

    Quote Originally Posted by quickshade View Post
    Firefox now uses GTK for theme support, hence the depends hell because GTK has tons of them. No clue why the Opensuse guys backported Firefox 3 to you guys, yea it's 100% better than 2.0, but 2.0 is still stable and will have support for another year. Anyways I suggest if you can update to 11 at some time. Once you get everything set back up you would regret it.
    I'm not sure what you mean by backported. Any recent OpenSUSE distro will have the required gtk2 libraries. There's no backporting for a recent distro version like 10.3 or 11.0. I think even 10.2 will work if you apply the latest security updates. Alas 10.0 doesn't but I'm going to upgrade that machine's OS anyway.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •