Results 1 to 5 of 5

Thread: [Sound] Disable Pc / Motherboard Speaker

  1. #1
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    57

    Question [Sound] Disable Pc / Motherboard Speaker

    Please help me disable my most annoying laptop speakers (the one on the motherboard, not the normal speakers), before I reach for a sledgehammer. Honestly I don't understand why this is not disabled by default (in OpenSUSE 11.0, not tested with 10.3), other than waking up everybody in the house when you press CTRL+ALT+BACKSPACE in the middle of the night I see no purpose for it.

    I'd like to put this thread forward as a reference: Disable Pc / Motherboard Speaker

    But the solution presented there is not so clear for me, there the~jester suggests:
    adding set bell-style none to /etc/inputrc work.
    But /etc/inputrc is a gigantic file with lots of if statement so where to add this line and using what syntax?

    Or is there an even easier solution (via Yast)?

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,386
    Blog Entries
    34

    Default Re: [Sound] Disable Pc / Motherboard Speaker

    I would think there are many places/files where you can place the "setterm -blength" command, during the boot.

    There are also other solutions:
    HowTo: Turn off (mute) system beep « Muahahahahah

  3. #3
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    57

    Default Re: [Sound] Disable Pc / Motherboard Speaker

    Quote Originally Posted by oldcpu View Post
    I would think there are many places/files where you can place the "setterm -blength" command, during the boot.
    I guess I'll have to try that, what file can I put it in so that even when I'm in init 3 I get no system bleeps.

    There are also other solutions:
    HowTo: Turn off (mute) system beep Muahahahahah
    I tried that:
    rmmod pcspkr
    ERROR: Module pcspkr does not exist in /proc/modules

  4. #4
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    57

    Thumbs up Re: [Sound] Disable Pc / Motherboard Speaker

    The only thing relevant in my /proc/modules I can find is:
    Code:
    cat /proc/modules | grep snd
    snd_usb_audio 88704 1 - Live 0xf9552000
    snd_usb_lib 22016 1 snd_usb_audio, Live 0xf9508000
    snd_rawmidi 30208 1 snd_usb_lib, Live 0xf94ea000
    snd_pcm_oss 51968 0 - Live 0xf94b2000
    snd_mixer_oss 21120 1 snd_pcm_oss, Live 0xf9485000
    snd_seq 61376 0 - Live 0xf9491000
    snd_seq_device 12812 2 snd_rawmidi,snd_seq, Live 0xf9478000
    snd_hda_intel 374172 8 - Live 0xf99fe000
    snd_pcm 87812 5 snd_usb_audio,snd_pcm_oss,snd_hda_intel, Live 0xf9962000
    snd_timer 28424 3 snd_seq,snd_pcm, Live 0xf98f8000
    snd_page_alloc 14984 2 snd_hda_intel,snd_pcm, Live 0xf988e000
    snd_hwdep 14084 2 snd_usb_audio,snd_hda_intel, Live 0xf98b4000
    snd 67256 26 snd_usb_audio,snd_usb_lib,snd_rawmidi,snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep, Live 0xf9898000
    soundcore 11976 1 snd, Live 0xf9425000
    usbcore 152012 8 uvcvideo,snd_usb_audio,snd_usb_lib,usb_storage,usbhid,ehci_hcd,uhci_hcd, Live 0xf97ba000
    As for disabling KDE4's bleeps one has to dig into the Notifications settings via:
    Configure Desktop -> Notifications
    In "System Bell" untick "Use system bell instead of system notifications"
    In "System Notifications" And in the tab "Player Settings" say "No Audio Output" - although this doesn't seem to be saved (even in svn builds of KDE4.1 as reported here) but it seems to work nonetheless ... no beeps so far ... ahhhh the silence, so good.

  5. #5
    drye NNTP User

    Default Re: [Sound] Disable Pc / Motherboard Speaker

    To disable the speaker globally this worked for me:

    HTML Code:
    xset b off 
    xset b 0 0 0

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •