Results 1 to 2 of 2

Thread: Not mounting encrypted partition - mini howto

  1. #1

    Default Not mounting encrypted partition - mini howto

    In this forum thread,
    How not to mount Encrypted partition? - openSUSE Forums,
    I asked if there was a way to not mount an encrypted partition.

    I found the answer and wanted to share it.

    Encrypted partitions use a different file other than /etc/fstab.

    If you comment a mount point in /etc/fstab it will not get mounted, but it's password will still be prompted.

    The file to edit for encrypted partitions is
    /etc/crypttab.

    Just like /etc/fstab, /etc/crypttab has an option to not mount automatically a partition so one can have:
    cr_sdb5 /dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJDWPC42370-part5 none noauto

    That will prevent the partition from getting the password to be asked OR to have it mounted. The noauto option in /etc/fstab seems to be ignored for encrypted filesystems.

    I also discovered that if for any reason you fail to put your password in time or type in the wrong password to try to mount an encrypted partition by itself you can do:
    service boot.crypto start <entry from cryptab>

    Hope this helps someone in the future.

    [Edit]. To make more concise and correct a few minor errors.

  2. #2
    Join Date
    Jun 2008
    Location
    Johannesburg, South Africa
    Posts
    12

    Default Re: Not mounting encrypted partition - mini howto

    Hi There

    I moved from 10.3 to 11. My /home is normally crypted. I did not trust the partisoner in Yast, it asked for a password twice. So I just skipped it and added my partition like the howto.

    The only other thing I did was to add boot.crypto to the B runlevel. Only boot.crypto is needed and not boot.crypto.early. Otherwise it does not mount

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •