Results 1 to 5 of 5

Thread: Huawei 220 3G modem.

  1. #1
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    249

    Default Huawei 220 3G modem.

    Hi,

    I just installed on opensuse 10.3 a huawei 3G usb modem (3.5G actually), and just now noticed that opensuse does have a support page.

    SDB:HUAWEI E220 Support - openSUSE

    It took me a long time but now I find it simple although I did not follow any of the steps in the above howto.

    For those who still like to thinker with the prompt here goes an alternative way that I collected from this link:

    [3G_Tutorial] Huawei Card E620/E220 - Techzone

    In OpenSuSE 10.3 (64 bits) the kernel version supports the device.

    It basically says the following:

    connect to the usb the device and then make as root

    Code:
    lsubs
    after a couple of seconds a new line appears that corresponds to the modem:

    Bus 004 Device 012: ID 12d1:1003

    The ID part is the important one.

    now is a good time to for example shutdown ethernet configs ...

    make

    Code:
    ifdown eth0
    or whatever your wired/wireless connection requires.

    Now the important:

    Code:
    rmmod usb-storage && modprobe usbserial vendor=0x12d1 product=0x1003
    basically the modem is ready to run.

    I made it run with kppp and my config works for vodafone in Portugal, elsewhere some parameters obviously must change.
    It is very simple:

    The link above shows the wvdial config and it work ok.

    In the connection make a new connection with:

    *99***1#

    Authentication: PAP/CHAP

    - IP : dynamic
    - Gateway: default gateway, and check the box :
    assign the default route to this gateway
    - DNS
    Authomatic
    check: Disable existing DNS servers


    In Kppp modem section make a new modem with

    /dev/ttyUSB0
    Hardware[CRTSCTS0]
    Line termination CR
    Connection speed 460800
    Check use lock file

    - Check wait for dial tone before dialing
    busy 0sec

    - in modem commands:

    if your card requires a PIN then init1 = AT+CPIN=1324 (pin number)

    I place one of the clone sim cards I use (one for the Nokia E90 another for the huawei dongle) on the Nokia E90 and removed the PIN protection.

    init2 = ATZ

    All other parameters in this panel where default.

    Before we can dial there was one last problem:

    pppd gave an error both on kppp as well as on wvdial

    pppd unrecognized option 'passwordfd'

    I realized that all peers in /etc/ppp/peers had a call to the plugin passwordfd.so in their files except
    /etc/ppp/peers/wvdial

    So I edited /etc/ppp/peers/wvdial and placed a new line at the top:

    Code:
    plugin passwordfd.so
    after that both wvdial with the config from the initial link and kppp worked ok !

    And good friends: 3.5G Rocks ... 1.5Mb/s !!!

    Regards,
    Pedro








    First

  2. #2
    didis NNTP User

    Default Re: Huawei 220 3G modem.

    thanks pedro,your post very usefull for me

  3. #3

    Default Re: Huawei 220 3G modem.

    Hi Guys,

    i have just installed SuSE 11 and it can handle the huawei e220 very well. just plug&play! (Y)
    try it!

  4. #4
    gigglerace NNTP User

    Default Re: Huawei 220 3G modem.

    What have i missed as i am runnig a huawei 220 3G modem on my pc thru a usb hub and it did not pick it up, it is running in aus on 3 network, do i need to check anything else.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Huawei 220 3G modem.

    I originally had openSUSE 10.2 installed, and successfully manually configured my E220 with YaST's (modem utility), and controlled it via KInternet. Upon installing openSUSE11, the device was automatically detected by NetworkManager.

    What have i missed as i am runnig a huawei 220 3G modem on my pc thru a usb hub and it did not pick it up, it is running in aus on 3 network, do i need to check anything else.
    Try connecting the device directly to one of your usb ports, then if NetworkManager (I use KNetworkManager with KDE) can't see it, try running the 'lsusb' command. Post the rusults if you need more help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •