Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Synaptic Touchpad

  1. #1
    Join Date
    Jun 2008
    Location
    Finland
    Posts
    26

    Default Synaptic Touchpad

    Hello,
    i've got an Fujitsu-Siemens Si1520, after installation of live-cd opensuse 11 the mouse did work as espected but after an reboot my pointer only work's at the login screen, when the desktop is displayed my mouse pointer freezes.

    Anyone else seen this behavior?

    Help appreciated!

    Thomas

  2. #2

    Default Re: Synaptic Touchpad

    I have no idea what would cause that, but perhaps I could offer a few suggestions.

    -Does your keyboard work? As a base test, if you hit CAPS LOCK, does the keyboard light up? Can you navigate the desktop with your keyboard, such as ctrl+etc to open the menu...

    You could try booting into a more minimal mode and updating packages, that might help. If you can get into a terminal, run:

    zypper ref
    zypper dup
    zypper up

    This will likely be a huge download (1+ GB), and no guarantee of a fix. Hopefully someone with more specific knowledge will come along and help out!

  3. #3
    Join Date
    Jun 2008
    Location
    Finland
    Posts
    26

    Default Re: Synaptic Touchpad

    The keyboard works properly but the touchpad is completely dead after login

    I will try out those update commands.

    Thomas

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Synaptic Touchpad

    Could be linked to an open bug where this issue happens (mostly) after configuring the touchpad with the applet in Control Center.
    You might want to add you comments to the bug to get this fixed.

    As a workaround, so far I've only managed to 'fix' this by clearing my .gnome config files in my home directory and rebooting.

    It should be fixed in factory but I haven't tried it yet...

    See here: https://bugzilla.novell.com/show_bug.cgi?id=384028
    and here : https://bugzilla.novell.com/show_bug.cgi?id=377517

    edit: If you plug in a usb mouse you should at least have back your control...
    Have a lot of fun!

  5. #5
    Join Date
    Jun 2008
    Location
    Finland
    Posts
    26

    Default Re: Synaptic Touchpad

    Didn't help, all packages seems to be up to date.

  6. #6
    Join Date
    Jun 2008
    Location
    Finland
    Posts
    26

    Default Re: Synaptic Touchpad

    Found the problem, it was too simple to be true...
    The settings (sensitivity, acceleration) was set as default to zero in Touchpad preferences under control-center.
    I increased the speed and now it works perfectly!!!

    Thomas

  7. #7
    Join Date
    Jun 2008
    Location
    Finland
    Posts
    26

    Default Re: Synaptic Touchpad

    I've posted an workaround reply to the filed bug where others also had the same problem.

  8. #8
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Synaptic Touchpad

    Quote Originally Posted by thsundel View Post
    I've posted an workaround reply to the filed bug where others also had the same problem.
    Good to hear it had an easy fix Thanks for adding your comments!

    Cheers,
    Wj
    Have a lot of fun!

  9. #9
    Will Honea NNTP User

    Default Re: Synaptic Touchpad

    thsundel wrote:

    >
    > Found the problem, it was too simple to be true...
    > The settings (sensitivity, acceleration) was set as default to zero in
    > Touchpad preferences under control-center.
    > I increased the speed and now it works perfectly!!!


    This looks like it is happening on an update installation - many of us
    actually SET the sensitivity way low back about 10.2 just to tame the
    @#$%^& tap sensitivity. On my Toshiba, the ********** touchpad was so
    sensitive it was actually a hazard to my mental health until I manually
    mucked with it - the setup apps didn't manage to get it where it was
    usable.

    --
    Will Honea

  10. #10
    cpubus NNTP User

    Default Re: Synaptic Touchpad

    I had this problem running opensuse 11.0, and i have a synaptics touchpad. When i used the gsynaptics touchpad applet in the control panel to turn tapping off, then i rebooted or restarted teh session, the pointer was stuck. After about 3 days of messing around with this I found my problem was with the touchpad applet and gconf xml file. It seems to be that when you use the touchpad applet, the xml settings for each attribute don't get created unless you change them at least once. So the first time you configure it, if you just turn tapping off, the rest of the settings are zero because they weren't altered, and you have no movement. So to get around this, alter each attribute in the applet at least once before closing, and all the settings will be written.

    also, make sure "gsynaptics-init --sm-disable" is run when your session starts or it won't read your settings from the conf. Mine was already set up under "Touchpad" in the sessions applet.

    here is my /home/brandon/.gconf/desktop/gnome/peripherals/touchpad/%gconf.xml

    Code:
    <?xml version="1.0"?>
    <gconf>
            <entry name="sensitivity" mtime="1216866754" type="int" value="1">
            </entry>
            <entry name="coast_enable" mtime="1216866106" type="bool" value="true">
            </entry>
            <entry name="edge_motion_use_always" mtime="1214089178" type="bool" value="false">
            </entry>
            <entry name="circ_scroll_trigger" mtime="1214089062" type="int" value="5">
            </entry>
            <entry name="max_speed" mtime="1216866750" type="int" value="192">
            </entry>
            <entry name="min_speed" mtime="1216866749" type="int" value="90">
            </entry>
            <entry name="accel_factor" mtime="1216866748" type="int" value="3">
            </entry>
            <entry name="circular_scrolling" mtime="1214089176" type="bool" value="false">
            </entry>
            <entry name="circ_scroll_delta" mtime="1214089176" type="int" value="0">
            </entry>
            <entry name="horiz_scroll_delta" mtime="1216865145" type="int" value="0">
            </entry>
            <entry name="vert_scroll_delta" mtime="1216866745" type="int" value="100">
            </entry>
            <entry name="max_tap_time" mtime="1216866742" type="int" value="0">
            </entry>
            <entry name="off" mtime="1216866740" type="bool" value="false">
            </entry>
    </gconf>

    here is the device in /etc/X11/xorg.conf

    Code:
    Section "InputDevice"
      Driver       "synaptics"
      Identifier   "Mouse[3]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Emulate3Buttons" "on"
      Option       "HorizScrollDelta" "0"
      Option       "InputFashion" "Mouse"
      Option       "Name" "Synaptics;Touchpad"
      Option       "Protocol" "explorerps/2"
      Option       "SHMConfig" "on"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    Now my touchpad works perfectly, i have vertical scroll and i turned that silly tapping off, and best of all i can USE my pointer!
    Last edited by cpubus; 23-Jul-2008 at 19:51. Reason: p.s.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •