Results 1 to 7 of 7

Thread: Java JRE 1.6.0 Jar won't execute

  1. #1

    Default Java JRE 1.6.0 Jar won't execute

    I am having a problem with a Java application that I wrote on another distro. The app works on both Ubuntu 8.04 and Fedora 9 using Sun's Java, but when I try to execute it on openSuSE 10.3, I get the following:

    /usr/lib/<unknown>: No such file or directory

    I started with a clean install of openSuSE 10.3, then installed java-1_6_0-sun. Running from the command line in xterm as
    java -jar myjar.jar gives the error above.

    I also have a script tied to a Main Menu item. When I execute that way, Bug Buddy produces the following:

    System: Linux 2.6.22.5-31-default #1 SMP 2007/09/21 22:29:00 UTC i686
    X Vendor: The X.Org Foundation
    X Vendor Release: 70200000
    Selinux: No
    Accessibility: Disabled
    GTK+ Theme: Gilouche
    Icon Theme: Industrial

    Memory status: size: 222294016 vsize: 222294016 resident: 22818816 share: 12558336 rss: 35377152 rss_rlim: 421012480
    CPU usage: start_time: 1213623322 rtime: 343 utime: 218 stime: 125 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 100

    Backtrace was generated from '/usr/lib/<unknown>'

    [?1034h(no debugging symbols found)
    Using host libthread_db library "/lib/libthread_db.so.1".
    (no debugging symbols found)
    [Thread debugging using libthread_db enabled]
    [New Thread 0xb7e276c0 (LWP 23712)]
    [New Thread 0xab9b6b90 (LWP 23733)]
    ...

    I developed the app using Netbeans on another distro, so I downloaded and tried to install Netbeans on openSuSE, but I ended up with Bug Buddy reporting the same error when I tried to install.

    What is missing? Where do I get it?

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Java JRE 1.6.0 Jar won't execute

    zypper in java-1_6_0-sun-devel

    And re-try your application.

  3. #3

    Default Re: Java JRE 1.6.0 Jar won't execute

    zypper'ed java-1_6_0-sun-devel and tried again.

    Same result.

  4. #4
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Java JRE 1.6.0 Jar won't execute

    Any chance this application is available somewhere to test?

  5. #5
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: Java JRE 1.6.0 Jar won't execute


  6. #6

    Default Re: Java JRE 1.6.0 Jar won't execute

    Thanks Dave. The link you provided enabled me to get Netbeans running, and my application goes further before dying with the same error.

    Given the problems encountered, and the problems with other distros (different problems on each), I am rethinking whether Java was a good idea.

    Thanks again for the help.

    Jim

  7. #7
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: Java JRE 1.6.0 Jar won't execute

    Quote Originally Posted by hamdev View Post
    Given the problems encountered, and the problems with other distros (different problems on each), I am rethinking whether Java was a good idea.
    Jim
    In my experience with Java, it truly has been 'write once, run anywhere'
    as advertised, so I'm surprised that you're having problems.

    I'd be happy to try to fix the problem, if you want to send me
    the code. [I've been doing NetBeans java development for
    a few years.] If so, send me a private msg with details, including
    what version of NetBeans, etc.

    Cheers...
    Dave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •