Results 1 to 3 of 3

Thread: Mounting cifs qns

  1. #1

    Default Mounting cifs qns

    smbfs is replaced by cifs and I have one problem with it.

    With smbfs, I will
    e.g.


    Code:
    mount -t smbfs -o username=hero,password=zzz //server/folder /mymount


    With cifs, I am unable to use //server/folder, i can only use ip
    e.g.


    Code:
    mount -t cifs -o username=hero,password=zzz //192.168.1.1/folder /mymount


    I am able to smbclient it. But cifs does not take in //server, only IP.
    It will give me this error:



    Code:
    mount error: could not find target server. TCP name server/folder not found
    No ip address specified and hostname not found
    Is it possible to use //server instead of using IP address?
    Oh ya, I am using openSUSE 10.3

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Mounting cifs qns

    Just a thought: IP addresses get through firewalls where netbios names won't unless the required ports are opened. To test whether this is a problem for you, turn off firewalls on the Linux server and/or Linux client and try the command line mounts again. Then you'll know whether the problem lies in letting netbios names through the firewall/s

    Swerdna
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3

    Default Re: Mounting cifs qns

    did you enable nmbd?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •