Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: microphone doesn't work

  1. #1

    Angry microphone doesn't work

    Hi,
    my microphone doesn't work! I checked alsamixer and Kmix for enabling mic but it didn't help. All toggles for input are red colored in Kmix. It seems to be hardware problem? I checked google but without any progress.

    I installed openSuse 11 beta3 32 bit. My laptop is HP Compaq 6715b. I did all updates. Command "lspci -v" showed follows:
    Audio device: ATI Technologies Inc SBx00 Azalia
    Subsystem: Hewlett-Packard Company Device 30c2
    Flags: bus master, slow devsel, latency 64, IRQ 16
    Memory at 8c000000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

    Please can somebody help me? Because of skype I have to go to windows :-( all the time.
    Thanx

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: microphone doesn't work

    Quote Originally Posted by liborp View Post
    my microphone doesn't work! .....Please can somebody help me? Because of skype I have to go to windows Thanx
    I can not help with skype. I never use it.

    Did you try to get your mic to work with anything OTHER than skype?

    To help provide more information, can you please run the diagnostic scripts from the audio troubleshooting guide, and post here the output URL(s) that they provide:
    Scripts_to_run_to_obtain_detailed_information

    also please provide the output of:
    cat /etc/modprobe.d/sound

  3. #3
    Join Date
    Jun 2008
    Location
    NSW, Australia
    Posts
    55

    Default Re: microphone doesn't work

    Oldcpu, I don't use skype either but I was able to get the mike going with it some time back by enabling full duplex in kcontrol sound setup. Skype appears to require this setting. If this does not help, then the problem is more fundamental.
    Last edited by watagan; 15-Jun-2008 at 05:43. Reason: grammar

  4. #4

    Default Re: microphone doesn't work

    Thank you for quick reply!
    I tried mic in KRecord as well, but no sound was recorded. What other appl shall I try?
    Result of tsalsa is on tsalsa.txt - nopaste.com (beta)
    Unfortunately the script alsa-info.sh haven't returned url link. So I used debug mode and generated txt file. But don't know how to enclose this file to thread? Or shall I put the content directly by copy&paste?
    And finally cmd cat /etc/modprobe.d/sound generated this:
    options snd slots=snd-hda-intel
    # 5Dex.P+U_9rQw5R1:SBx00 Azalia
    alias snd-card-0 snd-hda-intel

    I hope this helped

  5. #5

    Default Re: microphone doesn't work

    Hi
    its finally works!!I've just done what watagan suggested! I tried make Skype test call and worked as well! Many thanks watagan.

    But strange thing. When I checked mixer, the toggles in Input and Switches tabs are still red. I tried them switch on/off but still the same. Is it the problem? Shall be I worried about it?


    (I didn't believe that I can so quickly resolve my problem by posting it to openSuse forum!)

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: microphone doesn't work

    Quote Originally Posted by liborp View Post
    Result of tsalsa is on tsalsa.txt - nopaste.com (beta)
    Glad its working now. Well done watagan on your suggestion.

    Reference the remaining problems, from the script I see you have an AD1981. You can try apply one of the model options to that, which are basic(default), hp, thinkpad, and toshiba. You could try change your /etc/modprobe.d/sound file to:
    Code:
    options snd slots=snd-hda-intel model=hp
    # 5Dex.P+U_9rQw5R1:SBx00 Azalia
    alias snd-card-0 snd-hda-intel
    Then restart alsa from a konsole with root permissions with: rcalsasound restart

  7. #7

    Default Re: microphone doesn't work

    I've tried put the "model" attribute but for all values (that you mentioned) I've received same error:

    Starting sound driver: hda-intelWARNING: Error inserting snd (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_hwdep (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd-hwdep.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_timer (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_pcm (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    Any other idea?
    Thanx

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: microphone doesn't work

    Quote Originally Posted by liborp View Post
    I've tried put the "model" attribute but for all values (that you mentioned) I've received same error:.......... sipped .....Any other idea?
    Maybe ...

    Can you provide me the output of:
    rpm -qa | grep alsa
    rpm -q libasound2

  9. #9

    Default Re: microphone doesn't work

    rpm -qa | grep alsa:
    alsa-utils-1.0.16-34
    alsa-oss-1.0.15-47
    alsa-plugins-1.0.16-55
    alsa-plugins-pulse-1.0.16-55

    rpm -q libasound2:
    libasound2-1.0.16-37

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: microphone doesn't work

    Quote Originally Posted by liborp View Post
    I've tried put the "model" attribute but for all values (that you mentioned) I've received same error:
    Can you try the model I suggested again in the /etc/modprobe.d/sound file, but this time give me the EXACT syntax you used. ie copy and paste:
    cat /etc/modprobe.d/sound
    even the slightest syntax error will cause a failure. I want to check your syntax.

    Also, don't forget you need to restart alsa after doing that edit, with:
    rcalsasound restart

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •