Results 1 to 7 of 7

Thread: Sound Blaster X-Fi error

Threaded View

  1. #1
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Question Sound Blaster X-Fi error

    Hello all,

    First of all nice job on the forums.
    I have a little problem with my X-fi. It was working fine till my hard drive died. I had just deleted my backup with view of making a new one but hadn't. Typical, I know

    Anyways, a new hard drive and instalation later I cannot get my X-fi to work. I noticed something worrying in Dmesg:

    Code:
    emupia: no version for "InterlockedIncrement" found: kernel tainted.
    ctalsa: disagrees about version of symbol snd_pcm_lib_free_pages
    ctalsa: Unknown symbol snd_pcm_lib_free_pages
    ctalsa: disagrees about version of symbol snd_pcm_set_ops
    ctalsa: Unknown symbol snd_pcm_set_ops
    ctalsa: disagrees about version of symbol snd_device_new
    ctalsa: Unknown symbol snd_device_new
    ctalsa: disagrees about version of symbol snd_card_new
    ctalsa: Unknown symbol snd_card_new
    ctalsa: disagrees about version of symbol snd_pcm_hw_constraint_integer
    ctalsa: Unknown symbol snd_pcm_hw_constraint_integer
    ctalsa: disagrees about version of symbol snd_pcm_lib_preallocate_free_for_all
    ctalsa: Unknown symbol snd_pcm_lib_preallocate_free_for_all
    ctalsa: disagrees about version of symbol snd_pcm_lib_ioctl
    ctalsa: Unknown symbol snd_pcm_lib_ioctl
    ctalsa: disagrees about version of symbol snd_pcm_lib_malloc_pages
    ctalsa: Unknown symbol snd_pcm_lib_malloc_pages
    ctalsa: disagrees about version of symbol snd_pcm_lib_preallocate_pages_for_all
    ctalsa: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
    ctalsa: disagrees about version of symbol snd_ctl_remove
    ctalsa: Unknown symbol snd_ctl_remove
    ctalsa: disagrees about version of symbol snd_card_free
    ctalsa: Unknown symbol snd_card_free
    ctalsa: disagrees about version of symbol snd_ctl_free_one
    ctalsa: Unknown symbol snd_ctl_free_one
    ctalsa: disagrees about version of symbol snd_pcm_hw_constraint_minmax
    ctalsa: Unknown symbol snd_pcm_hw_constraint_minmax
    ctalsa: disagrees about version of symbol snd_ctl_add
    ctalsa: Unknown symbol snd_ctl_add
    ctalsa: disagrees about version of symbol snd_pcm_new
    ctalsa: Unknown symbol snd_pcm_new
    ctalsa: disagrees about version of symbol snd_pcm_period_elapsed
    ctalsa: Unknown symbol snd_pcm_period_elapsed
    ctalsa: disagrees about version of symbol snd_card_register
    ctalsa: Unknown symbol snd_card_register
    ctalsa: disagrees about version of symbol snd_ctl_new1
    ctalsa: Unknown symbol snd_ctl_new1
    The Tainted Kernel bit in the first line worries me. Do I need to reinstall my kernel?
    I think I have all the Alsa things and the driver compiled fine.

    Code:
    alsa-utils-1.0.17rc1.git20080610-1.1
    alsa-oss-1.0.14-23
    alsa-firmware-1.0.17rc1.git20080610-4.1
    alsa-tools-1.0.17rc1.git20080610-2.1
    alsa-plugins-1.0.14-41
    alsa-1.0.17rc1.git20080610-1.1
    alsa-driver-kmp-default-1.0.16.20080613_2.6.22.17_0.1-1.3
    Can anyone just give me advice before I do something wrong to my kernel? Thanks
    Last edited by Dexter1979; 15-Jun-2008 at 02:32. Reason: Spelling :)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •