Results 1 to 5 of 5

Thread: Wireless LAN peripherals compatibility with 11.0

  1. #1
    lordofdestiny NNTP User

    Default Wireless LAN peripherals compatibility with 11.0

    My notebook's Broadcom BCM94311MCG chip refuses to work with the standard driver, and behaves strangely in WPA networks with ndiswrapper. Therefore, I'm looking for an external substitute. Do you know wireless LAN peripherals which work in 11.0 out of the box?

  2. #2
    Join Date
    Jun 2008
    Location
    Germany [Starlsund]
    Posts
    10

    Default Re: Wireless LAN peripherals compatibility with 11.0

    Works see :

    Code:
    01: PCI 300.0: 0282 WLAN controller
      [Created at pci.310]
      UDI: /org/freedesktop/Hal/devices/pci_14e4_4311
      Unique ID: y9sn.wZtoJ4c7zyA
      Parent ID: qnJ_.iXEd68VX6l3
      SysFS ID: /devices/pci0000:00/0000:00:0d.0/0000:03:00.0
      SysFS BusID: 0000:03:00.0
      Hardware Class: network
      Model: "Broadcom BCM94311MCG wlan mini-PCI"
      Vendor: pci 0x14e4 "Broadcom"
      Device: pci 0x4311 "BCM94311MCG wlan mini-PCI"
      SubVendor: pci 0x103c "Hewlett-Packard Company"
      SubDevice: pci 0x1375
      Revision: 0x02
      Driver: "b43-pci-bridge"
      Driver Modules: "ssb"
      Device File: wlan0
      Features: WLAN
      Memory Range: 0xf6000000-0xf6003fff (rw,non-prefetchable)
      IRQ: 19 (no events)
      HW Address: 00:1a:73:ab:af:2f
      WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
      WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
      WLAN encryption modes: WEP40 WEP104 TKIP CCMP
      WLAN authentication modes: open sharedkey wpa-psk wpa-eap
      Module Alias: "pci:v000014E4d00004311sv0000103Csd00001375bc02sc80i00"
      Driver Info #0:
        Driver Status: ssb is active
        Driver Activation Cmd: "modprobe ssb"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #12 (PCI bridge)
    using firmware RPMs for Broadcom can be found here :

    Index of /repositories/home:/schmolle1980/openSUSE_11.0/noarch

    Have Fun :-)
    HP Pavilion dv2899eg MTV-Edition openSuse 10.3 KDE 3.5.9 Kernel-2.6.25.6-1-default.x86_64

  3. #3
    lordofdestiny NNTP User

    Default Re: Wireless LAN peripherals compatibility with 11.0

    Thank you very much; the chip is now recognized correctly. Currently, I cannot proof whether WPA works but at least WEP works.

  4. #4

    Default Re: Wireless LAN peripherals compatibility with 11.0

    I couldn't get my Broadcom chip to work under Kubuntu 8.04 so I got a D-Link DWA-652 and it worked like a charm with ndiswrapper and the driver that came with the card. I see that there's a newer broadcom RPM though and I think I'll try it again. Can you post instructions or a link to current instructions please?

  5. #5

    Default Re: Wireless LAN peripherals compatibility with 11.0

    Nevermind. I found b43 - Linux Wireless and so will try to follow that. Does help to peruse the forums and sticky stuff for a bit first.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •