Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: graphic card

  1. #1
    morteza1358 NNTP User

    Unhappy graphic card

    i enable 3D acceleration but after update graphic card i got problem

    i can't run xserver

    failed to load the nvidia kernel module

    after that i updated my graphic card with NVIDIA-Linux-x86-173.14.05-pkg1.run package from nvidia website then i run init 5 and

    succeed to login normally

    but i think it's not a good driver for my graphic card because it's very slowly

    then i chane the resolution to 1024*768 but when i login ,it goes white

    how to return it to default resolution with default graphic card

    graphic crad:GeForce FX 5200 128MB

  2. #2
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: graphic card

    The GeForce 5200 series may be covered by the legacy driver, not the new one. There are two branches of the Nvidia driver.

  3. #3
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: graphic card

    You can find the list of Nvidia Latency Cards on the OpenSUSE Wiki. The top of that page also gives you the command for the hardware information for your card, so that might help you get more information on your card. If you do find that you have a latency card, the Nvidia Page has the latency drivers on the second part of the Easy Way section.

    As for your question about changing the resolution to a different setting: when you get to the splash screen that has the options for booting into SUSE (or Windows if you have a dual boot), cursor (the dark bar) over your OpenSUSE option and type 3 and then hit the enter key. This will load your CLI (Command Line Interface). Once all your system options finish loading, type your username and hit enter, and then type your password for your username and hit enter. After that, type su and then enter the root password. Now that you are logged in as root, type sax2 and hit enter. This will bring up your graphic card screen, and here you can change your graphic card information, as well as your resolution. Once you like the settings you have entered, click the Accept/OK button. Now type exit and then startx into the command terminal. This will load your graphic interface.

    Now, about the drivers, you can check which drivers you have installed in YaST through the command terminal as well. Load the terminal when you load SUSE (as mentioned above) and then login with your username and then as root (again, as above). Now type yast2 and YaST will load. Use your arrow keys to find Software Management under the Software section in the left column. Hit enter. Once your repositories are done loading, hit F1 to find the F-key commands. Hit the search key that you found in help and search nvidia (hit enter). Now you can see which packages you have installed for your drivers.

    Sorry for the long post, but hope that solves your problem.

    (NOTE: Always use Sax2 to configure your card when you install a new driver)

    Folding@Home
    Help save lives with Folding@Home

  4. #4

    Default Re: graphic card

    For NVidia cards, I recommend you use the tool NVidia ships with their drivers. You can launch it by typing "/usr/bin/nvidia-settings" in a console window, although it should be available in the openSUSE menu thing.
    It should look like this:

  5. #5
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: graphic card

    morteza1358 wrote:

    >
    > i enable 3D acceleration but after update graphic card i got problem
    >
    > i can't run xserver
    >
    > failed to load the nvidia kernel module
    >
    > after that i updated my graphic card with
    > NVIDIA-Linux-x86-173.14.05-pkg1.run package from nvidia website then i
    > run init 5 and
    >
    > succeed to login normally
    >
    > but i think it's not a good driver for my graphic card because it's
    > very slowly
    >
    > then i chane the resolution to 1024*768 but when i login ,it goes
    > white
    >
    > how to return it to default resolution with default graphic card
    >
    > graphic crad:GeForce FX 5200 128MB
    >
    >

    I'm using openSUSE 11.0 GM, Nvidia FX5200. I used Yast to install the rpm
    package from http://download.nvidia.com/opensuse/11.0. All my graphics
    appear to be working fine including the 3D.

    Hope this helps.
    --
    Russ
    Linux register user 441463

  6. #6

    Default Re: graphic card

    hi

    i did them but i can't login normally

    i can't run xserver or startx

    how to rollback to default graphic card that suse comes up first time

    when i run vi xorg.config,i can't see any config on it or any text about my graphic card

  7. #7
    Join Date
    Jun 2008
    Location
    Central Pa. , USA
    Posts
    94

    Default Re: graphic card

    At the boot splash, on the line type 3 and hit enter.

    Type root and enter root password.

    then type this.
    sax2 -r -a -m 0=nv
    Configure and be sure to TEST.

    exit and reboot.

    It's will be just the NV driver.
    Inquiring minds want to know?

  8. #8

    Default Re: graphic card

    HI:
    I have the same problem with the graphic card e-GeForce FX5200 in openSUSE 11.0. I did both procedures: Configuring with Yast and nvidia repositories and running sh NVIDIA-Linux-x86-173.14.09-pkg.1.run -q. For both sax2 responds with error: died at /usr/share/init.pl line 653.
    Besides, the file xorg.conf does not contain any information about the card.
    In the same machine Windows xp does not have problem working with the card.
    I suspect the problem is related with the presence of an unused onboard graphic card I have. This unused card is a PCI onboard card, the GeForce is also a PCI card.
    I intended to instruct the bios not to use the onboard card without success. In fact my bios has not clearly stated how to declare active only the pci card Geforce which is installed into the upper pci slot.
    Provisionally, to access openSUSE 11.0, I boot on "failsafe" which works fairly well despite the problem with the card.
    Any suggestion will be useful.
    Thanks.

  9. #9
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: graphic card

    Have you tried using the OpenSUSE package for the Nvidia driver found on the OpenSUSE Wiki (found here if you need to reference it)? I checked the latency list for the drivers and yours is a normal card, so the first button, the green one, for 1-click install would be the one you can install. I used to use the driver from the Nvidia website, but found that the one from the OpenSUSE Wiki is more supported and has had less problems related to it (at least in my own experience). Once you install the 1-click install driver (YaST will walk you through it), open a terminal window and login as a SuperUser using the su command and entering your root password. Once you have logged in as root, issue the command sax2 -r. After some loading, Sax2 should load and all your graphics configuration settings should be presented. If Sax2 doesn't load, try to see if you were alerted to refer to any error files. If you were, open a terminal window and enter the command cat followed by the location of the error file to have the contents of the file presented in the terminal. If there are any errors in the file, they should be near the bottom of the file (if you want to exit the file, press the q button on your keyboard to exit).

    Sorry for the long post, but I hope it helps.

    Folding@Home
    Help save lives with Folding@Home

  10. #10

    Default Re: graphic card

    Dear l'artigiano:

    I followed your instructions and used the Opensuse wiki and made the 1-click install without success. In fact the installation looks OK but sax2 -r fails. The output of sax2 -r is:
    *** buffer overflow detected ***: /usr/sbin/sysp terminated

    After, the following:
    ======= Backtrace: =========
    /lib/libc.so.6(__fortify_fail+0x48)[0xb7ac14c8]
    /lib/libc.so.6[0xb7abf500]
    /lib/libc.so.6[0xb7abe79d]
    ...
    ...and a long text with a final row:
    Died at /usr/share/sax/init.pl line 653.

    Do you have some suggestion?
    Thanks!.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •