Results 1 to 10 of 10

Thread: Zypper problems after fresh install.

  1. #1

    Default Zypper problems after fresh install.

    I just installed OS 10.3 on a desktop, and there was a problem with zypper during installation. Now my updater isn't working at all.
    It has a pop up that reads the following:
    "Can't launch zypp-checkpatches-wrapper helper program. Make sure zypper package is installed and working."
    What would be the easiest way to fix this problem, just go through yast and reinstall zypper?
    Also, is Smart package manager recommended over zypper? Cand smart be configured to auto install updates?

    Hmm...that's odd, yast doesn't even show zypper being installed.

    HP Pavillion DV7-1273cl, 4GB RAM, 500GB HDD, Intel Core2Duo 2.2Ghz, Intel Pro Wireless N, 512MB GeForce 9700, 64bit Linux Mint 8 and 64bit openSuSE 11.2

  2. #2

    Default Re: Zypper problems after fresh install.

    OK, Iinstalled zypper & now when I update I get this:

    Failed to mount cd:///?devices=/dev/sr0,/dev/sr1 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found) Problem downloading the package file from the repository: Failed to mount cd:///?devices=/dev/sr0,/dev/sr1 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found) Please, see the above error message to for a hint.

    Any ideas?

    HP Pavillion DV7-1273cl, 4GB RAM, 500GB HDD, Intel Core2Duo 2.2Ghz, Intel Pro Wireless N, 512MB GeForce 9700, 64bit Linux Mint 8 and 64bit openSuSE 11.2

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Zypper problems after fresh install.

    Quote Originally Posted by barryhenry76 View Post
    I just installed OS 10.3 on a desktop, and there was a problem with zypper during installation
    This should not happen. It suggests to me either:
    * bad installation CD/DVD or
    * CD/DVD reader is old and failing, or is new and failing.
    IMHO a re-install is best, with a good CD/DVD and/or with a CD/DVD reader that is not failing.

    Quote Originally Posted by barryhenry76 View Post
    Also, is Smart package manager recommended over zypper?
    This tends to be subjective. I like bananas, someone else likes oranges.

    I prefer smart in 10.3 because:
    a. smart is faster than zypper in 10.3
    b. smart can easily install off the hard drive in 10.3, while that is difficult for zypper in 10.3 (as for zypper the directory must first be made a repos),
    c. smart can keep a copy on its hard drive of the installed rpm, and zypper can not,
    d. smart has more display options (command line, shell, GUI) while zypper does not

    Quote Originally Posted by barryhenry76 View Post
    Can smart be configured to auto install updates?
    I am not a believer in auto updates. My rather subjective and biased view is "auto update" are a windows perspective that has migrated over to Linux. My view is Linux users should be on top of what their updates are. Of course my view is also contrary to the view of what could be the majority, who want the masses to move to Linux (and where the masses don't want to manually control their updates). .... So I won't debate a losing argument for me! Anyway, I simply don't know if smart can be configured to do that, because I never tried.

    Quote Originally Posted by barryhenry76 View Post
    Hmm...that's odd, yast doesn't even show zypper being installed.
    Check the rpm database. Type:
    rpm -q zypper

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Zypper problems after fresh install.

    Quote Originally Posted by oldcpu View Post
    I prefer smart in 10.3 because:
    Just a further note .... zypper has been improved significantly in 11.0, where in 11.0:
    a. zypper is faster than smart,
    b. zypper uses less memory than smart
    c. zypper (like smart) can install off of the hard drive easily,
    d. smart still can save/keep rpms on the hard drive (after an install), and zypper can not.

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Zypper problems after fresh install.

    Quote Originally Posted by oldcpu View Post
    Just a further note .... zypper has been improved significantly in 11.0, where in 11.0:
    a. zypper is faster than smart,
    b. zypper uses less memory than smart
    c. zypper (like smart) can install off of the hard drive easily,
    d. smart still can save/keep rpms on the hard drive (after an install), and zypper can not.
    Not sure about this but one new feature in zypper is also to keep packages within the cache ( the -k / -K options)? I will have a go at this to test seeing it's not clear to me what is meant with it, but if true point d would also be resolved with the new version.

    More info on switches here:
    Zypper/Changes/11.0 - openSUSE


    Cheers,

    Wj
    Have a lot of fun!

  6. #6

    Default Re: Zypper problems after fresh install.

    Magic31, you're right : zypper can save rpm on hard drive on 11.0

    However, smart can still do some things zypper can't do for the moment : parallelizing downloads, which allow to download all stuffs in a one way, then install all rpms.

    This features will be added in a couple of weeks/months, some discussion have already started about this on zypp-devel mailling list.
    Last edited by Spyhawk; 15-Jun-2008 at 03:17. Reason: typo :)

  7. #7

    Default Re: Zypper problems after fresh install.

    Quote Originally Posted by Spyhawk View Post
    Magic31, you're right : zypper can save rpm on hard drive on 11.0

    However, smart can still do some things zypper can't do for the moment : parallelizing downloads, which allow to download all stuffs in a one way, then install all rpms.
    I don't think I fully understand what you mean by that...parallelizing?

    HP Pavillion DV7-1273cl, 4GB RAM, 500GB HDD, Intel Core2Duo 2.2Ghz, Intel Pro Wireless N, 512MB GeForce 9700, 64bit Linux Mint 8 and 64bit openSuSE 11.2

  8. #8
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Zypper problems after fresh install.

    Quote Originally Posted by barryhenry76 View Post
    I don't think I fully understand what you mean by that...parallelizing?
    parallel downloading, having multiple download streams working at once so it can speed up the process and download continues while a package is also being installed.
    Have a lot of fun!

  9. #9

    Default Re: Zypper problems after fresh install.

    ooo...sounds exciting, how does one go about doing that??

    HP Pavillion DV7-1273cl, 4GB RAM, 500GB HDD, Intel Core2Duo 2.2Ghz, Intel Pro Wireless N, 512MB GeForce 9700, 64bit Linux Mint 8 and 64bit openSuSE 11.2

  10. #10
    Join Date
    Apr 2009
    Location
    Boston
    Posts
    6

    Default Re: Zypper problems after fresh install.

    Hey,

    I am a newbie to OpenSUSE, so please forgive my lack of knowledge... This is also my first post ever on this website...

    Anyways, I was attempting to use zypper to install VLC when I got a similar error message:
    failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on /dev/sr1)

    The problem was very simple to solve. Simply insert the OpenSUSE install DVD and try again. It worked for me!

    Good Luck,
    -Justin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •