Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: how to disable ping in 10.3

  1. #1
    DenverD NNTP User

    Default how to disable ping in 10.3

    i know this must have been asked a thousand times...but, neither google
    nor <http://forums.opensuse.org/search.php> finds the answer:

    how do i disable ping replies in openSuSE 10.3??

    (i found the spot in YaST to disable ping in 10.1, but can't remember
    how, now..)

    tia

    DenverD

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: how to disable ping in 10.3

    If you're using SuSEfirewall2, take a look at /etc/sysconfig/SuSEfirewall2 and find:

    ## Type: yesno
    ## Default: yes
    #
    # 19.)
    # Allow the firewall to reply to icmp echo requests
    #
    # defaults to "no" if not set
    #
    FW_ALLOW_PING_FW="no"

    And restart the service.

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: how to disable ping in 10.3

    Chrysantine wrote:
    > If you're using SuSEfirewall2, take a look at
    > /etc/sysconfig/SuSEfirewall2 and find:
    >
    > ## Type: yesno
    > ## Default: yes
    > #
    > # 19.)
    > # Allow the firewall to reply to icmp echo requests
    > #
    > # defaults to "no" if not set
    > #
    > FW_ALLOW_PING_FW="no"
    >
    > And restart the service.


    i'm stumped as this does not stop the ping:
    ..
    ..
    # defaults to "no" if not set
    #
    FW_ALLOW_PING_FW="no"


    and, neither does this:
    ..
    ..
    # defaults to "no" if not set
    #
    #FW_ALLOW_PING_FW="no"


    what next?

    DenverD

  4. #4
    Theo v. Werkhoven NNTP User

    Default Re: how to disable ping in 10.3

    The carbonbased lifeform DenverD inspired
    opensuse.org.help.network-internet with:
    > i know this must have been asked a thousand times...but, neither google
    > nor <http://forums.opensuse.org/search.php> finds the answer:
    >
    > how do i disable ping replies in openSuSE 10.3??


    echo "net.ipv4.icmp_echo_ignore_all = 1" >>/etc/sysctl
    /sbin/sysctl -p /etc/sysctl.conf

    Or, for one time only:
    echo 1 >/proc/sys/net/ipv4/icmp_echo_ignore_all"


    $su -c "echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_all "
    Password:
    [ferrets4me] theo:/home/theo
    $ping localhost
    PING localhost (127.0.0.1) 56(84) bytes of data.

    --- localhost ping statistics ---
    4 packets transmitted, 0 received, 100% packet loss, time 3010ms

    [ferrets4me] theo:/home/theo
    $su -c "echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all "
    Password:
    [ferrets4me] theo:/home/theo
    $ping localhost
    PING localhost (127.0.0.1) 56(84) bytes of data.
    64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.087 ms
    64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.099 ms

    Theo
    --
    theo at van-werkhoven.nl ICQ:277217131 SuSE Linux
    linuxcounter.org: 99872 Jabber:muadib at jabber.xs4all.nl AMD XP3000+ 1024MB
    "ik _heb_ niets tegen Microsoft, ik heb iets tegen
    de uitwassen *van* Microsoft"

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: how to disable ping in 10.3

    Theo v. Werkhoven wrote:
    >> i know this must have been asked a thousand times...but, neither google
    >> nor <http://forums.opensuse.org/search.php> finds the answer:
    >>
    >> how do i disable ping replies in openSuSE 10.3??

    >
    > echo "net.ipv4.icmp_echo_ignore_all = 1" >>/etc/sysctl
    > /sbin/sysctl -p /etc/sysctl.conf

    <snip>
    > Theo


    THANKS Theo....but, just in case, could you tell me how to, after using
    that, the magic incantation to once again allow ping..

    tia,
    DenverD

  6. #6
    ab@novell.com NNTP User

    Default Re: how to disable ping in 10.3

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Either remove the line you added and re-run the sysctl command or use
    the opposite of the command given previously:

    echo 0 >/proc/sys/net/ipv4/icmp_echo_ignore_all #run as 'root' of course

    Good luck.





    DenverD wrote:
    | Theo v. Werkhoven wrote:
    |>> i know this must have been asked a thousand times...but, neither
    |>> google nor <http://forums.opensuse.org/search.php> finds the answer:
    |>>
    |>> how do i disable ping replies in openSuSE 10.3??
    |>
    |> echo "net.ipv4.icmp_echo_ignore_all = 1" >>/etc/sysctl
    |> /sbin/sysctl -p /etc/sysctl.conf
    | <snip>
    |> Theo
    |
    | THANKS Theo....but, just in case, could you tell me how to, after using
    | that, the magic incantation to once again allow ping..
    |
    | tia,
    | DenverD
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIVKiX3s42bA80+9kRAhIFAJ4gimphPKFZXyX40yxQkgSatzSwXwCggNcZ
    IHIn7Hd4P5cv0kQdXxKA67s=
    =r0du
    -----END PGP SIGNATURE-----

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: how to disable ping in 10.3

    hmmmm...no workie:

    DenverD@Texan:~> su -
    Password:
    linux103-32:~ # echo "net.ipv4.icmp_echo_ignore_all = 1"
    >>/etc/sysctl/sbin/sysctl -p /etc/sysctl.conf

    -bash: /etc/sysctl/sbin/sysctl: No such file or directory

    now what??

    Denver
    ps: for anyone who might know; why the HECK is it not possible in
    YaST??? is this the OS giving, or taking away choice (all of a
    sudden--i'm pretty sure i did it in v9.x, through less than v10.3)



    ab@novell.com wrote:
    > Either remove the line you added and re-run the sysctl command or use
    > the opposite of the command given previously:
    >
    > echo 0 >/proc/sys/net/ipv4/icmp_echo_ignore_all #run as 'root' of course
    >
    > Good luck.
    >
    >
    >
    >
    >
    > DenverD wrote:
    > | Theo v. Werkhoven wrote:
    > |>> i know this must have been asked a thousand times...but, neither
    > |>> google nor <http://forums.opensuse.org/search.php> finds the answer:
    > |>>
    > |>> how do i disable ping replies in openSuSE 10.3??
    > |>
    > |> echo "net.ipv4.icmp_echo_ignore_all = 1" >>/etc/sysctl
    > |> /sbin/sysctl -p /etc/sysctl.conf
    > | <snip>
    > |> Theo
    > |
    > | THANKS Theo....but, just in case, could you tell me how to, after using
    > | that, the magic incantation to once again allow ping..
    > |
    > | tia,
    > | DenverD


  8. #8
    Theo v. Werkhoven NNTP User

    Default Re: how to disable ping in 10.3

    The carbonbased lifeform DenverD inspired
    opensuse.org.help.network-internet with:
    > Theo v. Werkhoven wrote:
    >>> i know this must have been asked a thousand times...but, neither google
    >>> nor <http://forums.opensuse.org/search.php> finds the answer:
    >>>
    >>> how do i disable ping replies in openSuSE 10.3??

    >>
    >> echo "net.ipv4.icmp_echo_ignore_all = 1" >>/etc/sysctl
    >> /sbin/sysctl -p /etc/sysctl.conf

    ><snip>
    >> Theo

    >
    > THANKS Theo....but, just in case, could you tell me how to, after using
    > that, the magic incantation to once again allow ping..


    Try to read the whole reply next time.

    <quote>
    $su -c "echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all "
    *^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^*
    </quote>

    Theo
    --
    theo at van-werkhoven.nl ICQ:277217131 SuSE Linux
    linuxcounter.org: 99872 Jabber:muadib at jabber.xs4all.nl AMD XP3000+ 1024MB
    "ik _heb_ niets tegen Microsoft, ik heb iets tegen
    de uitwassen *van* Microsoft"

  9. #9
    Theo v. Werkhoven NNTP User

    Default Re: how to disable ping in 10.3

    The carbonbased lifeform DenverD inspired
    opensuse.org.help.network-internet with:
    > hmmmm...no workie:
    >
    > DenverD@Texan:~> su -
    > Password:
    > linux103-32:~ # echo "net.ipv4.icmp_echo_ignore_all = 1"
    > >>/etc/sysctl/sbin/sysctl -p /etc/sysctl.conf

    > -bash: /etc/sysctl/sbin/sysctl: No such file or directory


    Where the fsck did you get that from?
    There were two lines, one with:
    echo "net.ipv4.icmp_echo_ignore_all = 1" >>/etc/sysctl
    (my bad, should have been: '>>/etc/sysctl.conf', see sysctl(8) )

    And another with:
    /sbin/sysctl -p /etc/sysctl.conf

    Of course these must be given as two seperate commands, or seperated by
    ';' or '&&' at least.

    Theo
    --
    theo at van-werkhoven.nl ICQ:277217131 SuSE Linux
    linuxcounter.org: 99872 Jabber:muadib at jabber.xs4all.nl AMD XP3000+ 1024MB
    "ik _heb_ niets tegen Microsoft, ik heb iets tegen
    de uitwassen *van* Microsoft"

  10. #10
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: how to disable ping in 10.3

    > Try to read the whole reply next time.
    >
    > <quote>
    > $su -c "echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all "
    > *^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^*
    > </quote>


    thanks Theo, but i don't actually need your smart-alec remark ...see, i
    don't know enough about it to KNOW what you MEANT to type...i *guess*
    you MEANT to say:

    to turn ping back on, issue this one as root:

    $su -c "echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_all "


    but, you didn't say that, and i can neither read your mind NOR fill in
    the blank spaces you left...

    so, thanks anyway

    DenverD

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •