Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: KDE4 OpenSuSe Updater error 'kdesu no reply'

  1. #1
    Join Date
    Jun 2008
    Location
    Frankfurt, Germany
    Posts
    13

    Default KDE4 OpenSuSe Updater error 'kdesu no reply'

    Anytime I want to install updates with my OpenSuSe updater it gives my following error message, after I gave root password:



    /usr/src/packages/BUILD/kdelibs-4.0.4/kdesu/client.cpp : 196 no reply from daemon

    somewhere else I read that it works when starting updater as root..

    Is there a some way to have it as normal user?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,171

    Default Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    It si,ply says that the other side gives no answer. Are you sure this is still a valid repro?
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,171

    Default Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    Sorry, I am a bit to quick.

    IMHO you do run is as root because you gave the root password it asked for.

    And no, this can only be run as root. You do not want every single user to install things I hope.

    BTW the updater applet has some problems since a few weeks. When you want to update security updates just use YaST > Online update (and it will ask for the root password).
    Henk van Velden

  4. #4
    j_w_lloyd NNTP User

    Thumbs up Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    I have also been seeing this recently. However, in checking the installed software, it looks as if the updates happen OK. The updater is just expecting some final message that the system doesn't send any more.

  5. #5
    Join Date
    Jul 2008
    Location
    Nanjing, China
    Posts
    78

    Default Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    Yeah, I'm getting it as well. Writing in to verify.

  6. #6

    Default Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    I've gotten this starting today, but only if I select all packages. If I select a large amount of packages to install. If there's just a couple at a time, there's no error message.

    Edit: 50 updates at a time worked, but not 60+
    I'm confused...No, wait...Maybe I'm not...

  7. #7

    Default Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    I was able to update everything except for four packages: kio_iso plasma-theme-aya kdelibs4-core libkde4 kdelibs4. When I updated via zypper, I was notified that plasma-theme-aya would change architecture, and kio_iso would change vendor.

    I hope this helps.
    I'm confused...No, wait...Maybe I'm not...

  8. #8

    Default Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    This always happened when I tried to update KDE 4.1 packages from the factory repo. Maybe it had to update KDEsu so it wouldn't let you update using the tool? Or maybe it's because of the number of packages like Wrath5000 said.

  9. #9

    Default Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    I have exactly the same problem. The system is Opensuse11 with KDE4.1 from Factory. Selecting all available updates brings up immediately the aforementioned error window. Selecting the first 30-40 updates work, depending on an unknown factor. Does this issue have a corresponding bug post?

  10. #10
    rebroad NNTP User

    Default Re: KDE4 OpenSuSe Updater error 'kdesu no reply'

    Yup. I'm also getting this problem. It's a brand new install of OpenSUSE x86_64, and I'm trying to install the latest updates for the first time. It's the first time it's booted up from the hard disk with no changes made so far.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •