Results 1 to 2 of 2

Thread: Boot problems with Asus P5K and Raid

  1. #1

    Default Boot problems with Asus P5K and Raid

    I'm newbie with linux and i like learn more and more and exceed my capacity.

    My first experience with linux, 15 years ago, and last month i'm trying to learn something to try mount a desktop pc with linux to work like a NAS and more phings.

    Problem and more problem and i consider mount my home server.

    Some aspect of components:
    - board ASUS P5K
    - pentium dual core
    - 1 GB of Ram
    - 3 sata disks (1 at sata control and 2 on Jmicron raid control)

    First of all i put the desktop work with WinXP. Work fine...

    Now i install OpenSuse 11.0 RC1, during instalation the first problem appear and with Grub. I'm trying to put /home at the raid and others files at the normal sata disk, including system.

    After a lot of hours i conclude that is impossible to install OpensSUSE withs raid active. Then i put raid off at the bios and i install OpenSuse 11 at normal sata disk without any problem.
    After that i turn on the raid control at bios, mount the raid at opensuse and the raid is mounting at /tmp, isn't possible to mount with /home because is mounted at normal sata disk.

    Now i'm trying to move the /home to the raid and i'm not experience to do this.
    I can i do this?
    I attach a screen with some information of my partitions.
    Thank you!

    I think my instalation problem is like that problem of that friend.
    Today I tried to partition a usb-harddrive under xp with partition magic (silly idea, I know).
    It said it had to reboot to finish and after that reboot grub hang in stage1 with error 15.

    I have an Asus P5K-board with SATA-Raid (2x250GB Raid0),
    on this 500GB volume first partition is xp, sda5 is boot, sda7 is root.
    I have OpenSuse 10.3 64.

    I tried to fix grub with the installation media (entering install and then selecting repair).
    This did not work, when I select repair the system automatically reboots.
    The 10.3 live cd does not recognize the raid-volumes at all.

    I cannot mount sda5 or 7 manually, i get error messages that the devices do not exist.
    The installation media drivers seems not to work correctly with my SATA-Raid-controller.

    I used an old win98 boot disk and with "fdisk /mbr" I got rid of grub and now at least xp starts again.
    The linux-partitions all seem to be ok (thats what partition magic says), but how do I boot my OpenSuse?
    With the method described in OpenSuse support its possible to
    load it with xp boot-manager, but you need bootset.lin which is not accessible:-(
    And I did not find any XP boot manager yet who can boot my system from sda5.

    Any ideas/suggestions?

  2. #2

    Default Re: Boot problems with Asus P5K and Raid

    Today i test update the bios of the motherboard to version 1006 and the Suse 11.0 RC1 has installed on raid Jmicron with sucess. No one problem found.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts