Results 1 to 7 of 7

Thread: Remote Access missing in openSuSE 11?

  1. #1
    mirko2324 NNTP User

    Default Remote Access missing in openSuSE 11?

    Hi,

    i have installed the RC1 of openSuSE 11.

    Up to the version 10.3 under YAST (Hardware - Graphics Card and montior - Remote Access) I could enable the vnc remote access.

    In the new version this is missing. Where can I activate this in the new version?

    Thx for your help

  2. #2
    google01103 NNTP User

    Default Re: Remote Access missing in openSuSE 11?

    mirko2324 wrote:

    >
    > Hi,
    >
    > i have installed the RC1 of openSuSE 11.
    >
    > Up to the version 10.3 under YAST (Hardware - Graphics Card and montior
    > - Remote Access) I could enable the vnc remote access.
    >
    > In the new version this is missing. Where can I activate this
    > in the new version?
    >
    > Thx for your help
    >
    >

    yast2 -> network services -> remote admin (vnc)

    you should try the yast2 search
    --
    Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

  3. #3
    mirko2324 NNTP User

    Default Re: Remote Access missing in openSuSE 11?

    This is not what I want.

    For example I to start an application on the remote computer. When I close the connection (vnc window) the program should still run on the remote computer. Later I will check if the program is finished with his work.

    I need a connection to the console of the remote computer as if I sit in front of it.

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Remote Access missing in openSuSE 11?

    There is an option in the Control Center called Remote Desktop. This lets you set to, on a per user base, allow others to connect to your active desktop. Works quite nicely.

    Cheers,
    Wj
    Have a lot of fun!

  5. #5
    mirko2324 NNTP User

    Default Re: Remote Access missing in openSuSE 11?

    Thanks for your answer.

    I can't find an option called "Remote Desktop". Under "Network Services" I found the "Remote Administration (VNC)" option, but that's not what I'm looking for.

  6. #6

    Default Re: Remote Access missing in openSuSE 11?

    Well,

    You can do the same thing sax2 used to do, but do it the hard way - edit, as root, the /etc/X11/xorg.conf file; make a backup first!!!:

    In Section "ServerLayout", you must have the following:
    Code:
        InputDevice    "Keyboard[2]" "ExtraKeyboard"
        InputDevice    "Mouse[3]" "ExtraPointer"
        Option         "VNC" "3 2"
    (note the [2] and [3] might be need to be changed if they already exist.)

    In Section "Module", you must have:
    Code:
        Load           "vnc"

    You must have these entire sections added (alter the Keyboard[2] and Mouse [3] to match above.):
    Code:
    Section "InputDevice"
        Identifier     "Keyboard[2]"
        Driver         "rfbkeyb"
        Option         "InputFashion" "VNC"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[3]"
        Driver         "rfbmouse"
        Option         "InputFashion" "VNC"
    EndSection

    And have this added to Section "Screen":
    Code:
        Option         "usevnc" "yes"
        Option         "rfbauth" "/root/.vnc/passwd"

    Then, as root, you must set your VNC password by typing in a shell:
    Code:
    vncpasswd

    If you don't want a password, then remove this line you just added to the xorg.conf:
    Code:
    Option         "rfbauth" "/root/.vnc/passwd"

    Lastly, you must restart the X server for the changes to take place. Oh yeah, make sure you have port 5900 open in your firewall.

    I hope this is what you wanted,
    g
    Last edited by greenmachine; 19-Jun-2008 at 13:39. Reason: formatting

  7. #7
    KOldham NNTP User

    Default Re: Remote Access missing in openSuSE 11?

    Many thanks for this. For others benefit I'll relate my problem which you've solved

    I installed 11.0 over 10.3 on 2 AMD64s and everything went smoothly. Using vnc to get :0 was as 10.3.

    However I then installed 11.0 on a new fileserver (dualcore Atom ITX - very impressed ) and couldn't get access to :0 although vnc access to :1 :2 :3 was fine.

    Your instructions worked fine.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •