Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Make command not found

  1. #1

    Default Make command not found

    I have a fresh install of 11 RC1 from the KDE CD.

    I was trying to install a suitable Atheros madwifi driver, but when I type make I get:

    bash: make: command not found

    What gives?

  2. #2
    65daysofstatic NNTP User

    Default Re: Make command not found

    you will need to install it, go to install software and search for make.

  3. #3

    Default Re: Make command not found

    Catch 22 eh? No wireless driver, no network, no make, can't install make, can't install wireless etc etc...

    I do wish that it was easier to get the atheros drivers I need installed on Suse... other distros work out of the box...

  4. #4

    Default Re: Make command not found

    Are you root?

  5. #5

    Default Re: Make command not found

    Quote Originally Posted by sideshow View Post
    Are you root?
    Oh yeah... didn't get caught out by that one.

  6. #6

    Default Re: Make command not found

    Quote Originally Posted by Gary_M View Post
    Catch 22 eh? No wireless driver, no network, no make, can't install make, can't install wireless etc etc...

    I do wish that it was easier to get the atheros drivers I need installed on Suse... other distros work out of the box...
    go to 10.3 choose the madwifi repository and it works out the box.

    if atheros isn't working out of the box it would likely be due to the fact that you are using a RC1 of OpenSuse and maybe the repository for madwifi hasn't been updated to that kernel yet.

  7. #7

    Default Re: Make command not found

    I had a problem with make, was trying to install the Nvidia driver and it told me I needed make. I looked in software updates and make was already installed. Tried to reinstall it but no luck.

    I've since reinstalled the whole OS so will try again later and see if it works.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Make command not found

    Quote Originally Posted by Crake View Post
    I had a problem with make, was trying to install the Nvidia driver and it told me I needed make. I looked in software updates and make was already installed. Tried to reinstall it but no luck.

    I've since reinstalled the whole OS so will try again later and see if it works.
    In addition to make, have you also installed gcc, gcc++, gcc42, gcc42++ ? (or is it 43 instead of 42 ? ... maybe I'm getting confused with the answer to life, the universe and everything?).
    Answer to Life, the Universe, and Everything - Wikipedia, the free encyclopedia

  9. #9

    Default Re: Make command not found

    Don't forget you need the Kernel sources to be installed too. (Technically just the headers).

    Under Yast select the patterns option (instead of search).

    Select the following under development:

    Base Development - Includes make etc
    C/C++ - gcc & g++ etc (compilers)
    Kernel Devel - Kernel sources (allows you to build kernel modules).

    This is really the best way to make sure all the right tools are installed, for now and in the future.

    Regards,

    James
    www.worm.me.uk | james at worm dot me dot uk

  10. #10
    Join Date
    Jun 2008
    Location
    Reading, UK.
    Posts
    3

    Default Re: Make command not found

    Quote Originally Posted by Gary_M View Post
    Catch 22 eh? No wireless driver, no network, no make, can't install make, can't install wireless etc etc...
    If you don't have network access, you will find make, and the other basic dev packages, on the installation media you used.

    As others have said, you'll probably need make, gcc, kernel-hearers, gcc++, gcc42, and gcc42++

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •