Results 1 to 9 of 9

Thread: Cable doesn' t work and Wifi is very slow

  1. #1
    jobvdnoort NNTP User

    Default Cable doesn' t work and Wifi is very slow

    Hi all,
    I have got a problem with my internet connection
    Now I have nm-applet 0.6.5 and I can connect to my wireless network but it is very slowly and my cable (lan) doesn't work. Can someone explain me how I can get my cable connection on or how I can get faster Wifi connection.

    Sorry for my bad Englisch.
    Best regards,
    Job van de Noort
    The Netherlands

  2. #2

    Default Re: Cable doesn' t work and Wifi is very slow

    have you disabled IPv6? this can cause a slow/bad connection in many cases. you can disable in yast>network devices>network cards under the global tab. if this doesn't work, post back. just one of the 1st things i would try.

    ross.

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Cable doesn' t work and Wifi is very slow

    If thestig's suggestion doesn't work, give us some idea of your setup by supplying these diagnostics: Open a console and enetr su to become rootlike. then execute these diagnostic commands one after the other:
    • lspci
    • ifconfig
    • route


    And copy/paste the results back here.

    Swerdna
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4

    Default Re: Cable doesn' t work and Wifi is very slow

    further to swerdnas advice one more may be useful regarding your wireless set up:

    iwconfig

  5. #5
    jobvdnoort NNTP User

    Default Re: Cable doesn' t work and Wifi is very slow

    linux:~ # lspci
    00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 81)
    00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 81)
    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
    00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
    00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
    00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
    00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
    00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
    00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
    00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
    00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
    01:00.0 VGA compatible controller: nVidia Corporation GeForce 6700 XL (rev a2)
    02:01.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
    02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    02:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
    02:04.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
    02:05.0 Communication controller: Agere Systems Unknown device 0620
    linux:~ # ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:152 errors:0 dropped:0 overruns:0 frame:0
    TX packets:152 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:13085 (12.7 Kb) TX bytes:13085 (12.7 Kb)

    wlan0 Link encap:Ethernet HWaddr 00:12:BF:63:B9:40
    inet addr:192.168.0.105 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::212:bfff:fe63:b940/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:67498 errors:0 dropped:0 overruns:0 frame:0
    TX packets:45960 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:86527763 (82.5 Mb) TX bytes:5740527 (5.4 Mb)

    wmaster0 Link encap:UNSPEC HWaddr 00-12-BF-63-B9-40-39-34-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    linux:~ # route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 wlan0
    loopback * 255.0.0.0 U 0 0 0 lo
    default 192.168.0.100 0.0.0.0 UG 0 0 0 wlan0
    linux:~ #

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Cable doesn' t work and Wifi is very slow

    Well that's real interesting. Your wlan looks OK prima facie and your wired device is this common one:
    Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    exactly same as mine which works fine for me. So maybe you should try configuring it in Yast. Have you already tried that? If you have and it's still not getting an IP address then there's a deeper problem, maybe electrical. BTW here's some pictures on activating a wired NIC:
    HowTo Configure a network card in Suse/openSUSE 10.x for LAN and Internet Access.

    At the same time edit wlan0 in Yast to start "never" so all the settings are kept but it stays switched off until you edit it to start otherwise than "never".
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    103

    Default Re: Cable doesn' t work and Wifi is very slow

    I'm thinking firewall or physical problems. For the problem to exist accross both interfaces it seems to be the only common point. Your config looks fine apart from the fact that there is no eth0/1/2/3/ or whatever. Crack the case and swap you nic to a different PCI slot. [esc] on the way up and see if the NIC is spotted during boot. head straight for yast if the card is detected and configure as per normal.

    I dont believe the card is being seen by the OS.
    if it aint broken...dont let me near it

  8. #8
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    103

    Default Re: Cable doesn' t work and Wifi is very slow

    can you post the /etc/init.d/network restart results
    if it aint broken...dont let me near it

  9. #9
    Dragonheart73951 NNTP User

    Default Re: Cable doesn' t work and Wifi is very slow

    hello folks,
    I switched my laptop to openSuSE11 two weeks ago and I am impressed! For the first time since SuSE10.0 my wireless network worked! - and it 'just worked' - without any configuration!
    I just have one problem: it's very slow!! (10-20 kB/s with my 2000DSL-connection and the same in the local network) I don't have this, when I boot into XP.
    Following this thread I deactivated IPv6 support in YAST but I couldn't see a real improvement.
    I have a realtec-card and use the RT2500 driver.

    I have posted here the Output of ifconfig, iwconfig, etc.
    Please help me!

    [I]Schlepptop:/home/heiko # ifconfig
    eth0 Link encap:Ethernet Hardware Adresse 00:40:CA:CF:B3:2E
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:7 Basisadresse:0x1c00

    lo Link encap:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:500 errors:0 dropped:0 overruns:0 frame:0
    TX packets:500 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:0
    RX bytes:39372 (38.4 Kb) TX bytes:39372 (38.4 Kb)

    wlan0 Link encap:Ethernet Hardware Adresse 00:90:4B:CD:42:21
    inet Adresse:192.168.0.3 Bcast:192.168.0.255 Maske:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:11046 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4235 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:2876034 (2.7 Mb) TX bytes:520370 (508.1 Kb)

    wmaster0 Link encap:UNSPEC Hardware Adresse 00-90-4B-CD-42-21-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    Schlepptop:/home/heiko # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"daheim2"
    Mode:Managed Frequency:2.437 GHz Access Point: 00:13:49:BD:B0:81
    Bit Rate=1 Mb/s Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Encryption keyff
    Link Quality=51/100 Signal level=-54 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    Schlepptop:/home/heiko # route
    Kernel IP Routentabelle
    Ziel Router Genmask Flags Metric Ref Use Iface
    localhost * 255.255.255.0 U 0 0 0 wlan0
    loopback * 255.0.0.0 U 0 0 0 lo
    default localhost 0.0.0.0 UG 0 0 0 wlan0
    Schlepptop:/home/heiko # lspci
    00:00.0 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.1 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.2 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.3 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.4 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.7 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
    00:06.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
    00:0c.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
    00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
    00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
    00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
    00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
    00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
    00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller(rev 80)
    00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
    01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter (rev 02)
    hello folks,
    I switched my laptop to openSuSE11 two weeks ago and I am impressed! For the first time since SuSE10.0 my wireless network worked! - and it 'just worked' - without any configuration!
    I just have one problem: it's very slow!! (10-20 kB/s with my 2000DSL-connection and the same in the local network) I don't have this, when I boot into XP.
    Following this thread I deactivated IPv6 support in YAST but I couldn't see a real improvement.

    I have posted here the Output of ifconfig, iwconfig, etc.
    Please help me!

    Schlepptop:/home/heiko # ifconfig
    eth0 Link encap:Ethernet Hardware Adresse 00:40:CA:CF:B3:2E
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:7 Basisadresse:0x1c00

    lo Link encap:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:500 errors:0 dropped:0 overruns:0 frame:0
    TX packets:500 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:0
    RX bytes:39372 (38.4 Kb) TX bytes:39372 (38.4 Kb)

    wlan0 Link encap:Ethernet Hardware Adresse 00:90:4B:CD:42:21
    inet Adresse:192.168.0.3 Bcast:192.168.0.255 Maske:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:11046 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4235 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:2876034 (2.7 Mb) TX bytes:520370 (508.1 Kb)

    wmaster0 Link encap:UNSPEC Hardware Adresse 00-90-4B-CD-42-21-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    Schlepptop:/home/heiko # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"daheim2"
    Mode:Managed Frequency:2.437 GHz Access Point: 00:13:49:BD:B0:81
    Bit Rate=1 Mb/s Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Encryption keyff
    Link Quality=51/100 Signal level=-54 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    Schlepptop:/home/heiko # route
    Kernel IP Routentabelle
    Ziel Router Genmask Flags Metric Ref Use Iface
    localhost * 255.255.255.0 U 0 0 0 wlan0
    loopback * 255.0.0.0 U 0 0 0 lo
    default localhost 0.0.0.0 UG 0 0 0 wlan0
    Schlepptop:/home/heiko # lspci
    00:00.0 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.1 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.2 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.3 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.4 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:00.7 Host bridge: VIA Technologies, Inc. CN400/PM880 Host Bridge
    00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
    00:06.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
    00:0c.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
    00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
    00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
    00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
    00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
    00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
    00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
    00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller(rev 80)
    00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
    01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter (rev 02)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •