Results 1 to 7 of 7

Thread: Getting Splashy To work

  1. #1

    Question Getting Splashy To work

    hello,
    I'm using opensuse 10.3 & gnome 2.2. I cant get splashscreen @ bootup. All i get is text mode. I've tried several different vga= modes on kernel line in menu.lst and when I reboot all I get is unrecognized video mode message. When I run splashy test I get:
    splashy test
    linux:/boot # Splashy ERROR: Couldn't splashy_start_splashy(). Error -2
    I googled that but wasnt very helpful. I also have run:
    grep CONFIG_FB /boot/config-2.6.22.17-0.1-default
    CONFIG_FB=y
    CONFIG_FB_DDC=m
    CONFIG_FB_CFB_FILLRECT=y
    CONFIG_FB_CFB_COPYAREA=y
    CONFIG_FB_CFB_IMAGEBLIT=y
    CONFIG_FB_SYS_FILLRECT=m
    CONFIG_FB_SYS_COPYAREA=m
    CONFIG_FB_SYS_IMAGEBLIT=m
    CONFIG_FB_SYS_FOPS=m
    CONFIG_FB_DEFERRED_IO=y
    CONFIG_FB_SVGALIB=m
    # CONFIG_FB_MACMODES is not set
    CONFIG_FB_BACKLIGHT=y
    CONFIG_FB_MODE_HELPERS=y
    CONFIG_FB_TILEBLITTING=y
    CONFIG_FB_CIRRUS=m
    CONFIG_FB_PM2=m
    CONFIG_FB_PM2_FIFO_DISCONNECT=y
    CONFIG_FB_CYBER2000=m
    CONFIG_FB_ARC=m
    # CONFIG_FB_ASILIANT is not set
    CONFIG_FB_IMSTT=y
    CONFIG_FB_VGA16=m
    CONFIG_FB_VESA=y
    CONFIG_FB_HECUBA=m
    CONFIG_FB_HGA=m
    CONFIG_FB_HGA_ACCEL=y
    CONFIG_FB_S1D13XXX=m
    CONFIG_FB_NVIDIA=m
    CONFIG_FB_NVIDIA_I2C=y
    # CONFIG_FB_NVIDIA_DEBUG is not set
    CONFIG_FB_NVIDIA_BACKLIGHT=y
    CONFIG_FB_RIVA=m
    CONFIG_FB_RIVA_I2C=y
    # CONFIG_FB_RIVA_DEBUG is not set
    CONFIG_FB_RIVA_BACKLIGHT=y
    CONFIG_FB_I810=m
    CONFIG_FB_I810_GTF=y
    CONFIG_FB_I810_I2C=y
    CONFIG_FB_LE80578=m
    CONFIG_FB_CARILLO_RANCH=m
    CONFIG_FB_INTEL=m
    # CONFIG_FB_INTEL_DEBUG is not set
    CONFIG_FB_INTEL_I2C=y
    CONFIG_FB_MATROX=m
    CONFIG_FB_MATROX_MILLENIUM=y
    CONFIG_FB_MATROX_MYSTIQUE=y
    CONFIG_FB_MATROX_G=y
    # CONFIG_FB_MATROX_I2C is not set
    CONFIG_FB_MATROX_MULTIHEAD=y
    CONFIG_FB_RADEON=m
    CONFIG_FB_RADEON_I2C=y
    CONFIG_FB_RADEON_BACKLIGHT=y
    # CONFIG_FB_RADEON_DEBUG is not set
    # CONFIG_FB_ATY128 is not set
    CONFIG_FB_ATY=m
    CONFIG_FB_ATY_CT=y
    CONFIG_FB_ATY_GENERIC_LCD=y
    CONFIG_FB_ATY_GX=y
    CONFIG_FB_ATY_BACKLIGHT=y
    CONFIG_FB_S3=m
    CONFIG_FB_SAVAGE=m
    CONFIG_FB_SAVAGE_I2C=y
    CONFIG_FB_SAVAGE_ACCEL=y
    CONFIG_FB_SIS=m
    CONFIG_FB_SIS_300=y
    CONFIG_FB_SIS_315=y
    CONFIG_FB_NEOMAGIC=m
    CONFIG_FB_KYRO=m
    CONFIG_FB_3DFX=m
    CONFIG_FB_3DFX_ACCEL=y
    CONFIG_FB_VOODOO1=m
    CONFIG_FB_VT8623=m
    CONFIG_FB_CYBLA=m
    CONFIG_FB_TRIDENT=m
    CONFIG_FB_TRIDENT_ACCEL=y
    CONFIG_FB_ARK=m
    CONFIG_FB_PM3=m
    CONFIG_FB_GEODE=y
    CONFIG_FB_GEODE_GX=m
    # CONFIG_FB_GEODE_GX_SET_FBSIZE is not set
    CONFIG_FB_GEODE_GX1=m
    CONFIG_FB_SM501=m
    # CONFIG_FB_VIRTUAL is not set

    So it looks like I have FB setup in kernel. I am using an old Dell100l w/i810 graphics driver. Anybody got any ideas on how to get splash screen working.And yes I have splash=silent on kernel line also.
    thanx...

  2. #2

    Default Re: Getting Splashy To work

    First, you should find your supported VGA mode. Most computers I've tested can boot with vga=791 just fine so try that. Then make sure splashy is enabled in yast (yast, system ,sysconfig editor.) go to system, boot and make sure splash is on and that it points to a correct theme (next item down) then, in terminal as root do a mkinitrd and it should work.

  3. #3

    Default Re: Getting Splashy To work

    I tried vga=791 and I get an error message saying "Unrecognized Video Mode" I've tried several diferent modes and all give the same message. I also tried vga=ask and that just gives me a bunch of text mode options on boot. Splashy is setup in system config. but I would assume first I have to solve this problem of finding a vga= setting that will work? That's why I'm wondering do i have my hardware setup correctly? Can the i810 video chip support this?
    openSUSE 11.1 Gnome 2.24.1 PIII @1gHz uname -r
    2.6.27.7-9-default

  4. #4

    Default Re: Getting Splashy To work

    AFAIK, SuSE11 does use splashy, and if you wait 2 more days, you should get it
    "If it ain't broke, find something wrong with it"

  5. #5

    Default Re: Getting Splashy To work

    I dont think that will help. I already have splashy installed on 10.3 I was doing some more reading and I noticed that someone was using /sbin/fbresolution to determine what resolution he should use for splash screen. When I issue that command I get:
    /sbin/fbresolution
    open /dev/fb0: No such file or directory
    Is this @ the root of my problem? that I dont have /dev/fb0? And how do I get /dev/fb0?
    openSUSE 11.1 Gnome 2.24.1 PIII @1gHz uname -r
    2.6.27.7-9-default

  6. #6

    Default Re: Getting Splashy To work

    Quote Originally Posted by some-guy View Post
    AFAIK, SuSE11 does use splashy, and if you wait 2 more days, you should get it
    That's good I've always thought that bootsplash was so..outdated (well it is :-P) and I'm happy Suse is back on the bleeding edge

  7. #7
    Join Date
    Jun 2008
    Location
    France
    Posts
    9

    Default Re: Getting Splashy To work

    I had the same issue and I've found on this forum the thread:

    Now Low Resolution For Startup - openSUSE Forums

    that helps with VGA modes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •