Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: openSUSE 11 RC1: gvfs: Permission denied

  1. #1

    Default openSUSE 11 RC1: gvfs: Permission denied

    Hi,

    I have an error message in Smart Package Manager, It says:
    Code:
    error: failed to stat /var/lib/gdm/.gvfs: Permission denied
    That showing to me after doing smart upgrade

    I don't have any problem, but why it show me that message?

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: openSUSE 11 RC1: gvfs: Permission denied

    I've seen this error pop up here and there and mostly seems to be related to software installation.

    As far as I've seen this is merely a cosmetic error but it would be good if they tackle it to avoid confusing users.
    Have a lot of fun!

  3. #3
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: openSUSE 11 RC1: gvfs: Permission denied

    GVFS was updated and you should try a zypper ref && zypper dup to bring your RC up to date.

    Note that it may download *a lot* of files.

  4. #4

    Default Re: openSUSE 11 RC1: gvfs: Permission denied

    Quote Originally Posted by Chrysantine View Post
    GVFS was updated and you should try a zypper ref && zypper dup to bring your RC up to date.

    Note that it may download *a lot* of files.
    Actually I am using SMART as default package manager in my system, and this is my channels:
    Code:
    [opensuse-updates]
    type = rpm-md
    name = openSUSE-11 Updates
    baseurl = http://download.opensuse.org/update/11.0/
    
    [drivers_webcam]
    type = rpm-md
    name = Webcam Drivers (openSUSE_11.0_Update)
    baseurl = http://download.opensuse.org/repositories/drivers:/webcam/openSUSE_11.0_Update/
    
    [rpm-sys]
    type = rpm-sys
    name = RPM System
    
    [packman]
    type = rpm-md
    name = Packman repository
    disabled = yes
    baseurl = http://packman.mirrors.skynet.be/pub/packman/suse/11.0/
    
    [SaX2]
    type = rpm-md
    name = X11 configuration (Factory)
    disabled = yes
    baseurl = http://download.opensuse.org/repositories/SaX2/openSUSE_Factory/
    
    [OpenOffice.org_STABLE]
    type = rpm-md
    name = Stable Version of OpenOffice.org  (openSUSE_11.0)
    disabled = yes
    baseurl = http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.0/
    
    [X11:XGL]
    type = rpm-md
    name = Repository for Xgl and related packages that give your Desktop some bling (X11:XGL)
    baseurl = http://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.0/
    
    [mozilla]
    type = rpm-md
    name = Latest packages for Mozilla projects
    baseurl = http://download.opensuse.org/repositories/mozilla/openSUSE_11.0/
    
    [mozilla_beta]
    type = rpm-md
    name = Experimental/beta Mozilla versions (openSUSE_11.0)
    baseurl = http://download.opensuse.org/repositories/mozilla:/beta/openSUSE_11.0/
    
    [Banshee]
    type = rpm-md
    name = Banshee Media Player (openSUSE_11.0)
    baseurl = http://download.opensuse.org/repositories/Banshee/openSUSE_11.0/
    
    [opensuse]
    type = rpm-md
    name = openSUSE Factory
    baseurl = http://download.opensuse.org/distribution/SL-OSS-factory/inst-source/suse/
    
    [Beagle]
    type = rpm-md
    name = Beagle Desktop Search (openSUSE_Factory)
    disabled = yes
    baseurl = http://download.opensuse.org/repositories/Beagle/openSUSE_Factory/
    
    [games]
    type = rpm-md
    name = Games (openSUSE_11.0)
    baseurl = http://download.opensuse.org/repositories/games/openSUSE_11.0/
    
    [smart]
    type = rpm-md
    name = Latest smart packages for openSUSE
    priority = 10
    baseurl = http://download.opensuse.org/repositories/smart/openSUSE_Factory/
    
    [GNOME_STABLE]
    type = rpm-md
    name = Stable branch of GNOME (openSUSE_11.0)
    baseurl = http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_11.0/
    
    [X11_XOrg]
    type = rpm-md
    name = X.Org development (openSUSE_11.0)
    baseurl = http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.0/
    
    [opensuse-nonoss]
    type = rpm-md
    name = openSUSE Factory NON-OSS
    baseurl = http://download.opensuse.org/distribution/SL-Factory-non-oss/inst-source-extra/suse/
    
    [GNOME_Community]
    type = rpm-md
    name = Open repository for GNOME related packages (openSUSE_11.0)
    baseurl = http://download.opensuse.org/repositories/GNOME:/Community/openSUSE_11.0/
    
    [Emulators_Wine]
    type = rpm-md
    name = Wine (openSUSE_11.0)
    baseurl = http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.0/
    And I try using zypper ref && zypper dup but there's no any updates for GVFS.
    gvfs version on my system is: gvfs-0.2.3-28

  5. #5
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: openSUSE 11 RC1: gvfs: Permission denied

    You are indeed up to date - odd because I was having an issue where I was getting the message pre-version patch.

  6. #6
    steenisr NNTP User

    Default Re: openSUSE 11 RC1: gvfs: Permission denied

    As far as I can see it is all about permissions on the folders .gvfs. On my OpenSuse 11 distro the permissions on /var/lib/GDM/.gvfs are:

    d????????? ? ? ? ? ? .gvfs

    Anyone know how to fix this?

  7. #7

    Default Re: openSUSE 11 RC1: gvfs: Permission denied

    I'm having the same issue on openSUSE 11.0 GA.

    Code:
    # cat /etc/SuSE-release 
    openSUSE 11.0 (i586)
    VERSION = 11.0
    
    # ls -lha /var/lib/gdm
    ls: cannot access /var/lib/gdm/.gvfs: Permission denied
    total 20K
    drwxrwx--T  4 root gdm  4.0K Jul  2 23:49 .
    drwxr-xr-x 42 root root 4.0K Jul  3 00:12 ..
    -rw-------  1 root root   33 Jul  2 23:49 .cookie
    drwx------  3 gdm  gdm  4.0K Jul  2 18:02 .dbus
    prw-rw----  1 root root    0 Jul  2 23:49 .gdmfifo
    d?????????  ? ?    ?       ?            ? .gvfs

    Any ideas? Thanks

    Stewart@UGA

  8. #8
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: openSUSE 11 RC1: gvfs: Permission denied

    I can't reproduce that error here but there is a bug open for this : https://bugzilla.novell.com/show_bug.cgi?id=390701

    Maybe you can add your comments and get it sorted?

    Cheers,
    Wj
    Have a lot of fun!

  9. #9
    ykndr NNTP User

    Wink Re: openSUSE 11 RC1: gvfs: Permission denied

    I have same problem to and simple solve it.

    Reinstall all packages gvfs with YAST such as gvfs,gvfs-backends,gvfs-devel,gvfs-fuse,gvfs-lang,libgvfscommon0

    Have a nice day!http://forums.opensuse.org/images/icons/icon12.gif

  10. #10
    PSergey NNTP User

    Default Re: openSUSE 11 RC1: gvfs: Permission denied

    Just Install openSUSE 11(i586)(no RC1!)
    Some problem and reinstall packages with YAST dont work for me!!!
    Anyone else got an idea how I can fix it?

    Sergey

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •