Results 1 to 9 of 9

Thread: How to setting monitor refresh rate

  1. #1

    Default How to setting monitor refresh rate

    Hello Everybody

    I have recently installed Opensuse 11.0 RC1 .
    Other than bootsplash issue and this issue, there is no major problems.

    I have a Samsung Syncmaster 713x 17' LCD Monitor.
    My system always boots in 60hz refresh rate.
    My monitor support's 75hz refresh rate.
    Even KDE 4 also allows me to set 75hz as a refresh rate.
    But it is not configured permanently. i haven't set refresh-rate every time i login to my Desktop.

    My Xorg.conf file has the following content.

    Code:
     
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-06-11T14:11:37+0530.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AIGLX" "on"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Load         "freetype"
      Load         "type1"
      Load         "dbe"
      Load         "glx"
      Load         "extmod"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
    EndSection
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "12"
      Option       "Device" "/dev/input/mice"
      Option       "Emulate3Buttons" "on"
      Option       "Name" "Logitech USB Receiver"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  338 270
      HorizSync    30-81
      Identifier   "Monitor[0]"
      ModelName    "SAMSUNG SYNCMASTER"
      Option       "DPMS"
      Option       "PreferredMode" "1280x1024"
      VendorName   "SAM"
      VertRefresh  43-75
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
      Modeline 	"1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "945G"
      BusID        "0:2:0"
      Driver       "intel"
      Identifier   "Device[0]"
      Option       "monitor-VGA" "Monitor[0]"
      Screen       0
      VendorName   "Intel"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
      Option       "Composite" "on"
    EndSection
    I had this problem in Ubuntu 8.04 too, but there was a utility to set Graphics and Monitor options and it allowed to set Refresh-Rate permanently.

    So i wasn't needed to look for my monitor's specifications or needed to play with Xorg.conf file.

  2. #2
    kiwilinux NNTP User

    Default Re: How to setting monitor refresh rate

    try using Yast - Hardware - Graphics Card and Monitor. You should be able to set the refresh rate in there.

  3. #3

    Default Re: How to setting monitor refresh rate

    Quote Originally Posted by kiwilinux View Post
    try using Yast - Hardware - Graphics Card and Monitor. You should be able to set the refresh rate in there.
    Refresh Rate of the monitor cannot be changed via Sax2.

  4. #4

    Default Re: How to setting monitor refresh rate

    Hello Everybody

    I have solved the low refresh rate problem just by following method.

    Edited Xorg.conf using KWrite.

    Under Monitor section,
    In VertRefresh, there was 46-75.
    I replaced it with 75,
    Problem solved

  5. #5
    Join Date
    Jun 2008
    Location
    North east Ohio
    Posts
    74

    Default Re: How to setting monitor refresh rate

    One of the comments at the top of xorg.config says
    # PLEASE DO NOT EDIT THIS FILE!
    Im wondering why?

  6. #6
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: How to setting monitor refresh rate

    Mainly because sax will overwrite your changes next time
    you run it. Besides vertical refresh rate isn't really
    that important with an LCD monitor as they don't flicker
    like old CRT's do.

  7. #7
    Join Date
    Jun 2008
    Location
    North east Ohio
    Posts
    74

    Default Re: How to setting monitor refresh rate

    Thank you for the info, Hank.

    That brings to mind another question:
    In the situation described by Raghugs - where the change could not be made with sax, how does one make the change so it is permanent?

    Gary

  8. #8
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: How to setting monitor refresh rate

    The easiest way is to simply don't use sax, that's possible
    as long as you don't have any hardware that needs to be set
    up with sax. Xorg.conf can be much simpler than those gene-
    rated by sax with todays xorgserver, xorg is pretty good
    at finding out things by itself. The following very simple
    xorg.conf works for my setup:

    Code:
    Section "Device"
            Identifier  "MyCard"
            Driver      "fglrx"
    EndSection
    
    Section "Screen"
            Identifier "MyScreen"
            Device     "MyCard"
            DefaultDepth     24
            SubSection "Display"
                    Depth     24
    		Virtual   1280 1024        
    	EndSubSection
    EndSection
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    Much easier to read and follow, there's only 2 issues with it.
    As there's no keyboard section you'll have to set your keyboard
    layout in the desktop if it's not a us keyboard and for some
    reason xorg thinks my monitor can do 1450x900, so I have to
    use the line:
    Code:
    Virtual   1280 1024
    It might be this error from xorg that sets the refresh to 60 hz,
    with the above line it's set to 75 hz.

    There's a lot of interesting stuff about this, especially about
    setting up dual monitors on this link:
    X.Org Wiki - radeonhd

  9. #9
    Join Date
    Jun 2008
    Location
    North east Ohio
    Posts
    74

    Default Re: How to setting monitor refresh rate

    Thank you very much for the information.

    Your last post goes in my file of "things I ought know"

    Gary

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •