Results 1 to 7 of 7

Thread: Can't install on JMicron FakeRAID

  1. #1

    Unhappy Can't install on JMicron FakeRAID

    I can't manage to get linux to install on a computer with
    - a Gigabyte GA-MA790FX-DQ6 motherboard
    - 2x Samsung Spinpoint 200GiB as FakeRAID-0 on the jmicron controller (called GIGABYTE-SATA in the BIOS)

    The fakeraid array works flawlessly in :
    - Vista x84 (using the drivers provided with the board)
    - Linux System RescueCD 0.4.3 - using 'dmraid' to activate the array.
    (and of course in FreeDOS too, but in that case it's the BIOS handling the array anyway).

    *BUT* whenever I try to boot on an install CD, either openSUSE 10.3 or openSUSE 11.0 beta (same also happens with Ubuntu 7.10 and 8.4) :
    - Suddenly the metadata of the first disk in the fakeraid array becomes inaccessible.
    - I can't do 'dmraid' from the installation environment - dmraid can't detect the metadata on the first disk and can activate the fakeraid array. (both disk are readable, though. And if I want, I can access the array by manually assembling it with 'mdadm' and carefully using the same exact parameter as in the fakeraid bios).
    - The fakeraid bios it self can't detect the array. The first disk is reported as "non raid" and the array is broken.

    This situation persist until I power-cycle the machine. Then the array is back again, accessible in the BIOS, in Windows x64 and in SysRescCD.

    Has anyone had similar problem ?
    Can someone help me how I should proceed to try installing linux on that machine ?

    thank you very much.

  2. #2
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: Can't install on JMicron FakeRAID

    There's a procedure for making the driver available using a floppy if it's not on the install CD/DVD. See Novell Documentation for your version.

    With the driver & BIOS raid, should work with later versions.

    Before 10.1, to have SuSE on an established raid array, I had to do an install on another partition; install the driver; get the raid detected/configured and then move that install to the raid array. As I recall,I had to partition the raid array, I needed a /boot partition; had to rework the menu.lst for the new partition locations; used the "repair" function to make it bootable; etc. It was not that tough; just a little work
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  3. #3

    Post Re: Can't install on JMicron FakeRAID

    There's a procedure for making the driver available using a floppy if it's not on the install CD/DVD.
    The jmicron SATA-II controller works with the linux ahci driver.
    the problem is once I boot any other linux CD except the SysRescCD, the raid array suddenly breaks for *all* (including the bios and sysresccd) until I power cycle the machine.

  4. #4

    Default Re: Can't install on JMicron FakeRAID

    See this post: Boot problems with Asus P5K and Raid - openSUSE Forums
    Your problem is identical and with a bios upgrade i resolved them.
    Regards

  5. #5

    Default Re: Can't install on JMicron FakeRAID

    Quote Originally Posted by nandobig View Post
    See this post - Your problem is identical and with a bios upgrade i resolved them.
    according to the screenshot you've posted, dmraid at least detects your raid and creates corresponding '/dev/mapped/jmicron*' devices. in my situation, whenever the installation cd-r of opensuse is booted, the raid suddenly fails until the next power on/off.

    i have done a couple of bios upgrade but none of them did fix the raid problem.
    and gigabyte refuse to help as they don't officially support linux.

  6. #6

    Default Still not working

    Motherboard's BIOS has been upgraded to latest version F5.
    Latest version 11.0 (final) of openSUSE Linux downloaded.

    But still I can't get the fakeraid working.
    If I boot Linux from SystemRescueCD or Windows Vista : everything is fine.
    If I boot Linux from the openSUSE install CD, suddenly both drives on the fake raid become "Non-RAID" and the raid isn't accessible anymore (either by any flavor of Linux or even the BIOS itself) until the next power-cycle.

    The only difference is that now with the new BIOS, both drives fall of the raid.

    Has anyone had succes installing openSUSE Linux on the Gigabyte GA-MA790FX-DQ6 ?!?

  7. #7

    Exclamation Re: Can't install on JMicron FakeRAID

    I tweaked the dmraid source code to have it working with jmicron controller. The problem is in the name allocation for the jmicron controller. This is a very fast fix (~15 min) just to make it work.

    Anw the new source code can be found here
    Sorry about the rapidshare link...

    Before installing remove the previous dm-raid package but not its dependencies.

    Then run "./configure" and then "make install"

    Then dmraid should work with the jmicron controller.
    This was tested on opensuse 10.3 and Fedora Core 10.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •