Results 1 to 9 of 9

Thread: ClamAV versions

  1. #1
    Jim Pye NNTP User

    Default ClamAV versions

    All

    Can someone explain to me why the clamav rpm download from the build service
    is labeled as version 0.93.2 but the official version on clamav.net, and
    the warning message in my logs, says upgrade to version 0.93.1?

    Jim

    --
    Pye, James Pye, chmod 007, The Ultimate Open Source

    You know it's going to be a bad day when you hear
    "Transporter Malfunction" while being demolecularised.

  2. #2
    Join Date
    Jun 2008
    Location
    PHX
    Posts
    481

    Default Re: ClamAV versions

    What is the build service repo you found this in?
    <>---><^>

  3. #3
    Jim Pye NNTP User

    Default Re: ClamAV versions

    Cryovac wrote:

    >
    > What is the build service repo you found this in?
    >
    >


    Entering clamav into the search dialog on:
    http://software.opensuse.org/search


    --
    Pye, James Pye, chmod 007, The Ultimate Open Source

    You know it's going to be a bad day when you hear
    "Transporter Malfunction" while being demolecularised.

  4. #4
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Re: ClamAV versions

    You mean this is what you got, Software.openSUSE.org you need to use the "Permanent link to this result" else all everyone gets is a blank search. So we have no clue which Distro/version you are referring to. My best guess, seeing as how most of the hits on the above search are done by individuals they must have not labeled the version correctly.
    "We must plan for freedom, and not only for security, if for no other reason than only freedom can make security more secure." Karl Popper

  5. #5
    Join Date
    Jun 2008
    Location
    Albuquerque, NM, USA
    Posts
    87

    Default Re: ClamAV versions

    There's a difference between 0.93-1 and 0.93.1. I don't see anything from the build service that is using the 0.93.1 source. What's the output from
    rpm -qa --nosignature --nodigest |grep clamav
    It's really that much fun!
    Geeko Samurai (cc)
    My Recent Tracks

  6. #6
    Join Date
    Jun 2008
    Location
    Cyberspace
    Posts
    13

    Default Re: ClamAV versions

    Quote Originally Posted by benstein View Post
    There's a difference between 0.93-1 and 0.93.1. I don't see anything from the build service that is using the 0.93.1 source. What's the output from
    rpm -qa --nosignature --nodigest |grep clamav
    I've an updated version of ClamAV, it uses 0.93.1 and it is part of my BuildService project. However, until my repo is reactivated, people will have to either link or copy the package into their own project.. or wait until the package is officially updated. I've installed the new version locally and it works fine, and all the annoying warning notices about the engine being out of date have stopped. BuildService users feel free to use home:pikerhog package clamav -- it should work for 10.3, 11.0 and factory.

    I wonder if the shipped/release version of 11.0 will include a new version or when the official update(/11.0) will be updated. Anyways.. hope that helps.. If not, I could provide rpms at my own site later if need be.

    ...piker

  7. #7
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Re: ClamAV versions

    I hope SUSE 11.0 will have 0.93.1, or that they will allow upgrading to the newer version as soon as possible.

    To the original poster just because the version you have is one version out of date is nothing to worry about, freshclam will still download the new signatures for ClamAV and will still work until SUSE releases 0.93.1.
    "We must plan for freedom, and not only for security, if for no other reason than only freedom can make security more secure." Karl Popper

  8. #8
    Jim Pye NNTP User

    Default Re: ClamAV versions

    vendion wrote:

    >
    > I hope SUSE 11.0 will have 0.93.1, or that they will allow upgrading to
    > the newer version as soon as possible.
    >
    > To the original poster just because the version you have is one version
    > out of date is nothing to worry about, freshclam will still download the
    > new signatures for ClamAV and will still work until SUSE releases
    > 0.93.1.
    >
    >


    My original concern was with the version numbers. I subscribe to the ClamAV
    mailing list and saw that the 0.93.1 beta version had gone to release. And
    I know from past experience that the openSUSE updates usually take a day or
    2 to appear on the download/repo/update sites but I thought it a bit
    strange when they did appear that they were labelled 0.93.2.

    I usually download the .rpm for openSUSE and apply it manually so I can keep
    an eye on what the update is doing, making sure it restarts and runs
    properly and not have my mail suddenly stop behind my back, etc.

    Cheers
    Jim

    --
    Pye, James Pye, chmod 007, The Ultimate Open Source

    You know it's going to be a bad day when you hear
    "Transporter Malfunction" while being demolecularised.

  9. #9
    Russbucket NNTP User

    Default Re: ClamAV versions

    pikerhog wrote:

    >
    > benstein;1817571 Wrote:
    >> There's a difference between 0.93-1 and 0.93.1. I don't see anything
    >> from the build service that is using the 0.93.1 source. What's the
    >> output from
    >> rpm -qa --nosignature --nodigest |grep clamav

    >
    > I've an updated version of ClamAV, it uses 0.93.1 and it is part of my
    > BuildService project. However, until my repo is reactivated, people
    > will have to either link or copy the package into their own project..
    > or wait until the package is officially updated. I've installed the new
    > version locally and it works fine, and all the annoying warning notices
    > about the engine being out of date have stopped. BuildService users
    > feel free to use homeikerhog package clamav -- it should work for
    > 10.3, 11.0 and factory.
    >
    > I wonder if the shipped/release version of 11.0 will include a new
    > version or when the official update(/11.0) will be updated. Anyways..
    > hope that helps.. If not, I could provide rpms at my own site later if
    > need be.
    >
    > ...piker
    >
    >

    What is the link to your repo? I would like to try yours, mine is 0.93-7.1
    from build service and the messages from Klamav are driving me nuts. Also
    do you know a repo from the later clamav, have the offical 0.41 but the
    messages say upgrade to 0.43. I could compile my own but Its easier if
    there is a rpm.

    Also I understand how to search build serve but I have not found a good
    write up on how to use the build serve. Any links?
    --
    Russ
    Registered Linux user #441463

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •