Results 1 to 3 of 3

Thread: HP Deskjet 6980

  1. #1
    Graham P Davis NNTP User

    Default HP Deskjet 6980

    I have this printer successfully configured in 10.3 on a wireless network
    but have had no success setting it up under 11.0.

    Installing it using the shell script hplip-2.8.5.run requires half-a-dozen
    or more missing software items to be installed by YAST - one at a time as
    you only get warned about one of them on each run of the shell. When it
    finally has all the software, it fails for an "unknown" reason.


    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman, not newsboy.
    "What use is happiness? It can't buy you money." [Chic Murray, 1919-85]

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: HP Deskjet 6980

    Quote Originally Posted by Graham P Davis View Post
    I have this printer successfully configured in 10.3 on a wireless network but have had no success setting it up under 11.0.
    I assume your wireless network is running on 11.0 ?

    What technique/cups-print settings did you use on 10.3 to get it running? I assume you have no special firewall settings on 10.3 to get it working there?

    Did you compare any of the 10.3 config files to 11.0 ?

    It should work with Linux with no problems:
    OpenPrinting database - Printer: HP DeskJet 6980

    Unfortunately not one openSUSE user, who has the HP-6980 working under ANY version of openSUSE, has taken the time to update the wiki.
    HCL/Printers - openSUSE

  3. #3
    Graham P Davis NNTP User

    Default Re: HP Deskjet 6980

    oldcpu wrote:

    >
    > Graham P Davis;1816326 Wrote:
    >> I have this printer successfully configured in 10.3 on a wireless
    >> network but have had no success setting it up under 11.0.I assume your
    >> wireless network is running on 11.0 ?

    >
    > What technique/cups-print settings did you use on 10.3 to get it
    > running? I assume you have no special firewall settings on 10.3 to
    > get it working there?


    No special settings are needed when using hplip, everything is done for
    you - which is the sort of installation I like!

    The downloads and instructions are at
    http://hplip.sourceforge.net/install/index.html.

    >
    > Did you compare any of the 10.3 config files to 11.0 ?


    No. I doubt the install got that far. However, a message from the installer
    suggest that the shell wasn't able to install the missing dependencies
    because it didn't recognise that there was a working Internet connection.
    "note: Installation of dependencies requires an active internet connection."
    Normally, the modules would be installed automatically.

    The log for the installation is as follows:
    Jun 11 14:49:51 Wanderer python: hplip-install[4112]: warning: Invalid
    ppd_dir
    value: None
    Jun 11 14:50:01 Wanderer su: (to root) graham on /dev/pts/2
    Jun 11 14:50:01 Wanderer python: hplip-install[4112]: warning: There are 2
    missing OPTIONAL dependencies.
    Jun 11 14:50:01 Wanderer python: hplip-install[4112]: warning: Missing
    OPTIONAL dependency for option 'fax': reportlab (Reportlab - PDF library for
    Python)
    Jun 11 14:50:01 Wanderer python: hplip-install[4112]: warning: This
    installer
    cannot install 'reportlab' for your distro/OS and/or version.
    Jun 11 14:50:01 Wanderer python: hplip-install[4112]: warning: Missing
    OPTIONAL dependency for option 'base': cups-ddk (cups-ddk - CUPS driver
    development kit)
    Jun 11 14:50:01 Wanderer python: hplip-install[4112]: warning: This
    installer
    cannot install 'cups-ddk' for your distro/OS and/or version.
    Jun 11 14:50:02 Wanderer python: hplip-install[4112]: error: Configure
    failed
    with error: General/unknown error


    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman, not newsboy.
    "What use is happiness? It can't buy you money." [Chic Murray, 1919-85]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •