Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: trouble with DVDs

  1. #1
    Join Date
    Jun 2008
    Location
    biggest little city
    Posts
    37

    Default trouble with DVDs

    i plopped in a dvd expecting everything to go okay, but alas no. i am using kaffiene. so i did some searching and found that i needed to install some other things such as libdvdcss and the like. i have read all the links from the sticky in this section. i have installed xine and tried totem. i have gone through the restricted format install stuff and still no success.

    are there any other suggestions of things to check to try and get this to work, other specific files/programs that may need installing? is it possible that it will work with one dvd and maybe not another? i have only tried to play one so far, all the other video files i have played are mp4 or avi files (they work fine) and just never gotten around to playing a dvd until now.

    thanks

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: trouble with DVDs

    Quote Originally Posted by thalo View Post
    i plopped in a dvd expecting everything to go okay, but alas no. i am using kaffiene. so i did some searching and found that i needed to install some other things such as libdvdcss and the like. i have read all the links from the sticky in this section. i have installed xine and tried totem. i have gone through the restricted format install stuff and still no success.

    are there any other suggestions of things to check to try and get this to work, other specific files/programs that may need installing? is it possible that it will work with one dvd and maybe not another? i have only tried to play one so far, all the other video files i have played are mp4 or avi files (they work fine) and just never gotten around to playing a dvd until now.

    thanks
    Hello, I'm a newb in this myself, but I use the jem report a fair bit:
    Check these two out:
    Multimedia - openSUSE-Community
    and
    Hacking openSUSE 10.3 - Sofware in Review
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: trouble with DVDs

    Quote Originally Posted by thalo View Post
    i have installed xine and tried totem. i have gone through the restricted format install stuff and still no success.
    Apologies, but we need to ensure you followed the restricted format instructions sufficiently, as that is typically where users problems occur .... In the most part, I will need to be general, as I can not provide specific guidance, as you did not tell us your openSUSE version. That is important, as there are differences in how the Software package management is done between openSUSE versions.

    Now first, please ensure you followed the instructions in the links provided to you by swerdna. In truth all you need is there.

    Assuming you tried that, can you confirm you installed libdvdcss2 and libdvdread3? Type:
    rpm -qa '*libdvd*'

    If libdvdcss2 is not installed, in a konsole with root permissions type:
    Code:
     su -c "rpm -Uvh http://download.videolan.org/pub/libdvdcss/1.2.9/rpm/libdvdcss2-1.2.9-1.i386.rpm"
    That is openSUSE version independent.

    libdvdread3 will either be on your opensuse CD/DVD or on the packman site. Where possible, choose the Packman packaged version.

    Please also check to ensure you have installed the packman packaged version of libxine1. Also confirm you have w32codec-all. xvid is another good package to install. Both from the Packman packagers web site.

    Note the easiest way to install packages such as mentioned is to setup your openSUSE software package manager to semi-automate the install. There are instructions here:
    Repositories - openSUSE-Community
    please follow those instructions.

    Quote Originally Posted by thalo View Post
    is it possible that it will work with one dvd and maybe not another?
    Yes. Some of the latest DVDs with newer encryption may not work.

    Also note if you go direct to the Packman web site, you can use their search engine in the upper left corner of their web page.
    PackMan :: Startseite
    Type in "dvd" or "mpeg" or "mp4" and you get all sorts of interesting 'hits'.

    Also note that packman's packaged smplayer/mplayer combination, plus vlc, are great for playing DVDs. Those are the applications that I use to play DVDs. If you setup your software package management repositories like suggested above, this all becomes very easy to install, to remove ... etc ....

    Apologies if I am telling you things you already know. This can be difficult to judge in a users post.

    Please post on this thread some more, if my post and Swerdna's does not help you.

    And thankyou for participating in our forum, and good luck.

  4. #4
    Join Date
    Jun 2008
    Location
    biggest little city
    Posts
    37

    Default Re: trouble with DVDs

    sorry about the version, it is 10.3. i will go through the post and follow your instructions.
    thanks

    i had been using vlc (i have used it a bunch before using linux) but have had problems with it recently. i will address that in a different topic specific for it.

  5. #5
    Join Date
    Jun 2008
    Location
    biggest little city
    Posts
    37

    Default Re: trouble with DVDs

    i checked to see if i have libdvdcss2 and it looks like i dont:

    libdvdnav-0.1.10-75
    libdvdcss-1.2.9-5.4
    libdvdread-devel-0.9.7-4
    libdvdnav-devel-0.1.10-75
    libdvdread3-0.9.7-4.pm.7

    i tried to install from the code given and it gives an error that there is conflict:

    file /usr/lib/libdvdcss.so.2.0.8 from install of libdvdcss2-1.2.9-1 conflicts with file from package libdvdcss-1.2.9-5.4

    i am going through yast to try and find libdvdcss2 to install and hopefully it will take care of the conflicts automatically.

    i am pretty sure that i have w32codec-all installed, it was something that i had picked up earlier from one of the links that swerdna provided. i will have to check about the packman libxine1 install, i dont recall if i did from their repository or not.

    thanks for your help.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: trouble with DVDs

    Quote Originally Posted by thalo View Post
    i tried to install from the code given and it gives an error that there is conflict:

    file /usr/lib/libdvdcss.so.2.0.8 from install of libdvdcss2-1.2.9-1 conflicts with file from package libdvdcss-1.2.9-5.4
    I have always used libdvdcss2 and not libdvdcss.

    I do not know if there is a difference. ... but if it were me, I would remove libdvdcss and replace it with libdvdcss2.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: trouble with DVDs

    Quote Originally Posted by thalo View Post
    i am pretty sure that i have w32codec-all installed
    You can always be certain. Just check! Type:
    rpm -q w32codec-all

    Quote Originally Posted by thalo View Post
    i will have to check about the packman libxine1 install, i dont recall if i did from their repository or not.
    Ok, but again, the check is no big thing. Simply check with:
    rpm -q libxine1

    Good luck!

  8. #8
    Join Date
    Jun 2008
    Location
    biggest little city
    Posts
    37

    Default Re: trouble with DVDs

    Quote Originally Posted by oldcpu View Post
    I have always used libdvdcss2 and not libdvdcss.

    I do not know if there is a difference. ... but if it were me, I would remove libdvdcss and replace it with libdvdcss2.
    i uninstalled libdvdcss and then installed with the code above. checked with the rpm -q command and it shows as being there.

    just curious, because i am really new to all this stuff especially installing with line codes, why would the libdvdcss2 not show up when i searched through yast? according to the line it is picking it up from videolan (vlc) and i have the vlc repositories set up. also is installing through a code better than through yast (or other similar manager)? i still need to read all about this kind of stuff, just curious?

    thanks again for your help, i will check and see how things turn out with the new developments.
    cheers

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: trouble with DVDs

    Quote Originally Posted by thalo View Post
    why would the libdvdcss2 not show up when i searched through yast?
    If libdvdcss2 is an installed rpm (in the rpm database) then it will show up in yast.

    Quote Originally Posted by thalo View Post
    according to the line it is picking it up from videolan (vlc) and i have the vlc repositories set up.
    I never use the videolan repositories myself (other than the rpm command to install libdvdcss2). I use packman repositories instead. Sometimes (on rare occasions) there can be conflicts between videolan and packman when attempting to install a package. I simply prefer to avoid that conflict possibility, and hence I avoid videolan. Others like videolan. Others like both (like you) and they can put up with the occasional hiccup.

    Quote Originally Posted by thalo View Post
    also is installing through a code better than through yast (or other similar manager)?
    IMHO it is easier to install through a software package manager than by an rpm command, as a software package manager will automatically look after the dependencies.

    But many package managers, such as zypper, smart, apt .. etc ... allow one to install applications from the command line, and they will also sort dependencies.

    I see this as sort of an apples vs oranges vs bananas discussion. Sometimes I like an apple, on other days an orange. If my install is simple, I will often do it from a command line with smart or zypper. But if I want a more global presentation, and I want to see a more graphical view of what is taking place, I will flash up yast, or smart-gui and install that way.

    I see this just as part of the beauty of Linux. One is offered a choice.

  10. #10

    Default Re: trouble with DVDs

    I always get DVD and everything working through Packman

    I use the Hacking 10.3 link that swerdna posted and it has always worked for that version of Linux in my case to get DVD and all unencrypted video media playing

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •