Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: How to enable runlevel 5 services

  1. #1
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    371

    Default How to enable runlevel 5 services

    I'm attempting to install a new ATI video card. I was following the instructions on en.opensuse.org/Ati for SuSE 10.3. The last step indicated perform a control alt backspace. After performing this linux boots into terminal mode, with no X-windows.

    The boot up text indicates that runlevel 5 services have been disabled.

    Any help would be appreciated.

  2. #2
    Menes Narmer NNTP User

    Default Re: How to enable runlevel 5 services

    Parthenolide wrote:

    > I'm attempting to install a new ATI video card. I was following the
    > instructions on en.opensuse.org/Ati for SuSE 10.3. The last step
    > indicated perform a control alt backspace. After performing this linux
    > boots into terminal mode, with no X-windows.
    >
    > The boot up text indicates that runlevel 5 services have been
    > disabled.
    >
    > Any help would be appreciated.


    It sounds like X didn't restart. Try 'startx' after logging in.

    --
    Menes Narmer
    menesofmemphis [at] gmail [dot] com

    "Unity and humility is the lesson all of history teaches."

  3. #3
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    371

    Default Re: How to enable runlevel 5 services

    startx yields:

    (EE) No devices detected
    Fatal server error
    no screens found

  4. #4
    Menes Narmer NNTP User

    Default Re: How to enable runlevel 5 services

    Parthenolide wrote:

    > (EE) No devices detected
    > Fatal server error
    > no screens found


    Okay. Make sure the new ati module is loaded. Run 'hwinfo --gfxcard', and
    see what module your graphics card is expecting to run or supports. Then
    run 'lsmod | grep -i $module_name' including the module name reported in
    the hwinfo output to see if the module is actually loading. Assuming it to
    be loading, then run 'sax2 -r' and configure the display based on your
    preferences.

    Let me know what happens...

    --
    Menes Narmer
    menesofmemphis [at] gmail [dot] com

    "Unity and humility is the lesson all of history teaches."

  5. #5

    Default Re: How to enable runlevel 5 services

    Sounds like something has gone wrong or you've missed steps.

    Is there any reason why you didn't want to use the one-click install at the very top?

    But firstly lets get the gui back /me hopes this is correct

    sax2 -r -m 0=vesa

    zero not o

    vesa will work but iirc radeon in place of vesa may to. Then if you've not tried I would try the one clicks, or add the ati repo.

  6. #6
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    371

    Default Re: How to enable runlevel 5 services

    Re: One clink install --> Yes, this is what I did.

    Re:
    lsmod | grep -i radeon, no info
    lsmod | grep -i nvidia
    lists the nvidia driver, and other info.

    The new radeon video card installed is PCI based.
    The old nvidia card is AGP based.
    Both cards are physically installed. I've used the bios setting to select PCI vs. AGP.

    hwinfo --gfxcard shows info on both cards

    This kind of looks like the nvidia card settings haven't entirely gone away, and the radeon card setting aren't fully installed.

  7. #7
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    371

    Default Re: How to enable runlevel 5 services

    re; sax2 -r -m 0-vesa results:
    SaX: wrong module syntax
    SaX: syntax -m CardNr=CardModule[....]

  8. #8

    Default Re: How to enable runlevel 5 services

    You need to tell it what card think you need change the sax command to 1 is a way of getting the info back.

    Think sax -p will list them then you change 0 to 1 I suspect before setting it up.

    Edit
    Think sax2 -r -m 1=fglrx is correct but unsure been a while since used sax and even longer with ati, and never had 2 graphic cards in one machine ;-)
    Last edited by FeatherMonkey; 10-Jun-2008 at 12:09. Reason: addition

  9. #9
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    371

    Default Re: How to enable runlevel 5 services

    re: sax2 -r -m 0=radeon
    SaX: initialing please wait ...
    your current configuration will not be read in

    no X-Server is running
    will start own server if needed

    SPP: prepare device [0] profile: Depth24
    prepare device [0] profile: NVidia
    calling device [0] profile script: NVidia
    including prepared profile(s).....

    SaX: startup

    xc: sorry could not start configuration server
    for details refer to the log file:
    /var/log/SaX.log

    abort

  10. #10

    Default Re: How to enable runlevel 5 services

    Post sax2 -p

    If the above suggestion doesn't work. You're telling sax to configure the agp with 0 but you need to tell it to configure the pci 1.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •