Results 1 to 4 of 4

Thread: Setting the trip_points for fan activity

  1. #1

    Default Setting the trip_points for fan activity

    Good morning everybody,

    I recently installed Suse 10.3 on my notebook and I have a problem to control the fan cooling. The trip_points which control the fan activities are defined (by whom ??) in /proc/acpi/thermal_zone/THRM/trip_points as

    critical (S5): 85 C
    passive: 57 C: tc1=4 tc2=3 tsp=150 devices=CPU0
    active[0]: 50 C: devices= FN1
    active[1]: 40 C: devices= FN2

    To avoid that my notebook runs hot I would like to change these values. With an old Redhat on my notebook I could just do
    echo -n "85:0:50:40:35" >
    /proc/acpi/thermal_zone/THRM/trip_points, that would change the values. But now a modification of the file is no longer allowed.
    A clue in the Suse-documentation made me put the following
    settings into the files /etc/powersave/thermal or /etc/powersave/scheme_performance or /etc/powersave/scheme_powersave, respectively:

    THERMAL_CRITICAL_0="85"
    THERMAL_PASSIVE_0="50"
    THERMAL_ACTIVE_0_0="40"
    THERMAL_ACTIVE_0_1="35"

    But this had no effect whatsoever.

    Can anybody teach me how to change the trip_points?
    Thanks for any help in advance.
    Wolfgang

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,834

    Default Re: Setting the trip_points for fan activity

    But now a modification of the file is no longer allowed.
    In my system it is:
    Code:
    -rw-r--r-- 1 root root 0 Jun  9 09:59 trip_points
    so root is allowed to write. Or do you mean something different by 'modification not allowed'?
    Henk van Velden

  3. #3

    Default Re: Setting the trip_points for fan activity

    Henk,

    I also have

    -rw-r--r-- 1 root root 0 9. Jun 19:06 trip_points

    but when I do (as root)

    echo -n "85:0:50:40:35" > trip_points, or try to edit with pico, say,

    I get the answer

    "Error writing to trip_points: Invalid argument" or "bash: echo: write error: Invalid argument". Are you able to write this file as root?

    Wolfgang

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,834

    Default Re: Setting the trip_points for fan activity

    Well, all in /proc is not realy a file, so strange things can happen. I only hoped it was that simple as write access for root.

    When I try vi on it and try to writ the (unchhanged) file it warns me that it is changed in themean time and asks if I realy waant ... I then choose 'no' being a bit careful. But it proves there is something there we do not understand fully. And then one should be carefully!

    Hope somebody else may jump in this thread.

    I also googled around a little bit and to me it seems that you try to do what others do (even in 2007). However nobody mentions its kernel level, so it might have changed.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •