View RSS Feed

oldcpu's meandering thoughts on Computers, GNU/Linux and openSUSE

Skype-4.0/4.2 on openSUSE-13.1

Rate this Entry
Skype may have no sound or corrupted sound for some users on openSUSE-13.1 and this blog re-iterates what has been posted elsewhere in different places.

The method I use for installing skype is per the openSUSE wiki (where at the time of writing this blog entry it had advice labeled for openSUSE-12.3 that nominally should work for openSUSE-13.1).

I had no sound from skype-4.2.0.11 on my Toshiba Satellite Z930 Ultrabook after my openSUSE-13.1 GM installation.

After some surfing (and also reading of a user with a similar problem in the openSUSE forum on the 13.1 RC2 thread) I made note of the following on this subject:



Where I quote from the news announcement:
PulseAudio 4.0 and Skype

By Arun | Published: August 2, 2013

This is a public service announcement for packagers and users of Skype and PulseAudio 4.0.

In PulseAudio 4.0, we added some code to allow us to deal with automatic latency adjustment more gracefully, particularly for latency requests under ~80 ms. This exposed a bug in Skype that breaks audio in interesting ways (no sound, choppy sound, playback happens faster than it should).

We’ve spoken to the Skype developers about this problem and they have been investigating the problem. In the mean time, we suggest that users and packagers work around this problem in the mean time.

If you are packaging Skype for your distribution, you need to change the Exec line in your Skype .desktop file as follows:

Exec=env PULSE_LATENCY_MSEC=60 skype %U

If you are a user, and your distribution doesn’t already carry this fix (as of about a week ago, Ubuntu does, and as of ~1 hour from now, Gentoo will), you need to launch Skype from the command line as follows:

$ PULSE_LATENCY_MSEC=60 skype

If you’re not sure if you’re hit but this bug, you’re probably not. :-)
I applied the fix noted above and Skype worked for me.

Submit "Skype-4.0/4.2 on openSUSE-13.1" to Digg Submit "Skype-4.0/4.2 on openSUSE-13.1" to del.icio.us Submit "Skype-4.0/4.2 on openSUSE-13.1" to StumbleUpon Submit "Skype-4.0/4.2 on openSUSE-13.1" to Google Submit "Skype-4.0/4.2 on openSUSE-13.1" to Facebook Submit "Skype-4.0/4.2 on openSUSE-13.1" to Twitter

Updated 19-Nov-2013 at 15:51 by oldcpu

Categories
Uncategorized

Comments

  1. oldcpu's Avatar
    I note that the latest 13.1 release notes also covers this:

    Code:
    5.12. Skype
    
    PulseAudio 4.0 exposes a bug in the current version of Skype for Linux
    (v4.2). Until Skype is fixed and updated, run skype from the command line:
    
    
    PULSE_LATENCY_MSEC=60 skype
    
    
    For more information about this bug, see http://arunraghavan.net/2013/08/pulseaudio-4-0-and-skype/.
    My thanks to user wolfi323 for pointing this out to me.
    .
  2. RADJankowski's Avatar
    Hi,

    The only way I can get Skype to work properly was to run it as root and disable Pulseaudio (did the latency thing too).

    After my upgrade from openSUSE 12.3 to 13.1 I lost line-in sound, and start-up sound. I disabled Pulseaudio and have line-in now, but still have no start-up sound?

    With previous 12.3 openSUSE, boot up sometimes hanged for bit with pulseaudio activated.

    Asus P5P43TD with on board Intel Audio ALC887

    p.s. this is my first blog so apology’s if it's in the wrong place.
  3. wolfi323's Avatar
    Quote Originally Posted by RADJankowski
    The only way I can get Skype to work properly was to run it as root and disable Pulseaudio (did the latency thing too).
    This sounds like a permissions issue then. Is your user's session listed by "loginctl"?
    See here f.e.: http://forums.opensuse.org/english/g...on-failed.html

    After my upgrade from openSUSE 12.3 to 13.1 I lost line-in sound, and start-up sound. I disabled Pulseaudio and have line-in now, but still have no start-up sound?
    Startup sound is disabled by default in recent KDE versions.
    You can configure one in "Configure Desktop"->"Application and System Notifications" though.
    Updated 12-Jan-2014 at 00:32 by oldcpu (Tried to fix quote syntax)
  4. RADJankowski's Avatar
    [QUOTE=wolfi323;bt958]
    This sounds like a permissions issue then. Is your user's session listed by "loginctl"?
    See here f.e.: [url]http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/491766-authorization-failed.html[/url]

    [QUOTE]
    After my upgrade from openSUSE 12.3 to 13.1 I lost line-in sound, and start-up sound. I disabled Pulseaudio and have line-in now, but still have no start-up sound?
    [/QUOTE]

    Startup sound is disabled by default in recent KDE versions.
    You can configure one in "Configure Desktop"->"Application and System Notifications" though.
    [/QUOTE]

    Thank you very much for that, I'll look in to it. Thanks again. Bob Jankowski
    Updated 12-Jan-2014 at 00:27 by oldcpu (Tried to fix quote syntax)
  5. kingv's Avatar
    The only correct decision to avoid being deaf and mute skype is:
    QUOTE:
    Until Skype is fixed and updated, run skype from the command line:


    PULSE_LATENCY_MSEC = 60 skype

    END QUOTE!

    Please, colleagues, limit obsession to write redundant. Asking others to read extra things they do not need the least useful.

    Forum is only for specific solutions and is a social network for common themes.
  6. kingv's Avatar
    Put in /home/your_user_ home_name/.local/share/applications/skype.destop

    Exec=env PULSE_LATENCY_MSEC=60 skype %U

    and remove old

    exec=skype %U

    save it


    And enjoy!
  7. pottam's Avatar
    Quicklaunch command : "PULSE_LATENCY_MSEC=60 skype" worked in all cases.
    Horrible buzzing noise when launching Skype on a laptop : problem solved.
    No sound on a first desktop : problem solved
    Bad sound on another one : problem solved.
    Thank you.
    Opensuse development team didn't have to change Pulseaudio latency for this piece of ****, Microsoft owned, NSA approved, we install because friends/family/children with no computer ethics use it. :shame: :shame: :shame:
  8. johnoshock's Avatar
    I disabled pulseaudio in Yast and Skype works fine... In fact all audio apps are working fine for me under 13.1 - Rosegarden, VLC, Mplayer, web browsers with plugins, I even use 2 soundcards.... and ALSA directly
    I think pulseaudio is the problem. Who needs it when everything works fine without it?
  9. noopmkop's Avatar
    www.cxcztrade.com - The shop cheap wholesale and retail Nike Air Jordan shoes,Air Max Shoes,Designer Handbags,Jewelry,Belts,hats,Jeans,sunglasses,Sports Jerseys online,high quality goods and Low price outlet from china,free shipping,Welcome to order.
    Air Jordan shoes $56 http://www.cxcztrade.com
    Jordan hats $10 http://www.cxcztrade.com
    Brand Belts $27 http://www.cxcztrade.com
    Jewelry $15 http://www.cxcztrade.com
    AAA Jeans $52 http://www.cxcztrade.com
    Sunglasses $16 http://www.cxcztrade.com
    NBA Jerseys $25 http://www.cxcztrade.com
    (DG MK LV) Handbags $46 http://www.cxcztrade.com
    Jordans Shoes http://www.cxcztrade.com
    Cheap Handbags http://www.cxcztrade.com
    Fashion Jewelry http://www.cxcztrade.com
    Cheap Jordans http://www.cxcztrade.com
    Cheap Jewelry http://www.cxcztrade.com
    Jordans for sale http://www.cxcztrade.com
    Cheap NBA Jerseys http://www.cxcztrade.com
    Cheap Jordan shoes http://www.cxcztrade.com
    JoRdaN REleasE DAtES http://www.cxcztrade.com
    Cheap Designer Handbags http://www.cxcztrade.com