View RSS Feed

caf4926

openSUSE 13.1 Multi-media and Restricted Format Installation Guide

Rating: 9 votes, 5.00 average.
openSUSE 13.1 Multimedia Guide


Revised and Simplified manual Method
This assumes you already have the default: OSS, NON-OSS, NON-OSS-Update and Update repositories.


*NOTE* You need to become su - in a terminal
Become super user in a terminal (su -). Learn how here


STEP 1: Add Packman and libdvdcss repositories

Code:
zypper ar -f http://packman.inode.at/suse/openSUSE_13.1/ packman
Code:
zypper ar -f http://opensuse-guide.org/repo/13.1/ libdvdcss
Now do
Code:
zypper ref
(a) to accept always and trust the signing key


FOR KDE USE:


Code:
zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs


FOR GNOME or XFCE or LXDE USE:

Code:
zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux vlc smplayer totem-browser-plugin h264enc x264 gstreamer-plugins-libav vlc-codecs

If you face choices. Look carefully for the option to let the package/s switch from openSUSE > packman


When done. Close the terminal. And open Yast > Software Management and Apply the Package Switcher on Packman.

KDE: Example of Packman switch in KDE

Gnome: Example of Packman switch in Gnome

If you encounter dependency errors: Eg: Errors You need to accept changes that allow vendor switch to Packman If you can't work it out. Ask in the forum.

---edit--- opus tools fix edited out as it is now resolved ---edit---


IMPORTANT NOTES:

  1. This multi-media install now separates kde and gnome. This should ensure a complete multi-media experience with the least difficulty.
  2. A good step by step multimedia check is available HERE
  3. Please do not use the VideoLan repository!
  4. OneClick options will be available here: Restricted formats - openSUSE Community Wiki

Submit "openSUSE 13.1 Multi-media and Restricted Format Installation Guide" to Digg Submit "openSUSE 13.1 Multi-media and Restricted Format Installation Guide" to del.icio.us Submit "openSUSE 13.1 Multi-media and Restricted Format Installation Guide" to StumbleUpon Submit "openSUSE 13.1 Multi-media and Restricted Format Installation Guide" to Google Submit "openSUSE 13.1 Multi-media and Restricted Format Installation Guide" to Facebook Submit "openSUSE 13.1 Multi-media and Restricted Format Installation Guide" to Twitter

Updated 24-Jan-2014 at 20:33 by caf4926

Categories
Technical Advice

Comments

Page 1 of 2 12 LastLast
  1. Oscar2007's Avatar
    This repo : http://opensuse-guide.org/repo/13.1/ libdvdcss missing now. However, only one package not install...
    Very good tutorial. Thanks!
  2. cjmannino's Avatar
    That is a great tutorial. I was struggling with codecs. Great Job !!!!
  3. Fraser_Bell's Avatar
    Hi, Carl. Thanks for the help, works well. However, not sure if you are interested in dealing with this:

    When I run the One-Click located here,

    http://opensuse-community.org/Restricted_formats

    it gives me, along with the multi-media files, the complete list of libre office to install.

    I have Apache Foundation's OpenOffice installed, and I am completely happy with that. I don't understand why, when I am installing multi-media, this wants to push libre office on me. Kind of reminds me of the Windows software installations, trying to sneak unrequested things in.

    Of course, I am able to deselect libre office, fortunately I looked over the list before executing the install, but I don't think it should be in there to begin with.

    Note that I opened the ymp file, find no mention in there of libre office, so wonder how else this is happening.

    btw: Got the same above problem when running the 12.3 one-click, as well as the 13.1 one-click.

    Thanks for all your hard work,
    -fb
  4. caf4926's Avatar
    By default any install of openSUSE will have some of the libre office base installed and post install updates especially on live dvd installs will fetch a good quantity of files that couldn't be put on the live media. I don't think their installation is particularly associated with the multimedia install.
  5. paschuller's Avatar
    Hi,

    Please note that your entry at http://forums.opensuse.org/showthread.php/407184-Multi-media-and-Restricted-Format-Installation-Guide?p=2597108#post2597108 (#9, viewed 2014-02-11) seems to provide a link that is faulty. It does not lead to this blog.

    Thank you for a correction.
  6. paschuller's Avatar
    Sorry, one more thing, in the "Important Notes", step 2, the link under "HERE" apparently has changed. I suggest to now use https://forums.opensuse.org/entry.php/36-MMCHECK-Version-2-45-Check-Your-Multimedia-in-16-Steps-Bash-Script-File .
  7. MozgFx's Avatar
    [b]Else my codeck list include next which wasn't included in author's list:[/b]
    gstreamer-0_10
    gstreamer-0_10-plugins-base
    faad2
    libfaad2
    a52dec
    twolame
    w32codec-all
    libavcodec52
    libavcodec54
    MPlayer
    faac
    libmpg123-0
    libquicktime0
    libxvidcore4
    libmad0
    libmad0-32bit
    libmpeg2-0
    libmac2
    mpeg2dec
    xvidcore
    libdcaenc0
    dirac
    libdirac_encoder0
    libdirac_decoder0
    gstreamer
    libdvdread3
    libdvdplay0
    libdvdnav4
    libavcodec55
    libavdevice52
    libavdevice54
    libavdevice55
    libavfilter1
    libavfilter2
    libavfilter3
    libavformat52
    libavformat54
    libavresample0
    libavresample1
    libavutil50
    libavutil51
    libmatroska6
    libx264-142
    libx264-142-32bit
    libvpx1
    libswfdec0_9_2
    libx265-10
    x265
    libvo-aacenc0
  8. maxray's Avatar
    thanks its great
  9. cyberoptiq's Avatar
    I get the following no matter how carefully I type the command provided for adding those 2 repositories:

    "If only one argument is used, it must be a URI pointing to a .repo file."

    this is for Gnome 13.1
  10. wolfi323's Avatar
    Quote Originally Posted by cyberoptiq
    I get the following no matter how carefully I type the command provided for adding those 2 repositories:

    "If only one argument is used, it must be a URI pointing to a .repo file."
    And what exactly are you typing in?
    Maybe use copy/paste.

    I just tried and the commands work fine as they are here.

    Since the message talks about "only one argument is used", you probably omitted the space character.

    OTOH, you can find those repos in YaST's Community Repositories list as well.
    Enter YaST->Software Repositories, click on "Add", choose "Community Repositories", and add the Packman and the libdvdcss repo there.
    Updated 25-Oct-2014 at 09:12 by wolfi323
  11. cyberoptiq's Avatar
    [QUOTE=wolfi323;bt1060]And what exactly are you typing in?
    Maybe use copy/paste.

    I just tried and the commands work fine as they are here.

    Since the message talks about "only one argument is used", you probably omitted the space character.

    OTOH, you can find those repos in YaST's Community Repositories list as well.
    Enter YaST->Software Repositories, click on "Add", choose "Community Repositories", and add the Packman and the libdvdcss repo there.[/QUOTE]

    I typed the command EXACTLY as it appears at the top with spaces where they need to be...more than once I tried and it gives me the same error message each time....btw: I also su'd into root as instructed above....I've only been working with Unix/Linux since 1995 so I don't think it's my typing....
  12. wolfi323's Avatar
    Quote Originally Posted by cyberoptiq
    I typed the command EXACTLY as it appears at the top with spaces where they need to be...more than once I tried and it gives me the same error message each time....btw: I also su'd into root as instructed above....I've only been working with Unix/Linux since 1995 so I don't think it's my typing....
    Well, the EXACT same works fine here (and yes, I did copy/paste it to the terminal window), so the problem must be at your end...

    Are you actually using 13.1 and is it fully up-to-date? In earlier versions zypper might have had different command line switches.
    And your error message clearly states that you only specified _one_ argument. Maybe you typed Alt+Space instead of Space or something like that?

    Other than that I have no idea.

    But again, as I wrote already, you can find the same repos in YaST's Communty Repositories, so just add them there if you cannot do it with zypper for whatever reason.
  13. cyberoptiq's Avatar
    I also tried in YaST as you suggested and it gave me this error:

    "Unable to create repository from URL 'http://packman.inode.at/suse/openSUSE_13.1/ packman'. Change the URL and try again?"

    So it's obviously not an error on my part....
  14. wolfi323's Avatar
    Quote Originally Posted by cyberoptiq
    "Unable to create repository from URL 'http://packman.inode.at/suse/openSUSE_13.1/ packman'. Change the URL and try again?"

    So it's obviously not an error on my part....
    That's even more a problem on your side, as you cannot reach the server apparently.

    Do you have a working internet connection?
    Are you behind a proxy?
  15. cyberoptiq's Avatar
    [QUOTE=wolfi323;bt1062]Are you actually using 13.1 and is it fully up-to-date? In earlier versions zypper might have had different command line switches.
    And your error message clearly states that you only specified _one_ argument. Maybe you typed Alt+Space instead of Space or something like that?[/QUOTE]

    This is a new install of 13.1 done yesterday. The command above has 2 arguments (a r ) and they are both included when I typed it in manually. Like I said, I've been typing Unix/Linux commands manually since '95 and I can see when I make an error. But now YaST is complaining about the URL so I don't think it's me....thanks for your help.....
  16. cyberoptiq's Avatar
    [QUOTE=wolfi323;bt1064]That's even more a problem on your side, as you cannot reach the server apparently. Do you have a working internet connection? Are you behind a proxy?[/QUOTE]

    Obviously I have a good solid Internet connection since I'm able to reply to you....I'm on my own home network and able to access Google, Outlook.com, and this website.....
  17. wolfi323's Avatar
    Quote Originally Posted by cyberoptiq
    Like I said, I've been typing Unix/Linux commands manually since '95 and I can see when I make an error.
    So what. Not all typing mistakes are obvious.

    Why are you getting so upset?

    The commands are correct, and the server is running and reachable. Period.
    I was just suggesting a possible (and even likely) cause.

    If you are such an expert and infallable, why do you even ask for help?

    But now YaST is complaining about the URL so I don't think it's me....thanks for your help.....
    I didn't say it's you.
    But there is a problem on your side, as I can reach the server just fine here.
    See also my previous reply.
  18. wolfi323's Avatar
    Quote Originally Posted by cyberoptiq
    Obviously I have a good solid Internet connection since I'm able to reply to you....I'm on my own home network and able to access Google, Outlook.com, and this website.....
    And how should I know?
    You could be writing this from a second computer.

    So, are you behind a proxy?
    Just because your browser has the correct proxy settings, doesn't mean that zypper (which runs as root) has.

    Can you refresh your other online repos or do you get errors as well?
    Code:
    zypper ref
    Can you ping the server?
    Code:
    ping packman.inode.at
    Or the one from the Community List:
    Code:
    ping ftp.gwdg.de
  19. cyberoptiq's Avatar
    [QUOTE=wolfi323;bt1067]So what. Not all typing mistakes are obvious.

    Why are you getting so upset?

    The commands are correct, and the server is running and reachable. Period.
    I was just suggesting a possible (and even likely) cause.

    If you are such an expert and infallable, why do you even ask for help?


    I didn't say it's you.
    But there is a problem on your side, as I can reach the server just fine here.
    See also my previous reply.[/QUOTE]

    A) I'm not getting upset....on the contrary I'm trying to work with you....don't be hasty to jump to conclusions....I was merely stating that my typing I double-check when performing these types of tasks as I don't want to screw up my system....I'm no expert and no sysadmin....I'm just a guy with 23 years of working in I/T but never in a sysadmin role....always worked in command centers or NOC's as some refer to them.....

    B) I never accused you of anything or that you were implying that I was at fault....again on the contrary I'm only trying to work with you to better understand what may be wrong....

    C) It appears YaST, for some odd reason, does not like the command and neither does the command line. That's why I came here seeking advice....there's no need to for anyone to bash someone asking for help....at work everyone loves coming to me for solutions, if I can help them, because I'm very patient with them and know that at one time when I started in the I/T field back in 1991 I, too, was green as the grass that grows in the park.....also because those whom I sought out for advice when I first started were patient with me....
  20. cyberoptiq's Avatar
    [QUOTE=wolfi323;bt1068]So, are you behind a proxy?
    Just because your browser has the correct proxy settings, doesn't mean that zypper (which runs as root) has.

    Can you refresh your other online repos or do you get errors as well?
    [code]zypper ref[/code]

    Can you ping the server?
    [CODE]ping packman.inode.at[/CODE]
    Or the one from the Community List:
    [CODE]ping ftp.gwdg.de[/CODE][/QUOTE]

    Not behind a proxy at my end....and both pings worked fine as did the repo refresh.....
Page 1 of 2 12 LastLast