• HowTo Upgrade openSUSE 11.4 to Tumbleweed

    This article is obsolete. It will only work from now until the date when openSUSE 12.1 is released. The new article, which works from now (9 Novenber 2011) onwards is located here: HowTo Upgrade openSUSE 12.x to Tumbleweed. Despite the title, it works for 11.4 just fine.

    If you have a working version of Tumbleweed based on openSUSE 11.4, this article might interest you: HowTo Prepare 11.4-based Tumbleweed for openSUSE 12.1

    Warning: Tumbleweed can be a challenge for new users: The system is gradually and perpetually upgraded with new RPMs appearing almost daily in the Tumbleweed repositories. Zypper is the recommended tool for keeping your Tumbleweed distro up to date. You will receive messages from zypper regarding dependencies where you will make choices. If that could make you stressed, don't install Tumbleweed.

    First, have a look at the Tumbleweed Portal at openSUSE.org. Next join the mailing list mentioned there.

    Be aware that your distro will no longer be openSUSE 11.4 after the upgrade, it will be openSUSE Tumbleweed (based on openSUSE 11.4)

    There are three principle steps:
    1. make all necessary software updates plus installations of Packman's 11.4 RPMs before you do the upgrade
    2. add the Tumbleweed Repository and change the Packman repository to Packman-all_of_Tumbleweed
    3. use zypper to upgrade your distro from openSUSE 11.4 to openSUSE Tumbleweed

    Repositories:
    OpenSUSE 11.4 users should already have these four key repositories installed/activated as a matter of course:
    • openSUSE 11.4 oss
    • openSUSE 11.4 non-oss
    • Updates for openSUSE 11.4
    • Packman for openSUSE 11.4

    You might also have one or more of these Community repositories activated:
    • Main Repository Contrib
    • NVIDIA or ATI Repository
    • other specialist repos like Google Earth etc


    You shouldn't have any factory repos activated unless you really know what you're doing.

    Now, before anything else, do step 1 above (make all necessary software updates plus installations of Packman's 11.4 RPMs before you start the Tumbleweed-upgrade process).

    Next you rearrange your repos quite simply:
    • disable/remove any 11.4 Packman repositories
    • disable/remove NVIDIA or ATI repos (you have to install drivers for these "the hard way" after each kernel update).
    • add "openSUSE Tumbleweed" from here:
      HTML Code:
      http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/
    • add "Tumbleweed all of Packman" from here:
      HTML Code:
      http://packman.inode.at/suse/openSUSE_Tumbleweed


    You can use zypper to do that or go to Yast --> Software --> Software Repositories.

    When you finish you should have repos as listed by "zypper ls" somewhat like this:
    Code:
    john@tumbleweed114:~> zypper ls
    #  | Alias                            | Name                             | Enabled | Refresh | Type    
    ---+----------------------------------+----------------------------------+---------+---------+---------
    1  | Tumbleweed                       | Tumbleweed                       | Yes     | Yes     | rpm-md  
    2  | Updates-for-openSUSE-11.4        | Updates for openSUSE 11.4        | Yes     | Yes     | rpm-md  
    3  | openSUSE_Tumbleweed              | Tumbleweed_AllOfPackman          | Yes     | Yes     | rpm-md  
    4  | repo-non-oss 11.4                | openSUSE-11.4-Non-Oss            | Yes     | Yes     | yast2   
    5  | repo-oss 11.4                    | openSUSE-11.4-Oss                | Yes     | Yes     | yast2
    Finally, run the upgrade. Become root in a console window and run this command
    Code:
    zypper dup
    PS if you prefer to do a dummy run, then run this version first, using the dummy-run switch -D, like so: zypper dup -D

    Updating your RPMs from this point forwards: Tumleweed is a distro with dynamic software. The RPMs are constantly evolving. Here is a strategy for upgrading your RPMs to keep abreast of the developing Tumbleweed distro. It's not the only strategy. Feel free to use some other strategy.

    Tumbleweed is being maintained by Greg K-H (see openSUSE Factory) who maintains the packages in the repos. He advocates having the following repos attached and enabled for going forward with the new distro (Tumbleweed): openSUSE Update repo, openSUSE-oss repo, openSUSE-non-oss repo and Tumbleweed repo/s. (reference: Gmane Loom)

    This translates as follows:
    Mandatory Repos:
    Tumbleweed --> http: //download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/
    opensuse-oss --> http: //download.opensuse.org/distribution/11.4/repo/oss/
    opensuse-non-oss --> http: //download.opensuse.org/distribution/11.4/repo/non-oss/
    opensuse-updates --> http: //download.opensuse.org/update/11.4/

    Also Recommended:
    Tumbleweed All of Packman --> http: //packman.inode.at/suse/openSUSE_Tumbleweed

    Additional Options. If you use special packages, you can/should enable the special repos, for example:
    opensuse-contrib --> http: //download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/
    Tumbleweed VirtualBox --> http: //download.virtualbox.org/virtualbox/rpm/opensuse/11.4/
    Others as required..............

    Command for regular updates: zypper dup
    Continue to use a simple dup with the command:
    Code:
    zypper   dup
    I recommend this approach because it's the method used and recommended by the developer (Greg K-H, maintainer of the Tumbleweed repos).
    This article was originally published in forum thread: HowTo: upgrade openSUSE 11.4 to Tumbleweed started by swerdna View original post
    Comments 6 Comments
    1. creatura85's Avatar
      creatura85 -
      You may change the address of the virtual box repo to this one: http://download.virtualbox.org/virtu...opensuse/11.4/ for Tumbleweed users
    1. divinsal's Avatar
      divinsal -
      Great article. It really helped me get to Tumbleweed. Thanks
    1. swerdna's Avatar
      swerdna -
      Thanks creatura85. (BTW I edited your address cos it had a typo, didn't want readers to get puzzled)
    1. creatura85's Avatar
      creatura85 -
      No problem Swerdna, glad to be of help.
    1. mikronimo's Avatar
      mikronimo -
      I'd like to try opensuse kde (which already use with PCLinuxOS). My question is: if I install the current 11.4 (or even the 12.1 rc) and apply to it the tumbleweed repository, can i expect to update to 12.1 (when it comes out), or is it better install the 12.1 directly and then apply the tumbleweed repository? I understand that the question seems strange (if I make a rolling distro, it should update itself automatically), but i'm not sure, so... Hoping my english is clear and correct, thanks in advance for your response and attention.
    1. Winux2's Avatar
      Winux2 -
      FYI: openSUSE:Contrib - openSUSE
      Please note that from the openSUSE 12.1 release onwards, the Contrib repository is deprecated!
      If you are a user, rest assured that the vast majority of these packages is now integrated in the main repository of openSUSE. Some of them are available on the build service and you can find them using the [software.opensuse.org/ software search]. If you're a developer, please push your packages to Factory! This is not complicated and gets your package to all openSUSE users out there!