• KDE 4.10 Upgrade for 12.2

    How to Upgrade your openSUSE 12.2 Install to KDE 4.10

    Caveat: As with any upgrade there are risks. openSUSE 12.2 has a perfectly usable version of KDE. This upgrade requires a vendor or package switch to a non standard repository (it is though considered stable and safe) and as such it requires user intervention, such intervention will differ due to factors beyond the control of the author of this guide. This basically means, YOU are responsible for your system and the choices you make. If you are at any time unsure about a choice required during the upgrade, we suggest you make a note and ask for help before proceeding. It is recommended that any upgrade take place on a fully patched/updated system. If you have been using KDE49, you will need to remove/disable these repos before adding the new ones for KDE410 and proceeding with this upgrade.


    STEP 1: Add the new repositorie/s
    Use your mouse to copy and paste this code in to a su - terminal
    Video link of becoming su -

    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/Release:/410/openSUSE_12.2/ kde410


    You may also like to add the Extras repository:

    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_410_openSUSE_12.2/ kde-extra


    STEP 2: Refresh repos and accept key


    Code:
    zypper ref
    When requested use (a) to accept the key

    Now close the terminal and open Yast > Software Management



    STEP 3: Switch Packages to the New Repository kde410


    The following is an example of the principle of the switch. You need to view by Repository and select kde410 on the left side, then click 'Switch System Packages.

    Applying a switch on KDE repo

    Notice there 5 steps shown in this image.
    Comments 26 Comments
    1. SLK021's Avatar
      SLK021 -
      Quote Originally Posted by kerijan2003 View Post
      And how "did" you resolve the k3b codecs?
      Deleted them, they have no use to me
    1. keellambert's Avatar
      keellambert -
      kerijan2003

      What problem?

      The new update was refused. Stayed with what was there before.

      Sun Feb 10 02:30:49 CET 2013
      michael@linux-xjw5:~/Documents> rpm -qa | grep k3b
      k3b-lang-2.0.2-15.45.noarch
      k3b-2.0.2-15.45.x86_64
      k3b-codecs-2.0.2-15.45.x86_64
    1. ncfc001's Avatar
      ncfc001 -
      Since I had updated the system just before update to 4.10, I didn't have any problems.

      Thanks for the guide.

      Regards,
    1. wakou's Avatar
      wakou -
      Quote Originally Posted by ncfc001 View Post
      Since I had updated the system just before update to 4.10, I didn't have any problems.

      Thanks for the guide.

      Regards,
      Just to report, it all went flawlessly, only the k3b needed intervention. Even Apper works no problems..
    1. wakou's Avatar
      wakou -
      ..except that kwallet is now not working. I workaround by configure desktop>account details>kwallet Disable
      then enable, then run manager, then open from manager then get new email. Not satisfactory!
    1. caf4926's Avatar
      caf4926 -
      Quote Originally Posted by wakou View Post
      ..except that kwallet is now not working. I workaround by configure desktop>account details>kwallet Disable
      then enable, then run manager, then open from manager then get new email. Not satisfactory!
      I have no problem with kwallet