• KDE 4.10 Upgrade for 12.2

    How to Upgrade your openSUSE 12.2 Install to KDE 4.10

    Caveat: As with any upgrade there are risks. openSUSE 12.2 has a perfectly usable version of KDE. This upgrade requires a vendor or package switch to a non standard repository (it is though considered stable and safe) and as such it requires user intervention, such intervention will differ due to factors beyond the control of the author of this guide. This basically means, YOU are responsible for your system and the choices you make. If you are at any time unsure about a choice required during the upgrade, we suggest you make a note and ask for help before proceeding. It is recommended that any upgrade take place on a fully patched/updated system. If you have been using KDE49, you will need to remove/disable these repos before adding the new ones for KDE410 and proceeding with this upgrade.


    STEP 1: Add the new repositorie/s
    Use your mouse to copy and paste this code in to a su - terminal
    Video link of becoming su -

    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/Release:/410/openSUSE_12.2/ kde410


    You may also like to add the Extras repository:

    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_410_openSUSE_12.2/ kde-extra


    STEP 2: Refresh repos and accept key


    Code:
    zypper ref
    When requested use (a) to accept the key

    Now close the terminal and open Yast > Software Management



    STEP 3: Switch Packages to the New Repository kde410


    The following is an example of the principle of the switch. You need to view by Repository and select kde410 on the left side, then click 'Switch System Packages.

    Applying a switch on KDE repo

    Notice there 5 steps shown in this image.
    Comments 26 Comments
    1. caf4926's Avatar
      caf4926 -
      Please be advised that currently STEP 1 in this article has broken code tag formatting and a bug in the forum software is preventing any update at this time

      The correct STEP 1 is

      Code:
      zypper ar -f http://download.opensuse.org/repositories/KDE:/Release:/410/openSUSE_12.2/ kde410
      Thank you
    1. robertorc87's Avatar
      robertorc87 -
      thx I spotted the new repos and was already updating.

      Maybe it would be good to update the KDE repo page at KDE repositories - openSUSE for new/n00bs users.
    1. caf4926's Avatar
      caf4926 -
      Quote Originally Posted by robertorc87 View Post
      thx I spotted the new repos and was already updating.

      Maybe it would be good to update the KDE repo page at KDE repositories - openSUSE for new/n00bs users.
      I expect Raymond will get to that in due course
    1. JudasDisciple's Avatar
      JudasDisciple -
      There's a few things that needed to be checked when switching repos, namely the packagekit and Apper. Now what if my KDE doesn't work after the update because of it?
    1. caf4926's Avatar
      caf4926 -
      Quote Originally Posted by JudasDisciple View Post
      There's a few things that needed to be checked when switching repos, namely the packagekit and Apper. Now what if my KDE doesn't work after the update because of it?
      It does work
      Apper is a big upgrade and some folks remove apper completely
    1. JudasDisciple's Avatar
      JudasDisciple -
      Nevermind. You're right. It does work.

      Hold it. Now if I want to update my software it's asking me to downgrade to 4.8.5!
    1. caf4926's Avatar
      caf4926 -
      You need to stop using Online Update or Apper or you will break your system

      To update use

      Code:
      zypper up
      I have deleted Apper from my system
    1. JudasDisciple's Avatar
      JudasDisciple -
      But why is this doing it now, considering I never had a problem with any of the KDE 4.9 packages?
    1. caf4926's Avatar
      caf4926 -
      Because the updated Apper also has a notification now, that continues to remind you, even if Apper is set to Never check updates.

      Even before though, if you had run Online Update it would have done the same thing.

      You can compare the behaviour by comparing:

      Code:
      zypper lp
      and
      Code:
      zypper lu
    1. Joeg1484's Avatar
      Joeg1484 -
      Is this a simple upgrade for those of us that upgraded to KDE 4.9 AND use packman?

      I imagine that I would have to remove the 4.9 and extra repo before adding in the new ones, then zypper dup --from kde410 --from kde410_extra.

      Then change back the packages to packman?

      Thanks!

      Joe
    1. SLK021's Avatar
      SLK021 -
      Quote Originally Posted by caf4926 View Post
      Because the updated Apper also has a notification now, that continues to remind you, even if Apper is set to Never check updates.

      Even before though, if you had run Online Update it would have done the same thing.

      You can compare the behaviour by comparing:

      Code:
      zypper lp
      and
      Code:
      zypper lu
      I can see the packages as you say
      Code:
      openSUSE:~ # zypper lpLoading repository data...
      Reading installed packages...
      
      
      Repository           | Name              | Version | Category    | Status | Summary                                          
      ---------------------+-------------------+---------+-------------+--------+--------------------------------------------------
      openSUSE-12.2-Update | openSUSE-2012-588 | 1       | recommended | needed | KDE: 4.8.5 stable update                         
      openSUSE-12.2-Update | openSUSE-2012-685 | 1       | recommended | needed | kdebase4-openSUSE: use the correct 12.2 rpm query
      So just remove Apper?
    1. SLK021's Avatar
      SLK021 -
      Quote Originally Posted by Joeg1484 View Post
      Is this a simple upgrade for those of us that upgraded to KDE 4.9 AND use packman?

      I imagine that I would have to remove the 4.9 and extra repo before adding in the new ones, then zypper dup --from kde410 --from kde410_extra.

      Then change back the packages to packman?

      Thanks!

      Joe
      I have not changed packman during or after the update, just had to resolve k3b codecs. All works good.
    1. Joeg1484's Avatar
      Joeg1484 -
      Quote Originally Posted by SLK021 View Post
      I have not changed packman during or after the update, just had to resolve k3b codecs. All works good.

      I just added the repos and then tried to do the upgrade, but, to no surprise, lots of dep errors:

      To start...

      Code:
      zypper dup --from KDE_410 --from KDE_Extra
      Retrieving repository 'Packman Repository' metadata .................................................................................[done]
      Building repository 'Packman Repository' cache ......................................................................................[done]
      Loading repository data...
      Reading installed packages...
      Computing distribution upgrade...
      2 Problems:
      Problem: PackageKit-branding-openSUSE-12.2-2.1.1.noarch requires PackageKit = 0.7.4, but this requirement cannot be provided
      Problem: k3b-codecs-2.0.2-15.96.x86_64 requires k3b = 2.0.2-15.96, but this requirement cannot be provided
      
      
      Problem: PackageKit-branding-openSUSE-12.2-2.1.1.noarch requires PackageKit = 0.7.4, but this requirement cannot be provided
        uninstallable providers: PackageKit-0.7.4-2.9.1.i586[repo-oss]
                         PackageKit-0.7.4-2.9.1.x86_64[repo-oss]
                         PackageKit-0.7.4-2.12.1.i586[repo-update]
                         PackageKit-0.7.4-2.12.1.x86_64[repo-update]
       Solution 1: deinstallation of PackageKit-branding-openSUSE-12.2-2.1.1.noarch
       Solution 2: keep obsolete PackageKit-0.7.4-2.16.1.x86_64
       Solution 3: keep obsolete PackageKit-0.7.4-2.16.1.x86_64
       Solution 4: break PackageKit-branding-openSUSE-12.2-2.1.1.noarch by ignoring some of its dependencies
      
      
      Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c):
      If I choose solution 2 as I have done most of the time before, I keep getting these for most other packages... Then...

      Code:
      Resolving dependencies...                                                                                                                       
      Computing distribution upgrade...                                                                                                               
      2 Problems:                                                                                                                                     
      Problem: PackageKit-gstreamer-plugin-0.8.7-7.1.x86_64 requires libpackagekit-glib2.so.16()(64bit), but this requirement cannot be provided      
      Problem: PackageKit-branding-openSUSE-12.2-2.1.1.noarch requires PackageKit = 0.7.4, but this requirement cannot be provided                     
                                                                                                                                                       
      Problem: PackageKit-gstreamer-plugin-0.8.7-7.1.x86_64 requires libpackagekit-glib2.so.16()(64bit), but this requirement cannot be provided       
        uninstallable providers: libpackagekit-glib2-16-0.8.7-7.1.x86_64[KDE_410]                                                                       
       Solution 1: deinstallation of PackageKit-gstreamer-plugin-0.7.4-2.16.1.x86_64
       Solution 2: install PackageKit-gstreamer-plugin-0.8.7-7.1.i586 despite the inferior architecture
       Solution 3: keep obsolete PackageKit-gstreamer-plugin-0.7.4-2.16.1.x86_64
       Solution 4: do not keep PackageKit-0.7.4-2.16.1.x86_64 installed
       Solution 5: break PackageKit-gstreamer-plugin-0.8.7-7.1.x86_64 by ignoring some of its dependencies
      
      
      Choose from above solutions by number or skip, retry or cancel [1/2/3/4/5/s/r/c] (c):
      It never ends...

      Here is my repo list:

      Code:
      Verbosity: 1
      #  | Alias                     | Name                               | Enabled | Refresh
      ---+---------------------------+------------------------------------+---------+--------
       1 | KDE_410                   | KDE_410                            | Yes     | Yes    
       2 | KDE_Extra                 | KDE_Extra                          | Yes     | Yes    
       3 | Packman Repository        | Packman Repository                 | Yes     | Yes    
       4 | libdvdcss repository      | libdvdcss repository               | Yes     | Yes    
       5 | repo-debug                | openSUSE-12.2-Debug                | No      | Yes    
       6 | repo-debug-update         | openSUSE-12.2-Update-Debug         | No      | Yes    
       7 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No      | Yes    
       8 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes    
       9 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes    
      10 | repo-source               | openSUSE-12.2-Source               | No      | Yes    
      11 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes    
      12 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes
      In additioan, it appears that the mirrors are not all in sync because I get retry errors on some packages too...

      Any ideas?

      Thanks!
      Joe
    1. mmarif4u's Avatar
      mmarif4u -
      Any news for openSUSE 12.1 repos?
    1. SLK021's Avatar
      SLK021 -
      Quote Originally Posted by Joeg1484 View Post
      I just added the repos and then tried to do the upgrade, but, to no surprise, lots of dep errors:

      To start...

      Code:
      zypper dup --from KDE_410 --from KDE_Extra
      Retrieving repository 'Packman Repository' metadata .................................................................................[done]
      Building repository 'Packman Repository' cache ......................................................................................[done]
      Loading repository data...
      Reading installed packages...
      Computing distribution upgrade...
      2 Problems:
      Problem: PackageKit-branding-openSUSE-12.2-2.1.1.noarch requires PackageKit = 0.7.4, but this requirement cannot be provided
      Problem: k3b-codecs-2.0.2-15.96.x86_64 requires k3b = 2.0.2-15.96, but this requirement cannot be provided
      
      
      Problem: PackageKit-branding-openSUSE-12.2-2.1.1.noarch requires PackageKit = 0.7.4, but this requirement cannot be provided
        uninstallable providers: PackageKit-0.7.4-2.9.1.i586[repo-oss]
                         PackageKit-0.7.4-2.9.1.x86_64[repo-oss]
                         PackageKit-0.7.4-2.12.1.i586[repo-update]
                         PackageKit-0.7.4-2.12.1.x86_64[repo-update]
       Solution 1: deinstallation of PackageKit-branding-openSUSE-12.2-2.1.1.noarch
       Solution 2: keep obsolete PackageKit-0.7.4-2.16.1.x86_64
       Solution 3: keep obsolete PackageKit-0.7.4-2.16.1.x86_64
       Solution 4: break PackageKit-branding-openSUSE-12.2-2.1.1.noarch by ignoring some of its dependencies
      
      
      Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c):
      If I choose solution 2 as I have done most of the time before, I keep getting these for most other packages... Then...

      Code:
      Resolving dependencies...                                                                                                                       
      Computing distribution upgrade...                                                                                                               
      2 Problems:                                                                                                                                     
      Problem: PackageKit-gstreamer-plugin-0.8.7-7.1.x86_64 requires libpackagekit-glib2.so.16()(64bit), but this requirement cannot be provided      
      Problem: PackageKit-branding-openSUSE-12.2-2.1.1.noarch requires PackageKit = 0.7.4, but this requirement cannot be provided                     
                                                                                                                                                       
      Problem: PackageKit-gstreamer-plugin-0.8.7-7.1.x86_64 requires libpackagekit-glib2.so.16()(64bit), but this requirement cannot be provided       
        uninstallable providers: libpackagekit-glib2-16-0.8.7-7.1.x86_64[KDE_410]                                                                       
       Solution 1: deinstallation of PackageKit-gstreamer-plugin-0.7.4-2.16.1.x86_64
       Solution 2: install PackageKit-gstreamer-plugin-0.8.7-7.1.i586 despite the inferior architecture
       Solution 3: keep obsolete PackageKit-gstreamer-plugin-0.7.4-2.16.1.x86_64
       Solution 4: do not keep PackageKit-0.7.4-2.16.1.x86_64 installed
       Solution 5: break PackageKit-gstreamer-plugin-0.8.7-7.1.x86_64 by ignoring some of its dependencies
      
      
      Choose from above solutions by number or skip, retry or cancel [1/2/3/4/5/s/r/c] (c):
      It never ends...

      Here is my repo list:

      Code:
      Verbosity: 1
      #  | Alias                     | Name                               | Enabled | Refresh
      ---+---------------------------+------------------------------------+---------+--------
       1 | KDE_410                   | KDE_410                            | Yes     | Yes    
       2 | KDE_Extra                 | KDE_Extra                          | Yes     | Yes    
       3 | Packman Repository        | Packman Repository                 | Yes     | Yes    
       4 | libdvdcss repository      | libdvdcss repository               | Yes     | Yes    
       5 | repo-debug                | openSUSE-12.2-Debug                | No      | Yes    
       6 | repo-debug-update         | openSUSE-12.2-Update-Debug         | No      | Yes    
       7 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No      | Yes    
       8 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes    
       9 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes    
      10 | repo-source               | openSUSE-12.2-Source               | No      | Yes    
      11 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes    
      12 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes
      In additioan, it appears that the mirrors are not all in sync because I get retry errors on some packages too...

      Any ideas?

      Thanks!
      Joe
      Just hit No. 1
    1. caf4926's Avatar
      caf4926 -
      Quote Originally Posted by mmarif4u View Post
      Any news for openSUSE 12.1 repos?
      I don't think it's happening
    1. caf4926's Avatar
      caf4926 -
      Quote Originally Posted by SLK021 View Post
      Just hit No. 1
      Correct .
    1. keellambert's Avatar
      keellambert -
      @caf4926

      Thx for the info.

      Updated today to KDE4.10 over KDE4.9 on laptop and pc

      Repo used: Index of /repositories/KDE:/Release:/410/openSUSE_12.2

      After install finished via yast, normal reboot/ power off did not work,
      in terminal, cmd as root 'reboot' or 'poweroff' did

      Only things noticed, two packages set to earlier versions,
      phonon-backend-gstreamer-0_10-4.6.3-36.1.x86_64 to phonon-backend-gstreamer-0_10-4.6.2-33.1.x86_64
      synaptiks-0.8.1-31.1.noarch to synaptiks-0.8.1-30.2.noarch
      and kdebase4-workspace-plasma-engine-akonadi-4.09.5-4.1.x86_64 deleted

      not loss of functionality notice, all is working well

      Linux 3.7.6-2-desktop #1 SMP PREEMPT Tue Feb 5 15:27:05 UTC 2013 (d5cefdd) x86_64 GNU/Linux
    1. caf4926's Avatar
      caf4926 -
      After install finished via yast, normal reboot/ power off did not work,
      in terminal, cmd as root 'reboot' or 'poweroff' did
      Same here .
    1. kerijan2003's Avatar
      kerijan2003 -
      Quote Originally Posted by SLK021 View Post
      I have not changed packman during or after the update, just had to resolve k3b codecs. All works good.
      And how "did" you resolve the k3b codecs?