Blog Comments

  1. oldcpu's Avatar
    I successfully installed a Bluetooth rechargeable mouse to work with this Lenovo X1 Carbon Generation-9 laptop, and it works well.

    The mouse is a (Chinese manufacturer) Inphic PM6BS Three mode mouse, where it can connect to one's PC via either:
    • 2.4 GHz wireless (the mouse comes with a USB wireless receiver), or
    • Bluetooth-3.0, or
    • Bluetooth-5.0

    Instructions for the mouse came in many languages: Chinese, Italian, Spanish, German, French and English language. According to the very short/succinct manual that came with the mouse, it is compatible with GNU/Linux versions that have a kernel of 2.6+ .

    The mouse is a bit larger than I am normally used to, but functionally its much more capable than the dirt cheap 2.4GHz wireless mouse that I have been using to date.
    • Dimensions : 4.7 x 3.2 x 1.4 inches
    • Weight: 3.68 ounces (about 0.1 kg).

    From lsusb, the 2.4 GHZ wireless receiver is a
    Bus 003 Device 010: ID 1ea7:0064 SHARKOON Technologies GmbH 2.4GHz Wireless rechargeable vertical mouse [More&Better]
    I have not tried to use this receiver (with the 2.4GHz wireless) yet, as the Bluetooth-5.0 interface works fine. I do note that Linux claims GNU/Linux compatibility with the 2.4GHz wireless receiver.

    I connected from a KDE desktop on LEAP-15.3 to this mouse using Bluetooth-5.0. It was incredibly easy to setup ... Before use, I initially charged it for only about 30-minutes by plugging it into a USB port on my laptop (I may need to charge it more later).

    I then in my Lenovo X1 Carbon's LEAP-15.3 KDE desktop clicked on the Bluetooth icon (bottom right corner icon) and I selected to add a Bluetooth device. Then on the mouse I switched its ON/OFF switch to ON.

    The mouse switched on in 2.4GZ wireless mode, so I pressed the 'mode selector switch' on the mouse, and it Toggled to the 'BT-5.0' setting (with a green light).

    I looked at my laptop's Bluetooth display, and it was showing a BT-5.0 mouse. I selected that, the pairing took place automatically, and the mouse worked.

    The advertisement website for the mouse states it supports 1000/1200/1600DPI. I haven't tried to change the DPI settings as of yet. The manual says nothing about switching DPI.

    TEST - Bose Sound Sport earbuds and Inphic PM6BS simultaneous

    While using this Bluetooth mouse, I then switched on my Bose Sound Sport Bluetooth earbuds. LEAP-15.3 immediately connected to the Earbuds. I then obtained great music from my Lenovo X1 Carbon Generation-9, while at the same time using this Inphic PM6BS Bluetooth mouse (using BT-5.0 with the mouse).
  2. oldcpu's Avatar
    USB 5-in-1 Hub (very small in size)

    Another of my Lenovo X1 Carbon's accessories arrived. In this case the "5-in-1 USB-C Hub" by Ention that I ordered.

    Front of the box

    This hub has a male USB-C type connection that, according to the box, one can plug into one's laptop, desktop computer, and even a mobile phone.
    Back of the box

    The hub's ports include:
    • 3 x USB-3.0 ports
    • 1 x RJ-45 ethernet port (for wired LAN/internet access)
    • 1 x Micro-B port (for data access, and also for providing power to the hub - power adapter not provided).

    The ethernet supports 10/100/1000 Mbs speed (ie gigabit speeds).

    Image of the hub (note small size of coin) (showing 3 x USB-3.0 ports)

    The hub is very small and very light. I confess I did not appreciate how small and how light it would be. This is a good thing ! (for a laptop).

    One of my tests was to plug it into my Xiaomi Mi-8 smartphone, where I had a USB stick plugged into the hub. My smartphone was then able to access the files on the USB stick (via this hub).

    I also plugged the hub into a female Thunderbolt-4 port on my Lenovo X1 Carbon generation-9 laptop (running openSUSE LEAP-15.3 GNU/Linux, with the cutting edge 5.14.11 kernel). I tested the USB ports a bit, and the USB-3.0 ports proved compatable with:
    • an external 2 TB Toshiba hard drive (this pleasantly surprised me as I was not convinced the hub would have sufficient power to power the external hard drive)
    • my Xiaomi Mi-8 smartphone (via a USB-c cable between my phone and the hub)
    • my USB wireless mouse.

    I have not yet tested the hub's Ethernet, nor the hub's micro-USB-2.0 port. I do believe thou the internet/LAN will work.

    When I had the hub plugged into my GNU/Linux laptop, I ran 'lsusb' and I note the following 3 additional USB ports:
    Bus 003 Device 008: ID 2109:2817 VIA Labs, Inc. USB2.0 Hub   
    Bus 002 Device 005: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
    Bus 002 Device 003: ID 2109:0817 VIA Labs, Inc. USB3.0 Hub
    I note the 0bda:8153 for the RJ-45. I previous (above) proved compatibility with a Vention USB-C to Ethernet adapter that my GNU/Linux supports RTL8153 (with the driver already included in this Linux Operating System). Note that the Vendor-ID/Product-ID (0bda:8153) is identical to that of the USB-C to Ethernet adapter. That gives me confidence of compatibility since I proved the adapter of same vendor/product-ID worked already.
  3. oldcpu's Avatar
    Up until a day ago, I have still been experiencing LEAP-15.3 crash/reboots, most often (but not always) when using Firefox.

    I tried a few things to resolve this:

    Disabled Firefox setting for hardware acceleration:

    Following an openSUSE forum suggestion, I deselected "use hardware acceleration when available" in Firefox-93.0 but I do not see any improvement wrt crash/reboot prevention. I was still obtaining the occasional LEAP-15.3 crash/reboot.

    Updated X-Windows:

    I finally was sufficiently annoyed with the crash/reboots, that I backed up the data off of the ultrabooks SSD drive (where given this is a new install there was not too much to backup) and did a Full repository vendor change to X11 : XOrg repo. That updated something like 211 packages to more cutting edge X-Window versions. My research into change history suggested that update would obtain many fixes relevant to TigerLake CPU and Iris Xe Graphics associated with that CPU.

    Here is the graphics part from 'inxi' :
    Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
               Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
               Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1920x1200~60Hz
               OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.4
    This is the repository that I added:
    I note it updated the version of Mesa from the previous v.20.2.4 to a newer 21.2.4.

    However I still encountered the occasional crash/reboot - so the XWindow update did not sort the issue.

    Ran Memory test

    I downloaded the memtest86 (from ) , created their boot USB, booted the Lenovo X1 Carbon Generation-9 laptop to that USB and ran the memtest for 2 hours on 3 separate occasions. It passed that short test each time. This gives me some confidence this is not a hardware issue.

    I then began to ask myself - could there be something in the BIOS firmware settings that is not compatible with LEAP-15.3?

    BIOS tuning

    BIOS: Linux S3 - I previous had the BIOS under "Power > Sleep State" set to "Windows 10 and Linux" and I changed that to "Linux S3" to see if that made any difference. Purportedly "Windows 10 and Linux" setting is the "Optimized Sleep State for Windows 10 and versions of Linux that are compatible with Suspend-to-Idle". I would have thought that applied to openSUSE.

    I thus then changed it and set to "Linux S3" where this is the "Optimized Sleep State for versions of Linux that are not compatible with Suspend-to-Idle".

    However later the next day, I again experienced an unexplained LEAP-15.3 crash/reboot, so it appears that BIOS setting change made no difference

    BIOS: Network settings

    In BIOS I then restored the 'Network' settings to the default values that were in place when the laptop was delivered. This meant I changed back:
    • "Wake on LAN from Dock" from OFF to ON
    • "Lenovo Cloud Services" from OFF to ON
    • "UEFI IPv4 Network Stack" from OFF to ON
    • "UEFI IPv6 Netowor Stack" from OFF to ON

    Frankly, I think I have no need for any of those to be ON, but at this point I am looking for a possible Firmware incompabibilty with my openSUSE LEAP-15.3 which is causing random crash/reboots.

    BIOS: Power management

    During the same BIOS boot as making the above network changes, I went to BIOS under Config > Power, and I changed 'CPU Power Management' to OFF from the default of "ON". I note this "Enables or Disables the power saving feature that stop the microprocessor clock automatically when there are no system activities. Normally, it is not necessary to change this setting."

    My suspicion is this could be the main issue that was causing the problem

    LEAP-15.3 network setting
    - I also after rebooting, changed my host name from the default 'localhost' to 'X1-Carbon-G9'. I serious doubt that has any bearing on the Crash/reboot issue, but I note this change here, just to be complete.


    Its over a day later and I have yet to experience another crash/reboot. This is the longest I have gone thus far without experiencing such, but I think it is too soon to tell. Maybe if after a couple of weeks of not experiencing such, I can say that something I did fixed this.

    If I get to that point, I may start one by one undoing the things that I most recently did, to see if undoing one brings back the 'crash/reboot' issue.
  4. oldcpu's Avatar
    Quote Originally Posted by pbojczuk
    I know X1 is not x260, which I bought this week and I did not start on it with openSUSE but with Debian Testing (bookworm), but when I saw after the first log on to the fresh installation the following:

    I could not resist the urge and clicked it. And with the next reboot the firmware was upgraded successfully.

    Is it a sufficient proof that we can nowadays perform the upgrade from non-NT like systems? Well, I would say it is still a single experience.
    I saw your blog post ( read it with Chrome and Google translate). Glad to read it worked ok !

    Perhaps in the future I may get more 'ambitious' and do the next BIOS update to my Lenovo from GNU/Linux. Currently thou I have the most up to date BIOS (v.1.47) for my Lenovo X1 Carbon generation-9.

    At the moment I am struggling with occasional crash/reboots .. and earlier today conducted a very large update, from the X11 : XOrg repository (doing a 'switch system packages to this repos' to that repository). This is NOT something I would normally do as that software is pretty cutting edge, but I am adopting rather drastic measures to find software that works better with this relative new TigerLake processor with its Iris Xe Graphics.

    I plan to blog again about this update, after I have had the opportunity to assess if it is stable.
  5. pbojczuk's Avatar
    I decided to play safe and do the firmware update from Windows-10.
    I know X1 is not x260, which I bought this week and I did not start on it with openSUSE but with Debian Testing (bookworm), but when I saw after the first log on to the fresh installation the following:

    I could not resist the urge and clicked it. And with the next reboot the firmware was upgraded successfully.

    Is it a sufficient proof that we can nowadays perform the upgrade from non-NT like systems? Well, I would say it is still a single experience.
  6. oldcpu's Avatar
    I purchased a number of external accessories (3rd market supplier instead of buying Lenovo) to go with this Lenovo X1 Carbon Gen-9. Two of the accessories have arrived.

    Thunderbolt (Type-C connector) to RJ-45 adapter.

    The adapter/dongle I purchased works well with openSUSE-LEAP-15.3 GNU/Linux.

    lsusb gives:
    Bus 002 Device 002: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
    It was fairly inexpensive, with my ordering via mail order (to here in Thailand). I tested it on my system and it worked fine. According to information on the Intenet (, this device works with kernels commencing with the very old kernel 3.11.

    Type-C to Type-A USB adapter

    This laptop comes with two type-A USB ports, and with two type-C Thunderbird-4 ports. On my use of the laptop, often one of the type-C is used providing power to the laptop, and I need another USB for my USB-wireless-mouse (maybe eventually I will move to a bluetooth mouse). Hence if I do that, it only leaves available one-type-A and one-type-C port available for other use ... On occasion I then like to copy data from one external drive to another external drive (where these external drives have type-A male cables). Hence I wanted the means to easily make one of the Lenovo laptop's type-C Thunderbolts available to a type-A connector to a hard drive.

    Hence I decided to procure a Type-C to Type-A adapter.


    I ended up with this basic device, which was surprisingly inexpensive, and it works well. I tested it with Thunderbolt (type-C port) on Laptop to:
    • USB-Wireless mouse - worked well
    • USB-2.0 memory stick - worked well
    • USB-3.0 memory stick - worked well
    • 2TB USB-3.0 external hard drive (Toshiba) - worked well

    In particular I was keen to see if it would mount the 2TB USB-3.0 external hard drive, as sometimes if a long cable is used there may be not enough power to switch-on such an external device. But it worked nicely.


    I still have a couple of more accessories coming:
    • a USB hub: (with 1xRJ45, 3xUSB-3.0 (type-C), 1xMicro-B (for power if required))
    • neoprene sleeve - to protect the laptop when traveling. I typically use such as a double layer, even when laptop is in a computer bag or in a backpack.
  7. oldcpu's Avatar
    I was pleased that gimagereader packaged by our forum administrator Malcolmlewis works on this new openSUSE LEAP-15.3 install on my Lenovo X1 Carbon Gen9.

    I blogged about this here: openSUSE-12.1 to openSUSE Leap-15.3 with gImageReader and Tesseract

    Many thanks to Malcolm for his efforts here, going back many years.
  8. oldcpu's Avatar
    Once again, Malcolmlewis was also kind enough to package gImageReader for openSUSE-Leap-15.3. MANY THANKS Malclom !!

    openSUSE Leap-15.3

    For information, to setup gImageReader to read/OCR German and French in opnSUSE-Leap-15.3.

    First - to add Malcomlewis' repository (the below commands need to be sent with root permissions) :
    zypper ar malcolm
    To update the new repository.
     zypper update
    Then to install the necessary applications :
    zypper in aspell-en aspell-fr ispell-french ispell-german aspell-spell myspell-de myspell-fr_FR
    zypper in tesseract-ocr tesseract-ocr-traineddata-german tesseract-ocr-traineddata-english tesseract-ocr-traineddata-french
    zypper in gimagereader gimagereader-qt5
    ... and finally to remove the repository :
    zypper rr malcolm
    I launched gimagreader with the command "gimagereader-qt5 %U".

    Gimagereader comes up ok. ... On my PC I tested this with an OCR of a German language document.

    Many thanks again to Malcomlewis for packaging gimagereader.
  9. oldcpu's Avatar
    Quote Originally Posted by oldcpu
    Unexpected crash/reboot

    After booting with 5.14.11 kernel, I posted on the thread, and then tested audio. While plugging the headphone in/out in a test, and playing a video on youtube, I experienced an unexpected reboot of the laptop. Subsequent checking of the /var/log/messages, /var/log/warn, and the journal (I previous enabled journal persistence) did not indicate the problem of the boot ... although I am suspicious of 'firefox' and the 'sound system' on this LEAP to be the cause of the reboot. The temperature was NOT hot during reboot.
    Operating system Crashes/Reboots

    One day ago, while testing the laptop, I had about a dozen immediate crash/reboots when playing YouTube videos with MozillaFirefox. When the crash occured the laptop screen would immediately go black, and then a couple of seconds later a reboot would start. I noted when playing YouTube videos from the Chrome browser I did not have an application nor an operating system crash.

    I attempted changing the Mozilla-Firefox-78.13.0 to the slightly different Mozilla-Firefox-78.10.0 from a LEAP multimedia repository, but I still obtained the same behaviour.
    This morning I again tested trying to obtain the crash, playing YouTube videos in Chrome for over an hour, and there were no crashes. There being no crashes with Chrome gave me confidence the issue was not hardware.

    I then updated the MozillaFirefox to v.93.0 in the LEAP-15.3 Mozilla 3rd party repository:
    This installed:
    I subsequently played YouTube videos for over 2 hours in MozillaFirefox-93.0, and there have been no crashes.

    I will continue to watch this, but its possible this issue is either solved, or made far less likely to occur.

    Operating System Shutdown works better now (after kernel update)

    I have yet to have one bad shutdown, nor a failed reboot, after the kernel update from v.5.3.18 to v.5.14.11 (reported above). Due to the above noted unexpected/crashes in openSUSE, yesterday I performed over two dozen reboots or laptop shutdowns. Each and everyone appeared to function correctly, with both reboots (without the previous freeze at operating system halt in the middle of the reboot) and shutdowns (include power removed) working properly.

    Hence it is possible the kernel update to v.5.14.11 solved the shower shutdown issue.

    In both cases I am not certain the problem has been solved, and I will continue to monitor this over the coming weeks.
  10. oldcpu's Avatar
    I updated sof-firmware on this LEAP-15.3 install to a newer version, although its likely not required.

    The sof-firmware is packaged for openSUSE LEAP-15.3 as sof-firmware-1.6.1-2.9. I noted in an openSUSE multimeda:libs repository that version-1.8 was available. I went to github where version 1.9 of the firmware is available for packagers, but that is not yet packaged for openSUSE. I looked at the change history from sof-firmware-1.6.1 to 1.8 and I noted a couple of updates relevant to TigerLake processors:
    * this from the sof-firmware v.1.8 change history: "Improved support for Intel Tiger Lake- and Alder Lake-based devices".
    * this from the sof-firmware v.1.7 change history: "Added support for Intel Tigerlake H and Intel Tiger Lake fix for clock switching".

    As to exactly what that 'added' and 'improved' support provides, I have no idea.

    The multimedia:/libs directory is here:

    zypper ar multimedia
    I added the repository via zypper and then installed sof-firmware-1.18 from that repos via YaST Software Management, although I could have done the same update via zypper.

    I rebooted after updating sof-firmware, and played some audio files (and video file with audio) and it seems to work well. I can't thou say that I hear any difference.

    In case anyone is curious, here is a link to the alsa-info information after the update (and after rebooting):

  11. oldcpu's Avatar
    I have been experiencing issues when shutting down this Lenovo X1 Carbon Gen-9, where the operating system will halt, but the power will remain on. Most the time the symptoms are the screen will go black, with an illuminated 'LEAP' at the bottom of the screen, and the CapsLock key flashing - with no response from any keys. Holding the power on/off key down for a dozen seconds then removes the power.

    On occasion the "LEAP" will not show up and the screen will stay a very dark grey, only slightly brighter than a typical black screen, and on occasion the CapsLock will not flash. So care was needed by me to ensure the shutdown takes place properly.

    Updated to 5.14.11 kernel

    I decided to update the kernel from the default 5.3.18 to an experimental 5.14.11 kernel, to see if that would help. I updated to the kernel on the kernel:stable:backport which was the noted 5.14.11. Successful update indication is here:
    oldcpu@localhost:~> uname -a
    Linux localhost.localdomain 5.14.11-lp153.2.g834dddd-default #1 SMP Sun Oct 10 08:34:34 UTC 2021 (834dddd) x86_64 x86_64 x86_64 GNU/Linux
    I was able to install this kernel and keep the secure boot, thanks to assistance from the openSUSE community, as to do such exceeded my experience and I was outside my 'comfort zone'. One can read of that experience in this help thread:

    Unexpected crash/reboot

    After booting with 5.14.11 kernel, I posted on the thread, and then tested audio. While plugging the headphone in/out in a test, and playing a video on youtube, I experienced an unexpected reboot of the laptop. Subsequent checking of the /var/log/messages, /var/log/warn, and the journal (I previous enabled journal persistence) did not indicate the problem of the boot ... although I am suspicious of 'firefox' and the 'sound system' on this LEAP to be the cause of the reboot. The temperature was NOT hot during reboot.

    Intel Media Driver

    I then decided to update the intel-media-driver application that runs with the i915 graphic driver, as it purportedly takes advantage of the intel GPU and delivers superior video encoding. LEAP-15.3 comes with the intel-media-driver-20.3.0-1.41.x86_64. In a community repository ( patrikjakobsson:intel-opencl ) is the intel-media-driver-21.2.3. While its not as new as the intel-media-driver-21.3.5 in github, when I checked the change history between LEAP-15.3's v.20.3.0 and the community 21.2.3, I noted a massive number of updates. I ended up updating:

    I then rebooted (where on this occasion with 5.14.11 kernel the reboot did not freeze) and I now plan to test with this newer setup.

    This is all much more 'cutting edge' than I normally use, so its fair to say that I am out of my comfort zone - but I think I am learning which is typically a good thing.
    Updated 12-Oct-2021 at 22:10 by oldcpu
  12. oldcpu's Avatar
    I finally got around to testing the bluetooth on this SUSE LEAP-15.3 install on my X1 Carbon Gen9.

    It works fine and synchronized with my old Bose Soundsport (bluetooth) wireless headphones (earbuds) with no problem.

    For information - these are the apps that were automatically installed as part of the LEAP-15.3 install relating to bluetooth:
    oldcpu@localhost:~> rpm -qa | grep blue
    I don't know exactly which of those are essential for the functionality - for as noted the default LEAP-15.3 install placed them all on the laptop SSD.

    I'm quite happy that this worked immediately with no issue.
  13. oldcpu's Avatar
    Thunderbolt port

    I finally got around to testing the transfer speed on one of this Lenovo X1 Carbon Gen9 (running openSUSE LEAP-15.3) Thunderbolt ports. I did this with one Thunderbolt port receiving power and I connected the 2nd Thunderbolt port to an external "SanDisk External Portable SSD" - 500 GB device. Copying from the laptop to this external SSD, I obtain speeds of 310 MiB/sec.

    That is in contrast to the 80 MiB/sec I typically get when transferring files from an external USB-3 hard drive.
    Updated 06-Oct-2021 at 21:23 by oldcpu
  14. oldcpu's Avatar
    Features Not Yet Tested

    I have not tested the following (due to my having no requirement yet):

    * bluetooth
    I did not yet test this but I noted the bluetooth detected in dmesg (where “dmesg | grep -i blue” gave a bunch of information).

    * thunderbold functionality (other than for power/charging and data transfer with an external HD). My wife has an external SSD with a USB-C connector, and I may plug that into a Thunderbird port and try a test.

    * finger print reading. I did not install fprintd which I understand is likely needed for this. LEAP-15.3 has an officially packaged fprintd-0.80 (made available on github for packagers on 13-Sep-2017), but one can get fprintd-1.90.9 (made available on github for packagers on 13-January-2021) from a LEAP-15.3 experimental repository. In fact version 1.94 is available on github (as of 20-August-2021) but there are no rpms yet packaged for openSUSE LEAP-15.3. As noted, I did not install this.

    * HDMI – I have not tested this.

    * BIOS updates from GNU/Linux: To update the BIOS in GNU/Linux one can use fwupd-1.2.14 (openSUSE LEAP-15.3 packaged version). I did not use this app, but rather I updated the BIOS in MS-Windows. Currently from the LEAP-15.3 experimental repositories, one can install v.1.5.8 (made available for packagers on github on 24-March-2021). I notice the latest version on github is v.1.6.4 (made available for packagers on 24-Sep-2021), however that has not been packaged yet for openSUSE.

    I have not yet installed this fwupd application.

    Installation/hardware/software summary:

    Here is an output of “inxi -F” :
     localhost:/home/oldcpu # inxi -F
     System:    Host: localhost Kernel: 5.3.18-59.24-default x86_64 bits: 64 Desktop: KDE Plasma 5.18.6 Distro: openSUSE Leap 15.3  
     Machine:   Type: Laptop System: LENOVO product: 20XW00A7TH v: ThinkPad X1 Carbon Gen 9 serial: PF3179W2  
                Mobo: LENOVO model: 20XW00A7TH v: SDK0J40697 WIN serial: L2HF1780345 UEFI: LENOVO v: N32ET71W (1.47 )  
                date: 09/06/2021  
     Battery:   ID-1: BAT0 charge: 57.2 Wh condition: 57.2/57.0 Wh (100%)  
     CPU:       Topology: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP L2 cache: 12.0 MiB  
                Speed: 925 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 971 2: 946 3: 670 4: 832 5: 925 6: 916 7: 862 8: 908  
     Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel  
                Device-2: Chicony Integrated Camera type: USB driver: uvcvideo  
                Display: x11 server: X.Org 1.20.3 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1200~60Hz  
                OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 20.2.4  
     Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: sof-audio-pci  
                Sound Server: ALSA v: k5.3.18-59.24-default  
     Network:   Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi  
                IF: wlan0 state: up mac: 10:3d:1c:c4:27:b9  
     Drives:    Local Storage: total: 2.30 TiB used: 495.35 GiB (21.1%)  
                ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL21T0HCLR-00BL7 size: 953.87 GiB  
                ID-2: /dev/sda type: USB vendor: Toshiba model: External USB 3.0 size: 1.36 TiB  
     Partition: ID-1: / size: 24.58 GiB used: 9.68 GiB (39.4%) fs: ext4 dev: /dev/nvme0n1p4  
                ID-2: /home size: 818.93 GiB used: 34.80 GiB (4.2%) fs: ext4 dev: /dev/nvme0n1p7  
     Swap:      ID-1: swap-1 type: partition size: 16.41 GiB used: 1.8 MiB (0.0%) dev: /dev/nvme0n1p6  
     Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A  
                Fan Speeds (RPM): cpu: 0  
     Info:      Processes: 248 Uptime: 1h 36m Memory: 15.36 GiB used: 1.84 GiB (12.0%) Shell: bash inxi: 3.1.00
    My pre-installation research, preparation, and some references:

    After ordering the laptop, and prior to receiving the laptop, I conducted a lot more research into how to setup this laptop in GNU/Linux than I would normally otherwise do. This was because (1) its much newer to the market place than any of my previous laptops, and (2) I am now older and hence retired and I have more time than I had in the past.

    OpenSUSE forum support:

    In the openSUSE forums “Chit Chat” I exchanged some posts, and received excellent suggestions from forum members, on installing openSUSE on this laptop. A link to that thread is here:

    I posted on the shutdown issue here:

    I posted on the ‘guvcview’ mic record issue here:

    Lenovo Linux support:

    Lenovo have a support forum for GNU/Linux on their devices here:

    Future kernel update possibility

    As noted above, in order to better take advantage of features in the TigerLake 1165G7 CPU, that came with this Lenovo X1 Carbon Gen-9, I may decide to update to a kernel that is newer than the one nominally provided with LEAP-15.3. I will post in this blog if I do download and install a kernel from the kernel:stable:backports repository. The intent is that this kernel, together with some apps on openSUSE will provide superior:
    (1) intel graphic support
    (2) CPU video rendering
    (3) thermal/power management


    I ask that anyone with 'help' requests related to this post, start a new post in the openSUSE forum area asking for help, and not post as a comment in this blog thread. Many thanks !

    = = = The END (of this initial series of blog posts) = = =
  15. oldcpu's Avatar
    Graphics work ok (Iris Xe Graphics, resolution: 1920x1200). Driver is i915.

    See below in this thread for an ‘inxi’ output (giving more information on graphic hardware and software).

    intel-media-driver: The package intel-media-driver 20.3.0-1.41 was automatically selected and installed from the LEAP-15.3 official repository.

    I previously read:
    The Intel Media Driver for VAAPI is a new VA-API (Video Acceleration API) user mode driver supporting hardware accelerated decoding, encoding, and video post processing for GEN based graphics hardware.

    I note this laptop uses the i915 graphic driver, and I found this internet explanation interesting, where someone gives their understanding of the difference between the i915 and the intel-media-driver:
    i915 is name of kernel module that talks to GPU hardware. It is used for many different things - controlling output signals to monitor, submitting 3d/rendering commands, memory management, etc.
    intel-media-driver is package of libraries that application use for hardware accelerated video processing, encoding & decoding. ie such as "mp4 playback" or "youtube videos". To do its work it talks to i915 module in kernel to access hardware.

    I noted on github the openSUSE LEAP-15.3 packaged intel-media-driver v.20.3.0 version was made available for GNU/Linux packagers on 30-Sep-2020. The latest ‘release’ version on github is a newer official version 21.2.3 9 (packaged 30-June-2021). Further, on github there are newer builds such as version 21.3.4 (made available on github 6-Sep-2021). I also noted v.21.3.4 is available in the LEAP-15.3 experimental and community repositories. I read on the github site, that version 21.2.3 needed at least intel-gmmlib-21.2.1 and libva-2.12.0. Versions that new for gmmlib and libva can be obtained for LEAP-15.3 on experimental & community repositories.

    I decided to not immediately go for the latest intel-media-driver, as I suspect it needs a kernel v.5.8 or newer for Tiger Lake processors, while LEAP-15.3 comes with the 5.3.18 kernel.

    This also makes me think that I probably should update the kernel to 5.14 or newer sometime in the future – in order to obtain best thermal performance. If I update to the 5.14 or newer kernel, I will add to this blog entry.

    As a further note, while there was no screen flickering that I could see, I noted some users experienced this. One of the fixes was to addi915.enable_psr=0 “ to the boot parameters (as that is purportedly to reduce ‘ i915.enable_psr=0’). I read the reason some people in other distros use PSR=0 is the following:
    Panel Self Refresh (PSR), a power saving feature used by Intel iGPUs is known to cause flickering in some instances FS#49628 FS#49371 FS#50605. A temporary solution is to disable this feature using the kernel parameter i915.enable_psr=0.

    I may add that boot code in the future if I have an issue.

    Some basic testing

    I note after installing openSUSE LEAP-15.3:

    * wifi works. WiFi device is an Intel Wi-Fi 6 AX201. The driver: iwlwifi

    * webcam works (uvcvideo compatible)
    The webcam is a: 04f2:b6ea Chicony Electronics Co., Ltd Integrated Camera. The webcam is not in the list in “ “ so I may send information to the mailing list on sourceforge letting them know the detail, where the Mailing list is here:

    Although, having typed that, I note this webcam is in more Lenovo hardware, and given its not in that uvc list, but works with uvc, makes me suspect that list may not be maintained any more.

    * audio: audio mostly works (speakers, mike, headphones). I did encounter an issue with the mic with an app where I believe that to be an openSUSE (or upstream pipewire) issue.

    While I successfully tested the mic with the command line app ‘arecord’ , I also noted the mic does not work with the application ‘guvcview’. I suspect this is the same issue reported in this Tumbleweed bug report: , and also raised in this openSUSE thread:

    * trackpad/red pointing stick: trackpad and red ‘pointing stick’ in middle of keyboard works.
    - the red ‘pointing stick’ is a "TPPS/2 Elan TrackPoint".
    - the trackpad is a “"ELAN0672:00 04F3:3187 Touchpad”

    * Function keys. Most of the function keys work. I only tested some of the function keys:
    * F1 – mutes sound (toggle) – this works
    * F2 – decreases volume – this works
    * F3 – increases volume – this works
    * F4 – mutes the mic (toggle) – this works
    * F5 – decreases display brightness – this works
    * F6 – increases display brightness – this works
    * F7 – for connecting to external monitor – I did not test
    * F8 – airplane mode (toggle) – I did not test
    * F9 – open/collapse a ‘notification center’ (I think for Windows-10) - I did not test.
    * F10 – answer incoming calls (for apps such as Skype in Windows-10) – I did not test
    * F11 – decline/hangup calls (for apps such as Skype in Windows-10) – I did not test
    * F12 – key for customization in Windows-10 using a ‘vantage app’ – I did not test.

    Hardware probe: An early ‘hw-probe’ after an openSUSE install (with the original 5.3.18 kernel) yielded this:

    Webcam: The webcam works under uvcvideo, although as I noted that the audio recording with that app fails.

    Battery: According to “lshw” the battery is a Celxpert, 57000 mWh. Product: 5B10W13974. I have not tested the battery life, but I have read it is supposed to be very long between charges.

    .... to be continued ....
  16. oldcpu's Avatar
    Some BIOS Settings:

    Note that prior to installing, I went into the BIOS (press F1 on boot) ensured I was happy with the settings. Most likely most of this is not needed:
    * Disabled “USB Key provisioning” (under Config)
    * Disabled “UEFI – IPV4/IPV6 stack” (under Config)
    * Disabled “Lenovo Cloud Service” (under Config)
    * Disabled “Network Boot” (under startup)
    * Set Boot Mode (under startup) to Diagnostics
    * Left “Secure boot” (under Security) as “Enabled”
    * Left “Device guard’ (under Security) as ‘OFF’ (default setting)
    * Left Enabled “Absolute Persistence Module” (under Security – it was ‘Enabled’ by default)

    Given the liveUSBs were able to boot with Secure Boot enabled, I was reasonably confidence I could install LEAP-15.3 with ‘Secure Boot’ enabled.

    Installing LEAP-15.3
    As part of the LEAP-15.3 install, I went into the advanced/custom part of the openSUSE LEAP-15.3 install, to make certain I had the swap, / and /home exactly where I wanted them. This also meant I had to point openSUSE to the existing MS-windows /efi for the openSUSE /boot/efi (being certain NOT to reformat that directory).


    sof-firmware: I noticed sof-firmware automatically installed, and it is version 1.6.1-2.9. For audio the kernel module is: snd_soc_skl_hda_dsp

    The openSUSE-LEAP-15.3 official repository sof-firmware-1.6.1-2.9 was made available on github for packagers on 4-December-2020. There is a v.1.8 available in the LEAP-15.3 experimental repository was made available on the github site ( ) for packagers on 23-June-2021. I also noted from the github site that it includes fixes for TigerLake CPUs Iattempted to update to v.1.8 but that failed – as the experimental repos failed to connect to some SuSE Enterprise repos.

    The audio worked ok for both speaker and headphones.

    There is an issue that I have, where the mic works for some applications (such as ‘arecord’) but does not work for some other applications (such as ‘guvcview’). There is already a bug report on the mic not recording (raised on Tumbleweed) and I suspect this could be the same issue. For the curious, here is the ‘ output on the LEAP-15.3 install:

    Thermal/Power Management

    TLP (Optimize Linux Laptop Battery Life): TLP-1.3.1 is installed by default for openSUSE LEAP-15.3. I note TLP version 1.3.1 was made available for packagers on 7-Feb-2020 on github). There is no newer version packaged for LEAP-15.3 in experimental/community repositories (although v.1.40 is available on github: (packaged 24-Sep-2021)). I read conflicting accounts on a Lenovo Linux forum, where one user stated in reddit: - Lenovo recommend to not use TLP (where nominally TLP is intended to better manage battery life in a laptop). That article purports that TLP interferes with the Lenovo X1 Carbon’s firmware power settings. However I also read on reddit ( ) another article that suggested to install TLP. Given TLP already installed - I considered this a moot point for the moment.

    thermald: I note ‘thermald’ v.1.6 comes with LEAP-15.3 (but it is not installed by default). I noted on github this version was released for packagers on 4-March-2017, which is before this Lenovo’s hardware was on the market. Github has v.2.4.6 (created on 8-June-2021) as the most current version but I speculate the newer 2.4.6 thermald may need the newer 5.14 kernel to take advantage of its features.

    The benefit of installing a newer kernel in this case, is supported by (for example) a Phoronix article: ( ) which notes the Linux-5.13 kernel ( ) can enable a ThinkPad ACPI driver to control the second fan on the ThinkPad X1 Carbon.

    This made me think that I probably should update the kernel to 5.14 or newer sometime in the future – in order to obtain best thermal performance.

    .... to be continued ....