Blog Comments

  1. nef131's Avatar
    [QUOTE=Knurpht;bt976]This is for non-Optimus cards. There's another blogpost with one-clicks for Optimus cards, i.e. bumblebee

    DKMS = Dynamic Kernel Module Support. This means that in case of a kernel update dkms will take care of the building of the NVIDIA driver for the new kernel. Currently this requires an extra reboot after the kernel-update to allow dkms to build the new NVIDIA driver.[/QUOTE]

    Many thanks for responding.
  2. Knurpht's Avatar
    This is for non-Optimus cards. There's another blogpost with one-clicks for Optimus cards, i.e. bumblebee

    DKMS = Dynamic Kernel Module Support. This means that in case of a kernel update dkms will take care of the building of the NVIDIA driver for the new kernel. Currently this requires an extra reboot after the kernel-update to allow dkms to build the new NVIDIA driver.
    Updated 04-Dec-2013 at 09:48 by Knurpht
  3. nef131's Avatar
    I was slightly confused by your introduction. Does your script work for systems that are not Bumblebee / Optimus configurations?

    Assuming, as I do, that your script is not for Bumblebee / Optimus configurations, when there are updates/upgrades to OpenSUSE 13.1, will the normal update approach for the Nvidia driver also work, as if the Nvidia repository had initially been added to the system (which, at the moment, is not available to be added), or will it be necessary, once the Nvidia repository is available, to add the repository?
  4. brunomcl's Avatar
    Hi Knurpht,

    Thanks for the report. Perhaps you'd be so kind as making a test for us non-English-speaking people

    How does it work with soft subtitles, specifically .srt? Last time I looked at it there has no support for streaming them together with the movie, as only one file could be streamed at a time to a client.
    The (CPU intensive) workaround given in one app - I think it was mediatomb, but not sure - was to re-encode the video with hard subs on-the-fly, something that didn't work very well for me.

    Regards,


    Bruno
  5. rrdonovan's Avatar
    Hmm MKS52 seems frustrated. I have had an Asus EEEPC with the Atom n270 processor and intel graphics. It ran just fine. Then there have been other laptops and desktops with some some *******ized graphics processors that sometimes don't work properly with open source drivers. There is no more SAX but the work arounds usually take care of the problem. Yes, WiFi has been a pain, but I guess as OpenSuse matures, these two problems will eventually diminish. At least we are not Microsoft Slaves, At least when you get a good install, OpenSuse runs fast, and is most stable. Keep the updates, and patches coming. Oh, Yeah, "have a lot of fun".

    Rod Donovan
  6. biltekakademi's Avatar
    good nice thanks ;)

    biltek akademi grafik tasarım kursu autocad kursu muhasebe kursu web tasarım kursları
    http://www.biltekakademi.com
    ;)
  7. oldcpu's Avatar
    I now have openSUSE-12.1 running on 5 completely different PCs in our appartment (2 of which are laptops that mostly exclusively use wireless) and they all work great. I'm heading from Europe to North America in 10 days and I plan to update my 86+ year old mother's openSUSE version from 11.3 to 12.1 and I fully expect 12.1 to work well for her.

    @ mks52, I think jdmcdaniel3 gave you some good advice. Like jdmcdaniel3 I am sorry to read you have a problem and please post on our GNU/Linux forum in the correct location, with a relevant technical topic asking for help, and I am confident you will have volunteers try to help you. I note to date you have not asked for help under the handle mks52, which can only lead one to conclude you are understandably frustrated and that thus far you have made no effort to obtain help on our forum. Please note also that the openSUSE forums which is hosting Knurpht's excellent blog, is a forum of volunteers and not developers nor SuSE-GmbH packagers. But we do have some very knowledgeable users (especially in the subject area of wireless). Best wishes and good luck in your efforts.

    @ Knurpht, many thanks for an excellent blog.
  8. jdmcdaniel3's Avatar
    [QUOTE=mks52;bt476]I opened an account here just to post in as many places as possible to discourage anyone from wasting their time with SuSe. I have an ASUS laptop and installed 12.1 successfully. It is the most bug-ridden and useless Suse ever. It demonstrates the increasing incompetence and laziness of SuSe maintainers. Foremost of all the WIFI won't initially work because they didn't have the courtesy to test the distribution before publishing. What is a laptop without WIFI? WLAN accesss on the road is THE whole point. Otherwise the computer is useless. When searching for a solution to this bug, that they are certainly aware of, there are NO search hits. Reading endless blogs from newbies and the confused (Even though they mean well) clutters up pages and pages of complicated configuration fixes that are not necessary. And Feedback to SUSE is disabled. In order to get WIFI up and running in 12.1, you have to install the WIFI widget that is missing from the task bar. Go to YAST, click "Software Management" type in "Widgets" in the search box and download everything WIFI. The widget will show up in the bar and you will get online. I wish that I could tell them directly. If you can do it forward this to them please. This is why I no longer get the boxed set for SuSe or any Linux. No decent support. They leave it up to users. No Support-No revenue Wake up Suse![/QUOTE]

    Perhaps it shows you do not know what you are doing as I have found openSUSE to be the best Linux Distribution by far. It is the most flexible and the fastest of every Linux Distribution I have tried. Anyone really into Linux understands that WiFi Adapters are very hard to make work and often require the very latest kernel to allow them to function. Your failure to make openSUSE to work is an example of how inept you may be. Further, all you need is to post a help request in the forums and we would do all we can to help get your copy of openSUSE to work. We are sorry that you have had a problem and we allow you to speak your mind in such matters. None the less, if you wish, place a help request in the correct location, and include all hardware information we can and we will try to help you out.

    Thank You,
  9. mks52's Avatar
    I opened an account here just to post in as many places as possible to discourage anyone from wasting their time with SuSe. I have an ASUS laptop and installed 12.1 successfully. It is the most bug-ridden and useless Suse ever. It demonstrates the increasing incompetence and laziness of SuSe maintainers. Foremost of all the WIFI won't initially work because they didn't have the courtesy to test the distribution before publishing. What is a laptop without WIFI? WLAN accesss on the road is THE whole point. Otherwise the computer is useless. When searching for a solution to this bug, that they are certainly aware of, there are NO search hits. Reading endless blogs from newbies and the confused (Even though they mean well) clutters up pages and pages of complicated configuration fixes that are not necessary. And Feedback to SUSE is disabled. In order to get WIFI up and running in 12.1, you have to install the WIFI widget that is missing from the task bar. Go to YAST, click "Software Management" type in "Widgets" in the search box and download everything WIFI. The widget will show up in the bar and you will get online. I wish that I could tell them directly. If you can do it forward this to them please. This is why I no longer get the boxed set for SuSe or any Linux. No decent support. They leave it up to users. No Support-No revenue Wake up Suse!
  10. Knurpht's Avatar
    Quote Originally Posted by oldcpu
    > video works, but using fbdev. Any ideas? Device is Intel Rev09

    Hi Knurpht, from what I have read, the ASUS EEEpc X101CH graphics uses the Cedar Trail processors where the graphics are a form of the poulsbo (Intel) graphics where there are many complaints wrt GNU/Linux. For example, this thread: Linux Mint Forums • View topic - EeePC resolution stuck at 800x600 . There may be possibilities there to get this working, but I am not on top of this technically.
    Well, for me it's not a very big issue, as long as the machines can run a php webapp in Firefox, which they do nicely. But since one of the three is a spare one, I'm experimenting and trying to get it working anyway, I'm planning to give the latest Ubuntu a spin on it, see if that works.
  11. oldcpu's Avatar
    > video works, but using fbdev. Any ideas? Device is Intel Rev09

    Hi Knurpht, from what I have read, the ASUS EEEpc X101CH graphics uses the Cedar Trail processors where the graphics are a form of the poulsbo (Intel) graphics where there are many complaints wrt GNU/Linux. For example, this thread: Linux Mint Forums • View topic - EeePC resolution stuck at 800x600 . There may be possibilities there to get this working, but I am not on top of this technically.
  12. oldcpu's Avatar
    dennisdesai1 this is not my blog, but please, out of courtesy for Knurpht do NOT type in ALL CAPS. That is considered extremely rude and its like shouting in one's face. The occasional word (for emphasis) in CAPS is fine, but an entire post is .... is simply extremely rude.

    Second, no one is claiming openSUSE-12.1 freezes here. Why are you posting that here? Again, its simply rude and an insult as you are inferring something posted that was not posted. Please post your complaints elsewhere in our forum. I'm sure we will have users more than happy to help you get your openSUSE-12.1 working properly. I have it running on many PCs and it runs fine.

    @ Knurpht, please feel free to delete my post and dennisdesai1's post from your blog.
  13. dennisdesai1's Avatar
    YOU GUYS ARE NOT ALONE. OPEN SUSE 12.1 DOES FREEZE. I TRIED TO INSTALL IT ON A TOSHIBA SATELLITE NOTEBOOK, BUT TO NO AVAIL. IT LOADS THE LINUX KERNEL, BUT AFTER THAT THE SCREEN BECOMES FUZZY AND DIES. I TRIED ALL THE DIFFERENT SETTINGS--DEFAULT, SAFE AND NO ACPI. A FIRMWARE TEST AND AN INSTALLATION MEDIA CHECK WERE NOT HELPFUL.
  14. Knurpht's Avatar
    Well, to sum it up, using the install mentioned above, with kernel and KDE48 repo:
    - sound works OOTB
    - wireles works OOTB, Atheros AR9285
    - video works, but using fbdev. Any ideas? Device is Intel Rev09
    - webcam works OOTB, tested using Kopete. It's a Chicony UVC compatible.

    Fact is, that the machines are going to be used as barcode scanning terminals for entrance checking in theatres. You get your ticket by email in PDF, unique barcode on it, The netbooks have a USB barcode scanner wirelessly attached. The webapp runs in Firefox and reads the input from the barcode scanner, tells whether the ticket is valid, or is for another show, or has been used already etc. etc.

    I quite like them though I wouldn't change a laptop for one of them.
    Cons: The keyboard is tiny, needs quite a bit of hammering. 2 GB of RAM could make a hell of a difference, yet performance is quite OK. I'd rather have had a 30GB SSD (replaced the HDD in my son's HP Mini by one, incredible difference). And this hardware issue. Before I found the post on the web, which brought me to the "repo trick", I tried 12.2 M3 on one of them and that worked.. But I'm wide aware that it could have been a giant disappointment as well. The video is something I'm going to find out this weekend, using the articles and forums here, since fbdev works but does show some artifacts now and then.
    Pros: Very quiet indeed, not too bad performance wise, openSUSE runs fine with the tricks mentioned above. Very light machine. Haven't tested them "empty' but battery seems to last for quite a while. At least much longer than my laptop's.
  15. oldcpu's Avatar
    Interesting, I've also never used the additional repos option. I'm curious as to what the YaST installer screen print looks like when choosing that option during install, and as a future test with openSUSE-12.2 milestone release, I may try this with my next sandbox install (maybe using Packman repos as the additional repos as part of this test).

    Reading up on this Eee PC X101CH netbook, I note it has a 10.1 inch, 1024 x 600 pixel display, a 1.6 GHz Atom N2600 processor, 1GB of RAM and a 320GB hard drive, and by default comes with a 3 cell, 23Whr battery. It includes 802.11b/g/n WiFi and a 0.3MP webcam. How did the wireless and webcam support work out ? What wireless hardware ? And is this a 'uvc' compatible webcam ?

    From what I can read, measuring 10.3″ x 7.1″ x 0.86″ and weighing about 2.2 pounds it does appear to be pretty light and small, not to mention quiet, as I have read the netbook also features a fanless design.
  16. psytropic's Avatar
    This worked flawlessly. Thank you.
  17. themagicm's Avatar
    disregard.. my problem was that 3.0 dock didnt get upgraded when I went from 11.4 to 12.1. After I upgraded the dock extension through software management then applied your fix..that did it.

    Thanks!
  18. themagicm's Avatar
    yea I made that change and that still didnt fix it for me. :-/
  19. smithark's Avatar
    congrats Knurpht! let this be an inspiration to all the budding programmers out there to use open source and open suse.
  20. jdmcdaniel3's Avatar
    Congratulations Knurpht for your success on this project and for allowing us to hear about this story.

    Thank You,
Page 2 of 3 FirstFirst 123 LastLast