Blog Comments

  1. nrickert's Avatar
    Quote Originally Posted by eaglesly
    Great !
    Can you tell us more ? I experienced the same problems on a Vaio laptop. The OpenSuse install succeed, even in secure boot mode, the grub2 bootloader works... until I start a Windows 8 session that erases it.
    If you can start a forum thread on this problem, then I think we will be able to help. The forum is better for dialog than posting in blog comments.
  2. eaglesly's Avatar
    [QUOTE=franck_d;bt902]okay, it's finally fixed :)
    I used an "app"... :rolleyes: where I could select the 'device' to boot and it keeps behaving well, even after a Windows session[/QUOTE]

    Great !
    Can you tell us more ? I experienced the same problems on a Vaio laptop. The OpenSuse install succeed, even in secure boot mode, the grub2 bootloader works... until I start a Windows 8 session that erases it.

    Which app did you use to select this device ?

    Thanks

    Cheers
  3. franck_d's Avatar
    [QUOTE=nrickert;bt899]Please start a discussion thread at opensuse forum (the install/boot forum there). In your opening post for the thread, indicate how you installed (the DVD, or with live media).[/QUOTE]

    okay, it's finally fixed :)
    I used an "app"... :rolleyes: where I could select the 'device' to boot and it keeps behaving well, even after a Windows session
  4. nrickert's Avatar
    Quote Originally Posted by franck_d
    -> how could I fix this?
    Please start a discussion thread at opensuse forum (the install/boot forum there). In your opening post for the thread, indicate how you installed (the DVD, or with live media).
  5. franck_d's Avatar
    I have reinstalled openSuse, but now with a separate efi partition as you wrote, but I still have the same problem: as soon as I start Windows, the next time I boot, I'm in a Windows-only situation :(

    the 'efibootmgr -c -g -d' etc. fixes this, till I go for another Windows session...

    -> how could I fix this?


    Windows 8 uefi (no secure boot)
    OpenSuse 12.3
    Sony Vaio
  6. jcdole's Avatar
    [QUOTE=jcdole;bt885]
    ASUS R900VJ, 6Go, 1To SATA Drive, Windows 8, Bios American Megatrend ver:320, Bios UEFI, OnBoard intel graphic + card nvidia GT 365M.

    OS : Windows 8

    3- From windows 8, enter bios menu
    --- Boot
    ----- Disable Fast Boot
    ----- Enable Launch CSM
    --- Security
    ------ Disable Secure Boot
    [/QUOTE]

    This computer is an ASUS notebook configured for europe market : ASUS R900VJ-yz125h.

    American Megatrend ver:320, Bios UEFI whose name is : APTIO SETUP UTILITY
    In the boot option there only 2 configurations option
    * FAST BOOT ( Normaly enabled by default )
    * Launch CSM ( Normaly disable by default )
    In the Security option
    * Secure Boot Control ( Normaly enabled by default )

    So Following your recommendation
    * FAST BOOT is disabled.
    * Launch CSM is enabled.
    * Secure Boot Control is disabled.

    Nothing more to say from my post.
  7. nrickert's Avatar
    Quote Originally Posted by sfbarbee
    Correction to last post:

    Line to add boot entry was actually:

    efibootmgr -c -g -d /dev/sda -p 3 -L "OpenSuSE 12.3" -w -l '\EFI\opensuse\grubx64.efi'

    I keep making the mistake.

    Thanks
    Sorry. I didn't see your comments until now. I was expecting to be notified of comments. I probably set something up wrong on that notification.

    Is secure-boot enabled or not?
    What kind of computer is this?
  8. jcdole's Avatar
    Work like a charm even for the windows boot.

    Bought a new notebook this week :
    ASUS R900VJ, 6Go, 1To SATA Drive, Windows 8, Bios American Megatrend ver:320, Bios UEFI, OnBoard intel graphic + card nvidia GT 365M.

    1- Defrag disk and reboot as many times until defrag do nothing more,
    2- shrink first windows 8 partition ( windows 8 OS ) to 60Go, remove the second windows partition of 600 Go ( for user data ) and create a 60 Go partition for linux. Temporaly formated NTFS Type
    3- From windows 8, enter bios menu
    --- Boot
    ----- Disable Fast Boot
    ----- Enable Launch CSM
    --- Security
    ------ Disable Secure Boot
    4- Reboot in uefi mode on Opensuse 12.3 install (iso on usb stick with uefi boot partition)
    5- Make install
    --- remove mount point for windows uefi boot partition,
    --- with gparted
    ------ create 100 Mo UEFI partition of type FAT for suse with mount point /boot/efi,
    ------ Reformat existing 60 Go Linux partition to ext4 (which was created at step 2), add swap and other stuff.
    ------ Format only Linux stuff, leave untouched : windows 8, ASUS recovery windows system (hidden partition), ASUS restore windows image(hidden partition), Microsoft reserved partition (hidden partition).
    --- In the Boot Loader Settings
    ------ Verify that boot loader option is "GRUB2-EFI" : Yes it is
    ------ Select Enable Secure Boot
    Finish install.
    Reboot automatically in Linux
    Automatic config done
    Reboot
    Login to see if all things are correct.
    Reboot
    Get the grub boot screen with :
    - Opensuse 12.3
    - Advance options for Opensuse 12.3
    - Windows boot manager (on /dev/sda1)

    Return to the bios menu to see what is new :
    --- Boot option
    ------ Launch CSM : Enable
    ------ Boot option priorities
    ---------Option 1 : opensuse secure boot ( P0: disk 1 )
    ---------Option 2 : opensuse ( P0: disk 1 )
    ---------Option 3 : P2 : Slimtype DVD A
    ---------Option 4 : Windows boot manager ( P0 : disk 1 )
    --- Security
    ---------Secure Boot Control : Disable


    Before suse install I9 had :
    ---------Option 1 : P2 : Slimtype DVD A
    ---------Option 2 : Windows boot manager ( P0 : disk 1

    As said booting on windows 8 take a little more time.
  9. sfbarbee's Avatar
    Correction to last post:

    Line to add boot entry was actually:

    efibootmgr -c -g -d /dev/sda -p 3 -L "OpenSuSE 12.3" -w -l '\EFI\opensuse\grubx64.efi'

    I keep making the mistake.

    Thanks
  10. sfbarbee's Avatar
    Thanks for this information. I went through the steps but this did not work.

    The initial install seemed to go smoothly, but on reboot to complete the setup, the system would not boot into linux. It only booted windows. I then deleted the windows efi and os partitions and attempted install again, but now no os is found at all.

    My partitions are:

    GPT fdisk (gdisk) version 0.8.5

    Partition table scan:
    MBR: protective
    BSD: not present
    APM: not present
    GPT: present

    Found valid GPT with protective MBR; using GPT.
    Disk /dev/sda: 500118192 sectors, 238.5 GiB

    Number Start (sector) End (sector) Size Code Name
    1 2048 534527 260.0 MiB FFFF EFI system partition
    2 534528 3553279 1.4 GiB 2700 Basic data partition
    3 3553280 4085759 260.0 MiB EF00 OpenSuSE EFI Partition
    4 4085760 4347903 128.0 MiB 0C01 Microsoft reserved part
    5 4347904 8546303 2.0 GiB 0700 OpenSuse Swap Partition
    6 454043648 500117503 22.0 GiB 2700 Microsoft Recovery Part
    7 8546304 60983295 25.0 GiB 0700 OpenSuSE Root partition
    8 60983296 102928383 20.0 GiB 0700 OpenSuSE Home partition
    9 102928384 454043647 167.4 GiB 0700 OpenSuSE Srv partition


    I then went into rescue boot from install usb and found that the linux partition was not added to the boot list. So I manually added the partition and even set it as the next boot partition.

    efibootmgr -c -g -d /dev/sda -p 3 -L "OpenSuSE 12.3" -w -l '\EFI\opensuse\grubx86.efi'
    efibootmgr -n 6

    efibootmgr

    BootNext: 0006
    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0006,0007
    Boot0000* EFI USB Device (hp USB FLASH DRIVE)
    Boot0001* EFI Network 0 for IPv6 (54-53-ED-1D-FE-62)
    Boot0002* EFI Network 0 for IPv4 (54-53-ED-1D-FE-62)
    Boot0003* EFI Network 0 for IPv4 (54-53-ED-1D-FE-62)
    Boot0004* EFI Network 0 for IPv6 (54-53-ED-1D-FE-62)
    Boot0005* EFI Network 0 for IPv4 (54-53-ED-1D-FE-62)
    Boot0006* OpenSuSE 12.3


    System does not find Linux OS still and booting into rescue again to check efi settings shows the OpenSuse entry is gone.

    I previiously loaded the latest available BOIS update for the system before trying all this, so I think I'm either running into some yet uncovered bug in the bios, or opensuse 12.3 or the uefi is not allowing changes because of verification failures. There are no errors being reported when making the changes so I can't tell which may be the case.

    Have you run across this scenario or can you provide any suggestions.

    Thanks
  11. jdmcdaniel3's Avatar
    So I don't use Tumbleweed, but YaST is configured by default in openSUSE 12.3 to keep three kernels installed in the same version. So perhaps the original installed 3.7 version is kept and then (3) 3.8 kernel versions is what you get. To look at or set these parameters, edit the config file as follows:

    [SIZE=2][CODE]In KDE do Alt-F2: kdesu kwrite /etc/zypp/zypp.conf[/CODE]

    OR

    [CODE]In Gnome do Alt-F2: gnomesu gedit /etc/zypp/zypp.conf [/CODE][/SIZE]

    Find the lines that start with [SIZE=2]multiversion = &[/SIZE][SIZE=2][SIZE=2] multiversion.kernels = [/SIZE] [/SIZE]:

    [SIZE=2][CODE]multiversion = provides:multiversion(kernel)
    multiversion.kernels = latest,latest-1,running[/CODE][/SIZE]

    The first line says to keep mutiversion kernels installed (don't remove older kernels install by YaST) and the second says to keep three versions so you can drop back one or two versions if you need to. These settings only effect kernels loaded by YaST, that is, you did not compile and install your own kernel outside of using YaST. To stop these actions you can put a remark # in front of the line and save the file. Line two would not do anything unless line one is not remarked out and they work together to form the default action used in openSUSE 12.3.

    Thank You,