Blog Comments

  1. vazhavandan's Avatar
    >>So, if you are running openSUSE 12.1
    Did you mean 12.3 ? Or did you mean that the script works across board from 12.1 to 12.3 ?

    I don't know if the script is supposed to work this way but:-
    It would be better if prerequisites are posted like "Oss,etc ... repos should be configured and enabled etc". If i have all the repos disabled and when i choose 'Y' for installation of "analyze","graphviz", the script doesn't exit pointing out that it couldn't install stuff..Also the script is not gnome-terminal friendly.I think since it is designed for "Konsole" where terminal background is black,this was not noticeable.
    See here :-

    Overall great job thanks
  2. jdmcdaniel3's Avatar
    [QUOTE=vazhavandan;bt781]change systend to systemd before 3rd screen[/QUOTE]

    Got it and thank you. Its been a long weekend of coding for SysdCmd. Hopefully it will be useful to some openSUSE users.

    Thank You,
  3. vazhavandan's Avatar
    change systend to systemd before 3rd screen
  4. jdmcdaniel3's Avatar
    [B] nVIDIA driver 313.30 (32 & 64 bit versions) have been released[/B]


    Fixed CVE-2013-0131: NVIDIA UNIX GPU Driver ARGB Cursor Buffer Overflow in "NoScanout" Mode. This buffer overflow, which occurred when an X client installed a large ARGB cursor on an X server running in NoScanout mode, could cause a denial of service (e.g., an X server segmentation fault), or could be exploited to achieve arbitrary code execution.

    [B]Supported Hardware:[/B]

    [CODE]GeForce 700M series:
    GT 730M, 710M

    GeForce 600 series:
    GTX TITAN, GTX 690, GTX 680, GTX 670, GTX 660 Ti, GTX 660, GTX 650 Ti BOOST, GTX 650 Ti, GTX 650, GT 645, GT 640, GT 630, GT 620, GT 610, 605

    GeForce 600M series:
    GTX 680MX, GTX 680M, GTX 675MX, GTX 675M, GTX 670MX, GTX 670M, GTX 660M, GT 650M, GT 645M, GT 640M LE, GT 640M, GT 635M, GT 630M, GT 625M, GT 620M, G610M

    GeForce 500 series:
    GTX 590, GTX 580, GTX 570, GTX 560 Ti, GTX 560 SE, GTX 560, GTX 555, GTX 550 Ti, GT 545, GT 530, GT 520, 510

    GeForce 500M series:
    GTX 580M, GTX 570M, GTX 560M, GT 555M, GT 550M, GT 540M, GT 525M, GT 520MX, GT 520M

    GeForce 400 series:
    GTX 480, GTX 470, GTX 465, GTX 460 v2, GTX 460 SE v2, GTX 460 SE, GTX 460, GTS 450, GT 440, GT 430, GT 420, GT 415, 405

    GeForce 400M series:
    GTX 485M, GTX 480M, GTX 470M, GTX 460M, GT 445M, GT 435M, GT 425M, GT 420M, GT 415M, 410M

    GeForce 300 series:
    GT 340, GT 330, GT 320, 315, 310

    GeForce 300M series:
    GTS 360M, GTS 350M, GT 335M, GT 330M, GT 325M, GT 320M, 320M, 315M, 310M, 305M

    GeForce 200 series:
    GTX 295, GTX 285, GTX 280, GTX 275, GTX 260, GTS 250, GTS 240, GT 240, GT 230, GT 220, G210, 210, 205

    GeForce 200M series:
    GTX 285M, GTX 280M, GTX 260M, GTS 260M, GTS 250M, GT 240M LE, GT 240M, GT 230M, GT 220M, G210M

    GeForce 100 series:
    GT 140, GT 130, GT 120, G 100

    GeForce 100M series:
    GTS 160M, GTS 150M, GT 130M, GT 120M, G 110M, G 105M, G 103M, G 102M

    GeForce 9 series:
    9800 GX2, 9800 GTX+, 9800 GTX/GTX+, 9800 GT, 9600 GT, 9600 GSO 512, 9600 GSO, 9600 GS, 9500 GT, 9500 GS, 9400 GT, 9400, 9300 SE, 9300 GS, 9300 GE, 9300 / nForce 730i, 9300, 9200, 9100

    GeForce 9M series:
    9800M GTX, 9800M GTS, 9800M GT, 9800M GS, 9700M GTS, 9700M GT, 9650M GT, 9650M GS, 9600M GT, 9600M GS, 9500M GS, 9500M G, 9400M G, 9400M, 9300M GS, 9300M G, 9200M GS, 9100M G

    GeForce 8 series:
    8800 Ultra, 8800 GTX, 8800 GTS 512, 8800 GTS, 8800 GT, 8800 GS, 8600 GTS, 8600 GT, 8600 GS, 8500 GT, 8400 SE, 8400 GS, 8400, 8300 GS, 8300, 8200, 8100 / nForce 720a

    GeForce 8M series:
    8800M GTX, 8800M GTS, 8700M GT, 8600M GT, 8600M GS, 8400M GT, 8400M GS, 8400M G, 8200M G, 8200M

    NVS Series:
    NVS 510, NVS 310, NVS 300

    Quadro series:
    K5000, 7000, 6000, 600, 5000, 410, 4000, 400, 2000D, 2000

    Quadro FX series:
    FX 5800, FX 580, FX 570, FX 5600, FX 4800, FX 4700 X2, FX 4600, FX 380 LP, FX 3800, FX 380, FX 370 Low Profile, FX 3700, FX 370, FX 3400/4400, FX 1800, FX 1700, CX

    Quadro Notebook series:
    K5000M, K4000M, K3000M, K2000M, K1000M, 5010M, 5000M, 4000M, 3000M, 2000M, 1000M

    Quadro FX Notebook series:
    FX 880M, FX 770M, FX 570M, FX 380M, FX 3800M, FX 370M, FX 3700M, FX 360M, FX 3600M, FX 2800M, FX 2700M, FX 1800M, FX 1700M, FX 1600M

    Quadro NVS series:
    NVS 450, NVS 420, NVS 295, NVS 290

    Quadro NVS Notebook series:
    NVS 5400M, NVS 5200M, NVS 4200M, NVS 320M, NVS 160M, NVS 150M, NVS 140M, NVS 135M, NVS 130M

    Quadro Plex series:
    Model IV, Model II, D Series, 7000

    Quadro Sync series:
    Sync, G-Sync II

    Quadro SDI series:
    Quadro SDI

    ION series:

    C-Class Processors:
    Tesla C870, Tesla C2075, Tesla C2070, Tesla C2050, Tesla C1060, T10 Processor

    M-Class Processors:
    Tesla M2090, Tesla M2075, Tesla M2070-Q, Tesla M2070, Tesla M2050, Tesla M1060

    X-Class Processors:
    Tesla X2090

    S-Class Systems:
    Tesla S2050

    K-Series Processors:
    Tesla K20Xm, Tesla K20m, Tesla K20c, Tesla K10[/CODE]

    Thank You,
  5. jdmcdaniel3's Avatar
    Have a look at some new info useful in writing bash scripts here: [URL][/URL]

    Thank You,
  6. jdmcdaniel3's Avatar
    S.A.C.T. - Samba Automated Configuration Tool has been updated to Version 1.07 with new status menus in:

    "6 . Samba Status, Testing and Log File Viewer Menu"

    showing the new:

    "3 . Show the smb program build status"


    "5 . Run testparm on /etc/samba/smb.conf file with defaults"

    menu options. Other minor changes have also been made.

    Thank You,
  7. jdmcdaniel3's Avatar
    In the S.A.C.T. New Main menu option "6 . Samba Status, Testing and Log File Viewer Menu" , you will find a status check named "3 . Run testparm on your default /etc/samba/smb.conf file" and when you run this test, you may find the error that says:

    [CODE]rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)[/CODE]

    This error is said to not be a problem and not in need of fixing, but if you would like to eliminate it, here is what you do:

    Edit the file /etc/security/limits.conf as root and add the following line at the bottom, save the file and reatrt openSUSE when done:

    [CODE]* - nofile 16384[/CODE]

    I have a bash script useful in editing system files own by root you can find here: [URL=""]SYSEdit - System File Editor - Version 1.00 - Blogs - openSUSE Forums

    [/URL] After you restart openSUSE, run the same test again and you will find the old error message will now be gone.

    Thank You,
  8. jdmcdaniel3's Avatar
    [SIZE=4][B]Folder Sharing For /home:

    [/B][SIZE=2]You can share your home area if you want it to show up like the other folder shares. When accessed this way, you must still enter the user name and password, but a viewer will know that /home/username is present for access. You make an entry at the end of your /etc/samba/smb.conf file as root:

    comment= User Home
    only guest=no
    create mask=0777
    directory mask=0777
    [SIZE=2]Anyway, just another /home folder sharing option you can use.

    Thank You,

    Updated 23-Nov-2013 at 10:16 by jdmcdaniel3
  9. jdmcdaniel3's Avatar
    [SIZE=3][B]CIFS Mount from fstab File Problems[/B][/SIZE]:

    For more information on using the cifs mount command from your /etc/fstab file, have a look at this guide here: [URL=""]Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 11 plus FAQs[/URL]

    While I am not a fan of having a permanent Samba share mount being made from your fstab file, I do see a lot of folks having a problem with it not working properly when used from the fstab file but it does work from the command prompt. If this is happening to you, then the problem may be due to your network not yet being up when the fstab mounts are executed at boot time. You could test this theory by opening up a terminal after an openSUSE restart and where the cifs mounts did not work and try this command:

    [CODE]james@LinuxMaster:~> su -
    LinuxMaster:~ # mount -a
    LinuxMaster:~ # df
    Filesystem 1K-blocks Used Available Use% Mounted on
    devtmpfs 8182504 4 8182500 1% /dev
    tmpfs 8209780 168 8209612 1% /dev/shm
    tmpfs 8209780 8148 8201632 1% /run
    /dev/sdb2 106994728 17296160 84256828 18% /
    tmpfs 8209780 0 8209780 0% /sys/fs/cgroup
    tmpfs 8209780 8148 8201632 1% /var/lock
    tmpfs 8209780 8148 8201632 1% /var/run
    /dev/sda2 207846992 60684 206729832 1% /Backup
    /dev/sda4 480834248 203225952 253176680 45% /DataSafe
    /dev/sda3 264093632 68140372 194879508 26% /home
    /dev/sdd2 1953153020 62139568 1891013452 4% /Windows
    /dev/sdc1 1465136124 306207028 1158929096 21% /Multimedia
    /dev/sde1 1465136124 283431900 1181704224 20% /Software

    If all of your cifs mounts work (I don't use the cifs command myself) then you should look at if your network card is being turned on at boot time or if it is set to start [B]On cable connection[/B]. To check this setting in YaST lets go to [B]YaST[/B] / [B]Network Settings[/B] / [B]Network Devices[/B]


    In order to make a change, we need to being using [B]Traditional Method with ifup[/B]. You can switch back to [B]User Controlled by NetworkManager [/B]after this change is made:


    Next, lets go to the [B]Overview[/B] Tab, select your network card and pick the [B]Edit[/B] Button at the bottom:


    On the[B] General[/B] tab make sure the [B]Device Activation[/B] is set to:[B] [U]At Boot Time[/U][/B]


    Once done, select [B]Next[/B] and then [B]Done[/B]. If you normally use the Network Manager, before you select [B]Done[/B], Go Back and Select the [B]Global Options[/B] Tab and select[B] User Controlled with NetworkManager[/B] and then press the [B]Done[/B] Button.

    [SIZE=4][B]Additional Resources:[/B][/SIZE]

    To edit your /etc/fstab file or any system file, have a look at the following blog post.

    SYSEdit - System File Editor - Version 1.50: [URL][/URL]

    Additional Online Resources can be found here:

    1. [URL=""]Index of /samba/docs/man[/URL]
    2. [URL=""]openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna[/URL]
    3. [URL=""]Samba - opening windows to a wider world[/URL]

    As always, if you have any comments, issues or requests, please let me know what they are.

    Thank You,
    Updated 12-Apr-2013 at 15:12 by jdmcdaniel3
  10. jdmcdaniel3's Avatar
    [QUOTE=Knurpht;2544326]Just FYI: it was confirmed today in a thread on G+ by Marcus Meisner, that there is an issue the devs missed at building 12.3: to properly use the NVIDIA driver, the user needs to be in the "video" group.
    An update of systemd is going to fix this soon.[/QUOTE]

    Thank You,
  11. jdmcdaniel3's Avatar
    nVIDIA driver 310.44 has been released with the following fixes.

    Fixed CVE-2013-0131: NVIDIA UNIX GPU Driver ARGB Cursor Buffer Overflow in "NoScanout" Mode. This buffer overflow, which occurred when an X client installed a large ARGB cursor on an X server running in NoScanout mode, could cause a denial of service (e.g., an X server segmentation fault), or could be exploited to achieve arbitrary code execution.
  12. jdmcdaniel3's Avatar

    For added security in using Samba on your home or small network, a couple of added parameters can help insure no communications from outside your local network subnet will be allowed. These next values shown will be added under the Global section (the first group at the top of your /etc/samba/smb.conf file) as:

    [CODE]hosts deny = ALL
    hosts allow =,[/CODE]

    In this example, the local subnet is 192.168.0 as determined by the plus we are allowing the localhost by adding in 127.0.01 and the first statement of hosts deny = ALL, means if you are not in the host allow list, you are being denied, by default.

    [SIZE=3][B]hosts deny (S)[/B][/SIZE]

    The opposite of hosts allow - hosts listed here are NOT permitted access to services unless the specific services have their own lists to override this one. Where the lists conflict, the allow list takes precedence.

    In the event that it is necessary to deny all by default, use the keyword ALL (or the netmask and then explicitly specify to the hosts allow = hosts allow parameter those hosts that should be permitted access.

    [CODE]Default: hosts deny = # none (i.e., no hosts specifically excluded)[/CODE]

    [CODE]Example: hosts deny = 150.203.4. [/CODE]

    [SIZE=3][B]hosts allow (S)[/B][/SIZE]

    A synonym for this parameter is allow hosts.

    This parameter is a comma, space, or tab delimited set of hosts which are permitted to access a service.

    If specified in the [global] section then it will apply to all services, regardless of whether the individual service has a different setting.

    You can specify the hosts by name or IP number. For example, you could restrict access to only the hosts on a Class C subnet with something like allow hosts = 150.203.5.. The full syntax of the list is described in the man page hosts_access(5). Note that this man page may not be present on your system, so a brief description will be given here also.

    Note that the localhost address will always be allowed access unless specifically denied by a hosts deny option.

    You can also specify hosts by network/netmask pairs and by netgroup names if your system supports netgroups. The EXCEPT keyword can also be used to limit a wildcard list. The following examples may provide some help:

    [CODE]Example 1: allow all IPs in 150.203.*.*; except one[/CODE]

    [CODE]hosts allow = 150.203. EXCEPT[/CODE]

    [CODE]Example 2: allow hosts that match the given network/netmask[/CODE]

    [CODE]hosts allow =[/CODE]

    [CODE]Example 3: allow a couple of hosts[/CODE]

    [CODE]hosts allow = lapland, arvidsjaur[/CODE]

    [CODE]Example 4: allow only hosts in NIS netgroup "foonet", but deny access from one particular host[/CODE]

    [CODE]hosts allow = @foonet[/CODE]

    [CODE]hosts deny = pirate[/CODE]

    Note that access still requires suitable user-level passwords.

    See testparm(1) for a way of testing your host access to see if it does what you expect.

    [CODE]Default: hosts allow = # none (i.e., all hosts permitted access)[/CODE]

    [CODE]Example: hosts allow = 150.203.5. [/CODE]


    If you are using Linux kernel version 3.7 or newer, the Samba protocol SMB2 has been added to the kernel. Check out this link and look for SMB2: [url=]Samba - Release Notes Archive[/url] And another interesting Document can be found here: [URL=""][/URL]

    You can take advantage of this fact by adding in the next value. This next setting shown will be added under the Global section (the first group at the top of your /etc/samba/smb.conf file) as:

    [CODE]max protocol = SMB2[/CODE]

    Possible values are :

    [B]CORE[/B]: Earliest version. No concept of user names.

    [B]COREPLUS[/B]: Slight improvements on CORE for efficiency.

    [B]LANMAN1[/B]: First modern version of the protocol. Long filename support.

    [B]LANMAN2[/B]: Updates to Lanman1 protocol.

    [B]NT1[/B]: Current up to date version of the protocol. Used by Windows NT. Known as CIFS.

    [B]SMB2[/B]: Re-implementation of the SMB protocol. Used by Windows Vista and newer. The Samba implementation of SMB2 is currently marked experimental!

    [CODE]Default: [I][I]max protocol[/I] = NT1 [/I][/CODE]
    NMB Failing to Start on Reboot:[/B][/SIZE]

    If, after you restart openSUSE, you notice that no one can find your PC on the network through your Samba share, it may be due to the fact that nmb is not starting. Its possible this is due to a failing of timing by systemd on bootup of your PC. One way to handle that issue to to allow it more time to find your network interfaces.

    This is a [B]YaST[/B] / [B]System[/B] / [B]/etc/sysconfig Editor[/B] Setting at:


    / [B]etc[/B] / [B]sysconfig[/B] / [B]Network[/B] / [B]General[/B] /[B] WAIT_FOR_INTERFACES[/B] Default is [B]30[/B], but I suggest you select [B]60[/B] seconds instead and press [B]OK[/B] and allow this change to be saved. It will be used then on your next openSUSE PC restart.

    [B][SIZE=3]-- CONTINUED --[/SIZE][/B]
    Updated 12-May-2013 at 19:23 by jdmcdaniel3
  13. khaos337's Avatar
    Awesome script! Really helped me out!!
  14. jdmcdaniel3's Avatar
    [LIST][*]NVIDIA Version 310.40 Proprietary Video Driver Release Highlights[*]Added support for the following GPUs:
    [LIST]Quadro K4000
    Quadro K2000
    Quadro K2000D
    Quadro K600
    GeForce G205M
    GeForce GT 240M LE
    GeForce 405M
    GeForce 610
    GeForce 615
    GeForce 620M
    GeForce GT 625M
    GeForce GT 625 (OEM)
    GeForce GT 635
    GeForce 705M
    GeForce 710M
    GeForce GT 710M
    GeForce GT 720A
    GeForce GT 730M
    Tesla X2070
    Tesla S2050
    Tesla K20s[/LIST]
    [*]Reduced the amount of time needed to establish framelock in some stereo configurations with many monitors.[*]Fixed a bug where glXSwapIntervalEXT failed to set a swap interval value of zero in certain situations.[/LIST]
  15. jdmcdaniel3's Avatar
    [SIZE=3][COLOR=#000000][B]UEFI and Secure Boot status [/B]
    It should be possible to install openSUSE 12.3 on a UEFI machine without problems. During the installation process you can see that YaST decides to use the EFI partition (usually /dev/sda1) as a boot partition, setting the mount point to [I]/boot/efi[/I]. That means that YaST will create a directory named “opensuse” in this partition, and will add grub.efi or grubx64.efi file in it. Also, YaST will create a new entry in the firmware boot manager, named again “opensuse”. We can use this new entry to load our distribution without problems. We are working hard to get Secure Boot into the equation, and in RC2 we can fully test the process. The good news is that openSUSE 12.3 RC2 can boot perfectly with Secure Boot enabled in our UEFI firmware.

    For this RC2 the process needs an extra manual action by the user (an issue which will be addressed before the gold master arrive). When YaST shows you a brief summary of the actions that it will do during the installation process (Installation Settings view), you can see now that in the Booting section there is a new entry: “Enable Secure Boot: false”. You need to click on the Booting section, and enable the Secure Boot support. That is all. Now YaST will create two entries in the Boot Loader section of our firmware, and you need to select the “opensuse-secureboot” one to boot your openSUSE distribution when Secure Boot is enabled in your machine.

    Thank You,
  16. jdmcdaniel3's Avatar
    [SIZE=3][B][COLOR=#0000ff]G[/COLOR]lobally Unique Identifier [COLOR=#0000ff]P[/COLOR]artition [COLOR=#0000ff]T[/COLOR]able (GPT) Hard Disks:[/B][/SIZE]

    For GPT Formatted disks, more information is required. By default, the lasted Linux kernel has no problem reading and writing to a GPT partitioned disk. To create your own GPT disk, install the application gptfdisk, if not already installed. Have a look here for more info: [URL=""]GPT fdisk Tutorial[/URL]. A GPT formatted hard disk used on a UEFI PC can exceed the 2.2 Terabyte limit of a MBR based disk and supports the new "Secure Boot" mode which can be used by Windows 8.

    1)[B] UEFI[/B] Firmware: It used to be called a PC BIOS and I may still use the term BIOS but the full name is [B][COLOR=#0000ff]U[/COLOR]nified [COLOR=#0000ff]E[/COLOR]xtensible [COLOR=#0000ff]F[/COLOR]irmware [COLOR=#0000ff]I[/COLOR]nterface[/B] (Unified Extensible Firmware Interface - Wikipedia [[URL=""]Unified Extensible Firmware Interface - Wikipedia, the free encyclopedia[/URL]], the free encyclopedia) or UEFI for short. Its still the starting program in your PC that kicks starts its operation when the PC is turned on or when it gets rebooted. It is designed to keep track of your hardware and to provide a uniform interface for those resources to your operating system. The UEFI system is designed to address lots of issues including total memory and total disk space. And now, with the advent of Windows 8, it can manage the signing of a operating system boot up process, not allowing an OS to boot if it does not match a certain key loaded into the PC firmware. As for hard disks, it needs to understand GUID partition tables and EFI Partitions. A UEFI PC can often be set to work as a simple BIOS and/or certain features operate while others do not, but it is all up the manufacturer as to what you are allowed to do in UEFI PC setup. Normally, to boot from a GPT disk, you need a PC that supports UEFI. UEFI function is very much in the hands of the hardware vendor, some can be very minimal in the nvram (eg HP Probook 4525s) and some full of features (eg DELL Latitude E5510). I think that probably a business oriented system will probably have better features than your run of the mill systems for casual users.

    2) [B]GUID[/B] Partition Table (GPT): Stands for a [B][COLOR=#0000ff]G[/COLOR]lobally Unique Identifier [COLOR=#0000ff]P[/COLOR]artition [COLOR=#0000ff]T[/COLOR]able[/B] or GUID for short or perhaps called a GPT partition (GUID Partition Table - Wikipedia [[URL]][/URL] the free encyclopedia). It is a standard for the layout of the partition table on a physical hard disk, but is very different from how a MBR based disk partition type works. It allows for very large hard disks, over 2.2 Terabytes, with very little limit to the number or sizes of the partitions and is about as far from the old MBR partition type as you can get. The basics are that the Linux kernel understands and works with GPT disk partitions just fine, but not all openSUSE disk tools can be used at present with GPT disk partitions. It supports the new "Secure Boot" mode which can be used by Windows 8 and with Linux with some effort [[URL]][/URL].

    3) [B]EFI[/B] System Partition (ESP): An EFI partition is called [B][COLOR=#0000ff]E[/COLOR]xtensible [COLOR=#000000]F[/COLOR]irmware[COLOR=#000000] I[/COLOR]nterface[/B] [B][COLOR=#0000ff]S[/COLOR]ystem [COLOR=#0000ff]P[/COLOR]artition[/B] or ESP and is part of the GPT disk partition definition (EFI System partition - Wikipedia [[URL=""]EFI System partition - Wikipedia, the free encyclopedia[/URL]], the free encyclopedia) designed to work with to be read by a Unified Extensible Firmware Interface PC in order to determine what is going to be booted. You can pretty much have an ESP (aka /boot/efi/EFI ) per partition and call multiple operating systems from any one of those ESP's as long as the efi file exists and is added to the EFI shell via efibootmgr. The efibootmgr is a userspace ([URL=""]efibootmgr(8): change EFI Boot Manager - Linux man page[/URL]) application used to modify the Intel Extensible Firmware Interface (EFI) Boot Manager. This application can create and destroy boot entries, change the boot order, change the next running boot option, and more.

    4) Grub2 or Grub2-efi [[URL=""]][/URL] is the latest incarnation of the openSUSE Linux Operating System boot selector with the efi version required to boot from a UEFI enabled PC. Grub2-efi should be able to boot from anything, but the manual partitioning tools that come with openSUSE 12.2 may not allow all possible GPT Partitions with a GPT disk partition setup, to be created. To perform all tasks with GPT disks, you should install the application utility called gptfdisk from YaST.

    5) As for loading openSUSE on a secondary or even external hard disk, there are just a few things you must do.

    a) Your PC UEFI or BIOS must allow you to select and boot from the second or external hard drive.
    b) The disk partition setup must be compatible with openSUSE 12.2.
    c) You must on purpose place all three suggested/required partitions on that second or external hard disk including root /, /home & SWAP
    d) You must make sure to either install the Grub 2 boot loader into the MBR (I recommend for a MBR disk) or place generic boot code into the MBR. Consider that secondary or external hard drives may contain a blank MBR which will not boot no matter what else is on the rest of the disk.

    6) In order to install openSUSE on a GPT disk using UEFI, you must select the UEFI boot mode for your openSUSE install DVD in your EFI equipped PC setup. In order to select the openSUSE DVD to enable a new install disk boot mode called [B]ELILO[/B] ([B][COLOR=#0000ff]E[/COLOR]FI [COLOR=#0000ff]L[/COLOR]inux [COLOR=#0000ff]L[/COLOR]oader[/B]), you must enter your PC UEFI mode. If you just boot from the openSUSE DVD, you will not be in the UEF enabled mode. The fact that a UEFI mode called ELILO is included with the standard MBR disk boot mode is why the openSUSE installation disk is often called a Hybrid disk. It includes MBR & ELILO boot modes. Booting from a USB DVD drive in the UEFI mode may not work, depending on your UEFI PC capabilities.

    7) By default and in UEFI mode, openSUSE will create the proper setup to boot openSUSE from that disk, but if the intent is to dual boot from the GPT disk, you must use your UEFI enabled PC to select which ESP partition to boot from, meaning the dual boot nature of grub2 does not include (at present) any other boot partitions on the same GPT disk. Expect this to be fixed in openSUSE 12.3 and newer openSUSE versions.

    8) It is possible to wipe out a GPT formatted disk, reverting to an MBR setup. Have a look at this post on the subject. ([URL=""]Wiping Out Old GPT Data[/URL])

    GPT Disk Layout:
    The GPT disk partitions in openSUSE could be named sda1, sda2, sdb1 or sdb2 where 'a' is the first hard drive and 'b' is the second hard drive and so forth. Partition numbers 1-128 are always Primary, as No Extended or Logical Partitions Exist. Deleting Partitions can cause missing Partition numbers and any added Partitions after a delete may not physically be in numerical order.

    If you have any questions or problems with this content, or if a link does not work for you, please leave me a comment on the issue TODAY!

    To help provide information on your disk boot setup, you can open up a terminal session and type in (copy from here and paste into terminal) the following command:

    [CODE]rm ~/bin/bis ; wget -nc -O ~/bin/bis ; chmod +x ~/bin/bis ; sudo bis[/CODE]

    If your disk will not boot, then boot from an openSUSE LiveCD, open up a terminal session and run the above command. Then, while still running the LiveCD, go online and post the results of the bash script into a code # block using the advanced message text editor. You can find openSUSE LiveCD's at the following download link.

    [URL=""] Download openSUSE 12.2[/URL]

    Thank You,
  17. jdmcdaniel3's Avatar
    [QUOTE=spmaster;bt666]it is not me, I swear! though, who else?
    Thank you very much! It works.

    Another question - userfix will be run every system startup ( after make-dkms-installer was executed) ?

    Thx again![/QUOTE]

    The USERFIX bash script is run before your nVIDIA driver gets compiled into the kernel. If there are any tasks that needs to be run first, USERFIX can do it. I can up with this when a certain kernel version required a modification so that the nVIDIA driver could be installed and USERFIX could do that. Now, its there if you need it.

    Thank You,
  18. spmaster's Avatar
    it is not me, I swear! though, who else? lol!
    Thank you very much! It works.

    Another question - userfix will be run every system startup ( after make-dkms-installer was executed) ?

    Thx again!
  19. jdmcdaniel3's Avatar
    I did everything by your instructions.

    I'v tried something else: put the driver in the home directory of the root and used $HOME - didn't help toо

    May be something wrong because
    LANG=ru_RU.UTF-8 ?

    Thank You[/QUOTE]

    So I see the problem now. You have renamed your nVIDIA propritary video files files to *.bin from *.run.

    spmaster@sac:~> ls /home/spmaster/Downloads/
    NVIDIA-Linux-x86_64-310.32.bin NVIDIA-Linux-x86_64-313.18.bin

    Will work if it says ...

    spmaster@sac:~> ls /home/spmaster/Downloads/

    Just like they come from a nVIDIA site download.

    Thank You,
  20. spmaster's Avatar
    Nothing :'(
    I did everything by your instructions.

    I'v tried something else: put the driver in the home directory of the root and used $HOME - didn't help toо

    May be something wrong because
    LANG=ru_RU.UTF-8 ?

    Thank You
Page 3 of 10 FirstFirst 12345 ... LastLast