PDA

View Full Version : TUMBLEWEED Problema al instalar Calibre



Vernius
03-Oct-2022, 07:14
Hola. Estoy intentando instalar calibre a traves de zypper y me da el siguiente error. ¿Que opcion tengo que asplicar-escoger?


Problema: nada proporciona libQt6Gui.so.6(Qt_6.3.2_PRIVATE_API)(64bit), que el elemento calibre-6.5.0-1.1.x86_64 que se va a instalar necesita
Solución 1: no instalar calibre-6.5.0-1.1.x86_64
Solución 2: romper calibre-6.5.0-1.1.x86_64 ignorando algunas de sus dependencias

Elija las soluciones usando '1' o cancele usando 'c' [1/2/c/i/?] (c):

Gracias

krovikan
03-Oct-2022, 08:19
Hola. Estoy intentando instalar calibre a traves de zypper y me da el siguiente error. ¿Que opcion tengo que asplicar-escoger?


Problema: nada proporciona libQt6Gui.so.6(Qt_6.3.2_PRIVATE_API)(64bit), que el elemento calibre-6.5.0-1.1.x86_64 que se va a instalar necesita
Solución 1: no instalar calibre-6.5.0-1.1.x86_64
Solución 2: romper calibre-6.5.0-1.1.x86_64 ignorando algunas de sus dependencias

Elija las soluciones usando '1' o cancele usando 'c' [1/2/c/i/?] (c):

Gracias

A bote pronto, no puedes.

Qt6 es de pago (sin versión libre como hasta la 5.15) y no se puede usar en desarrollos de programas (salvo que paguen por una licencia para usarlo).

Quizás el programa ha pagado la licencia, pero... ¿qué hace el usuario de a pie para instalarlo?

Pues no lo sé, igual hay algo que desconozco.

Saludos

mikrios
03-Oct-2022, 08:41
Hola:

Es la opción 1.

Ademas la versión oficial es la 6.6.1 (que es la que aparece en la página de descargas ) .

De todas formas, si consta en algún repositorio , ejecuta : zypper se -s calibre.

En este momento no tengo encendido TW, si no la 15.3 y en esa versión de Leap, tiene otra referencia :



S | Name | Type | Version | Arch | Repository
--+---------+---------+-------------------+--------+----------------------
| calibre | package | 3.48.0-lp153.1.35 | x86_64 | Repositorio principal
| calibre | package | 3.48.0-lp153.1.35 | x86_64 | Repositorio principal



Que se corresponde con la versión oficial de la 15.2 y 15.3 de Leap (tanto en los repositorios, como en la pagina de descarga de software) .

Saludos cordiales

krovikan
03-Oct-2022, 10:08
Aquí está la web de buscador de software de opensuse con el resultado de buscar calibre:

https://software.opensuse.org/package/calibre

Clickando en el repo oficial de TW puedes ver esto:

https://i.imgur.com/UuQgFJf.png

Como se puede ver es irresoluble el crear el paquete a falta de varios elementos.

Lo que no sé es por qué aparece como inestalable algo que es inestalable... (sí, ya, la página la dejan hecha para cuando lo sea, pero es ilógico, en todo caso la ocultas).


Saludos

mikrios
03-Oct-2022, 15:20
Hola:

Es una pena, ya que todo aquello que de una forma social, favorezca la comunicación , como pueda ser un lector de documentos, etc, no debería tener reparos en que se divulgue de forma gratuita, a lo mucho que reciba un subvención.

Todo aquello que sirva para mejorar la comunicación y aumentar el nivel cultural del pueblo, no debería tener frenos y menos para gente que no se lo pueda permitir. (es como si invento un medicamento y cobro por el) .

Me acuerdo cuando en UK, se eligió el ordenador BBC de la marca Acorn, todo libro, material informático, material educativo, estaba libre de impuestos, los que salían beneficiados eran los estudiantes y en un futuro la propia sociedad.

En fin que se le va hacer, ojala saquen una alternativa .

Saludos cordiales .

Vernius
03-Oct-2022, 23:51
Hola. Ya esta el caso en bugzilla, por ahora irresoluble. Toca esperar.
https://bugzilla.opensuse.org/show_bug.cgi?id=1203967
Saludos

victorhck
04-Oct-2022, 09:12
Con la última actualización de Tumbleweed se daba ese problema. Quizás Qt6 todavía no está en los repositorios y ha llegado antes Calibre que las dependencias necesarias.
En mi caso como no lo uso, cuando me dió el error lo desinstalé (creía haberlo desinstalado y haberlo puesto como tabú)

Problemas así suelen solucionarlos en una próxima actualización... veremos si esto también se soluciona...

Saludos.

DiabloRojo
05-Oct-2022, 04:05
En mi caso calibre siempre lo instalo con el script de su Web, copiar y pegar en una consola.

Vernius
05-Oct-2022, 06:02
En mi caso calibre siempre lo instalo con el script de su Web, copiar y pegar en una consola.

Hola. Con ese metodo de instalacion, se actualiza automaticamente? Saludos

DiabloRojo
06-Oct-2022, 01:37
Hola. Con ese metodo de instalacion, se actualiza automaticamente? SaludosNo se actualiza automáticamente, te sale un aviso de que hay una nueva actualización y tienes que actualizarlo de la misma manera con el script, pero no te preocupes, no pierdes la configuración y ni los libros.

Vernius
06-Oct-2022, 03:55
No se actualiza automáticamente, te sale un aviso de que hay una nueva actualización y tienes que actualizarlo de la misma manera con el script, pero no te preocupes, no pierdes la configuración y ni los libros.

Gracias por tu ayuda. Instalado con el script de la web de calibre, funcionando perfectamente.

sudo -v && wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin

Saludos

victorhck
06-Oct-2022, 06:23
hilo sobre el tema en las listas de correo:

https://lists.opensuse.org/archives/list/factory@lists.opensuse.org/thread/4GVGQZ2VTHMT3W5TDGNCBPTK3IWVHV7P/

nemonix
06-Oct-2022, 18:16
Hola, veo que ya esta solucionado yo utilizo siempre el portable siempre ha ido bien


https://www.fosshub.com/Calibre.html

rotfl!