PDA

View Full Version : Problemas con Plymouth



Liamwil
07-Sep-2022, 06:41
Me ha empezado a dar morcilla, indicando que no puede cargar plymouth, tanto en arranque y cierre, como en mensajes de un aplet de puesta al día, algo por estilo de " plymouth-lang-0.9.5~git20210406.e554475-150400.3.5.1.noarch requires 'plymouth = 0.9.5~git20210406.e554475',

karlggest
07-Sep-2022, 07:10
Hola!

Bienvenide al foro!

El mensaje que has puesto es un poco críptico. El mensaje que indicas es que una actualización de un paquete requiere una versión específica de otro paquete.

Puedes usar el instalador de software para comprobar qué versión de plymouth tienes y para asegurarte de que cada paquete relacionado (al menos plymouth-lang) tiene instalada la misma versión.

Salud!!

mikrios
07-Sep-2022, 14:00
Hola :

¿ Que versión de linux tienes ? .

Es raro que plymouth tenga un archivo de lang , ahora bien la versión , por ejemplo de Leap 15.3 va por la 0.9.5+git ... etc ; con la diferencia que ese tipo de archivo no viene.

Plymouth es un sistema grafico que se pone en el arranque del pc, para evitar parpadeos y problemas gráficos , mientras se carga .

Has cambiado el tema grafico en pantalla del arranque del equipo ? .

Si quieres ver las versiones de plymouth que tienes instaladas, puedes ejecutar en consola como super usuario, lo siguiente : zypper se -si plymouth .



HP-OMEN:~ # zypper se -si plymouth
Loading repository data...
Warning: Repository 'openSUSE:Backports:SLE-15-SP3' appears to be outdated. Consider using a different mirror or server.
Warning: Repository 'Repositorio principal de actualizaciones' appears to be outdated. Consider using a different mirror or server.
Warning: Repository 'Repositorio principal de actualizaciones' appears to be outdated. Consider using a different mirror or server.
Reading installed packages...

S | Name | Type | Version | Arch | Repository
---+----------------------------+---------+----------------------------------------+--------+-------------------------------------------------------------
i+ | plymouth | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-branding-openSUSE | package | 15.3.20210112-lp153.1.26 | noarch | Repositorio principal
i+ | plymouth-branding-openSUSE | package | 15.3.20210112-lp153.1.26 | noarch | Repositorio principal
i+ | plymouth-dracut | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-dracut | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-plugin-label | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-plugin-label | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-plugin-label-ft | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-plugin-label-ft | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-plugin-two-step | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-plugin-two-step | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-scripts | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-scripts | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-theme-bgrt | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-theme-bgrt | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-theme-spinner | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | plymouth-theme-spinner | package | 0.9.5+git20190908+3abfab2-150300.7.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15


Saludos

karlggest
08-Sep-2022, 02:47
Hola!

Mikrios, es un cambio en la versión. En la que viene con Leap 15.4 sí que hay un paquete lang:


:~> zypper se -si plymouth
Obtendo os datos do repositorio...
Lendo os paquetes instalados...

S | Name | Type | Version | Arch |
Repository
---+----------------------------+---------+---------------------------------------+--------+-
---------------------
i+ | plymouth | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | x86_64 |
Repositorio Principal
i+ | plymouth-branding-openSUSE | Paquete | 15.4.20220322-lp154.2.3 | noarch |
Repositorio Principal
i+ | plymouth-dracut | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | noarch |
Repositorio Principal
i | plymouth-lang | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | noarch |
Repositorio Principal
i+ | plymouth-plugin-label | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | x86_64 |
Repositorio Principal
i+ | plymouth-plugin-label-ft | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | x86_64 |
Repositorio Principal
i+ | plymouth-plugin-script | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | x86_64 |
Repositorio Principal
i+ | plymouth-plugin-two-step | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | x86_64 |
Repositorio Principal
i+ | plymouth-scripts | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | noarch |
Repositorio Principal
i+ | plymouth-theme-bgrt | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | noarch |
Repositorio Principal
i+ | plymouth-theme-spinner | Paquete | 0.9.5~git20210406.e554475-150400.1.32 | noarch |
Repositorio Principal

Salud!!

mikrios
08-Sep-2022, 11:30
Hola:

Gracias, lo mirare cuando actualice los sistemas, que pruebo en la x299.

Puede que abra la posibilidad de mensajes en plymouth ( que sepa había 3 o 4 temas ) , Los que tenían creo que era de 256 colores como máximo y resolución no muy alta .

Intentare averiguar algo mas, haber si hay información tipo txt en el sistema que diga algo (lo que es en la 15.3 , lo que encuentro de plymouth es el directorio vacío ) y aporte información que relacione el lenguaje con plymouth .

Saludos cordiales .

mikrios
08-Sep-2022, 13:21
Hola:


Efectivamente , es correcto .
Lo curioso es que las actualizaciones , que se realizaron hoy, en mi pc , se incluye añadidos de plymouth , ademas comprobé antes y después de actualizar y me salen el mismo nº de archivos :



mikrios:~ # zypper se -si plymouth
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+----------------------------+---------+----------------------------------------+--------+-------------------------------------------------------------
i | plymouth | package | 0.9.5~git20210406.e554475-150400.3.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | plymouth-branding-openSUSE | package | 15.4.20220322-lp154.2.3 | noarch | Repositorio principal
i | plymouth-dracut | package | 0.9.5~git20210406.e554475-150400.3.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | plymouth-lang | package | 0.9.5~git20210406.e554475-150400.3.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | plymouth-plugin-label | package | 0.9.5~git20210406.e554475-150400.3.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | plymouth-plugin-two-step | package | 0.9.5~git20210406.e554475-150400.3.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i | plymouth-scripts | package | 0.9.5~git20210406.e554475-150400.3.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | plymouth-theme-bgrt | package | 0.9.5~git20210406.e554475-150400.3.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i | plymouth-theme-spinner | package | 0.9.5~git20210406.e554475-150400.3.5.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15



Con respeto a la actualización de hoy, no he tenido problemas de dependencias , pero si al ejecutarse el script al final de la actualización, se muestra algún error ( cat /var/log/zypp/history |grep -i plymouth ) , pongo el de la fecha 8-9-2022 :



2022-09-08 20:40:31|install|plymouth-plugin-label|0.9.5~git20210406.e554475-150400.3.5.1|x86_64||repo-sle-update|a1545af2754aa197a9bee48aa925a01d2b1015279ac477a94a3a4e48f661136f|
2022-09-08 20:40:43|install|plymouth-plugin-two-step|0.9.5~git20210406.e554475-150400.3.5.1|x86_64||repo-sle-update|3d2412238e6ce05399f2e9464e90e8cc2748a1ec057e2677aa5e4dd5a51a1a
aa|
2022-09-08 20:40:43|install|plymouth-scripts|0.9.5~git20210406.e554475-150400.3.5.1|noarch||repo-sle-update|ac19368346292978aa5e1cd2b6e7538095ebc71bdded8645379d0a0caa08e84b|
2022-09-08 20:40:44|install|plymouth|0.9.5~git20210406.e554475-150400.3.5.1|x86_64||repo-sle-update|510efdfdf7fa3a469684e936be169b4e456a5a19fb23bc4ba136a83cbb4ebead|
2022-09-08 20:40:44|install|plymouth-lang|0.9.5~git20210406.e554475-150400.3.5.1|noarch||repo-sle-update|5deeb10937a601e0db857178a540e212529e164096c4f381439b405cc5cd3098|
2022-09-08 20:41:08|install|plymouth-theme-spinner|0.9.5~git20210406.e554475-150400.3.5.1|noarch||repo-sle-update|2a1bde9adb304d2936325c77eefdfdca46b6af837fce5aeafd538f5f484e2ddc
|
2022-09-08 20:41:08|install|plymouth-dracut|0.9.5~git20210406.e554475-150400.3.5.1|noarch||repo-sle-update|4dcddd1add4bf2a9270ae26c686ece9b6d1cd0edff3e809a50a52ec62d63fc67|
2022-09-08 20:41:09|install|plymouth-theme-bgrt|0.9.5~git20210406.e554475-150400.3.5.1|noarch||repo-sle-update|562439667f168e1ac1459d19e63f150adb7b0b19b2a51629be0829163851087d|
# dracut: *** Including module: plymouth ***
# /usr/lib/plymouth/plymouth-populate-initrd: line 450: +: command not found
# dracut: *** Including module: plymouth ***
# /usr/lib/plymouth/plymouth-populate-initrd: line 450: +: command not found



La linea 450 , lo que tiene, es el simbolo + (como no sea ese un comando, no hay nada , mas) .
¿ es posible que hubiese una equivocación al ejecutar el script ? .



linea 449 PLYMOUTH_TitleFont_PATH=$(fc-list |grep $(fc-match "$(echo $(grep "^TitleFont *= *" ${PLYMOUTH_SYSROOT}${PLYMOUTH_DATADIR}/plymouth/themes/`plymouth-set-default-theme`/`plymouth-set-default-theme`.plymouth | sed -e 's/^TitleFont *= *//'| awk 'NF{NF--};1'))" |awk -F : {'print $1'}) |awk -F : {'print $1'} | sort -u | head -n 1)

linea 450 +

linea 451 [ -f "${PLYMOUTH_Font_PATH}" ] && inst ${PLYMOUTH_Font_PATH} $INITRDDIR


Por lo demas no he visto mas errores.
Podría verificar problemas , ejemplo zypper ve ; otra cosa que se me ocurre, es que hubiese sido temporal y ahora este solucionado, por lo menos a mi no me dio ese fallo .

Saludos cordiales