PDA

View Full Version : LEAP 15.4 docker compose desactualizado



smicroz
28-Aug-2022, 12:46
Hola,

Instalé docker y docker-compose siguiendo las instrucciones de la wiki.

https://en.opensuse.org/Docker

Todo bien, sin embargo, al verificar la versión de docker compose quedó instalada una version antigua.

rpm -q python3-docker-compose
python3-docker-compose-1.25.1-bp154.1.16.noarch


Por cierto, docker engine quedó instalada la última version.

Alguna sugerencia?

gracias

DiabloRojo
29-Aug-2022, 00:44
No se con que criterios dices que tienes disitntas versiones, la ultima de un paquete y una mas antigua de otro paquete.
Dame la salida del comando
zypper se -iv docker

El compañero @soyasi utiliza docker, a ver si nos dice algo. Aqui tienes su hilo: https://forums.opensuse.org/showthread.php/573416-levantando-docker?highlight=docker

smicroz
29-Aug-2022, 09:24
No se con que criterios dices que tienes disitntas versiones, la ultima de un paquete y una mas antigua de otro paquete.
Dame la salida del comando
zypper se -iv docker

El compañero @soyasi utiliza docker, a ver si nos dice algo. Aqui tienes su hilo: https://forums.opensuse.org/showthread.php/573416-levantando-docker?highlight=docker

Hola,

Mas que nada porque estaba ejecutando docker compose (sin guión) y me di cuenta que no encontró el comando:


$ docker compose
docker: 'compose' is not a docker command.




$ zypper se -iv docker

Loading repository data...
Reading installed packages...


S | Name | Type | Version | Arch | Repository
---+------------------------+---------+--------------------------+--------+-------------------------------------------------------------
i+ | docker | package | 20.10.17_ce-150000.166.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
name: docker
i | docker-bash-completion | package | 20.10.17_ce-150000.166.1 | noarch | Update repository with updates from SUSE Linux Enterprise 15
name: docker-bash-completion
i | python3-docker | package | 4.2.0-3.2.1 | noarch | Main Repository
name: python3-docker
i+ | python3-docker-compose | package | 1.25.1-bp154.1.16 | noarch | Main Repository
name: python3-docker-compose
i | python3-docker-pycreds | package | 0.4.0-bp154.1.30 | noarch | Main Repository
name: python3-docker-pycreds
i | python3-dockerpty | package | 0.4.1-bp154.1.19 | noarch | Main Repository



Por cierto, voy a revisar el thread que me recomiendas.

Gracias

soyasi
29-Aug-2022, 12:14
Me imagino que instalastes de los repos oficiales y esas son las versiones oficiales que hay a día de hoy. Son las mismas que uso yo.

Si quieres algo más, mírate esta guía para SLES on s390x (IBM Z)

https://docs.docker.com/engine/install/sles/
(https://docs.docker.com/engine/install/sles/)
ó prueba instalando los binarios

https://docs.docker.com/engine/install/binaries/#install-daemon-and-client-binaries-on-linux

Saludos

smicroz
29-Aug-2022, 17:18
Me imagino que instalastes de los repos oficiales y esas son las versiones oficiales que hay a día de hoy. Son las mismas que uso yo.

Si quieres algo más, mírate esta guía para SLES on s390x (IBM Z)

https://docs.docker.com/engine/install/sles/
(https://docs.docker.com/engine/install/sles/)
ó prueba instalando los binarios

https://docs.docker.com/engine/install/binaries/#install-daemon-and-client-binaries-on-linux

Saludos

Si, de repos oficiales

Sólo me parecía extraño porque la v1 de docker-compose entiendo que quedó obsoleta, pero bueno, voy a intentar de la otra manera que me comentaste.

Gracias