PDA

View Full Version : Adobe reader na LEAP 15.4



Dyrszlak
21-Aug-2022, 08:10
Witam koleżanki i kolegów!

Czy udało się komuś znaleźć repo, albo paczkę z adobe readerem, który dałby się zainstalować pod LEAP 15.4?
Znalazłem na stronie SUSE.org paczkę dla 15.2

https://software.opensuse.org/download/package?package=acroread&project=home%3Aithod%3Arestored

ale nie może rozwiązać zależności a gdy próbuję ignorować twierdzi, że paczka nie zachowuje integralności.
Wine tego też nie chce uruchomić w żadnej akceptowalnej wersji. A potrzebuję wersji odczytującej rządowe pliki z PIT36, 37itp z wtyczkami.

Z góry bardzo dziękuję!

hui
21-Aug-2022, 08:23
Nie znajdziesz żadnego aktualnego repo z Adobe reader, ponieważ wsparcie zakończyło się w 2014 roku! Jeśli uda Ci się zainstalować tę nieutrzymywaną wersję na swoim komputerze, rozerwiesz niezliczone luki w zabezpieczeniach. Adobe nie dostarcza już wersji linuxowej.


Aktualny Adobe Reader DC może być zainstalowany za pomocą PlayOnLinux.
https://www.adobe.com/acrobat/pdf-reader.html

pbojczuk
21-Aug-2022, 09:06
A potrzebuję wersji odczytującej rządowe pliki z PIT36, 37itp z wtyczkami.

Co to są rządowe pliki i o jakie wtyczki chodzi?

Dlaczego Evince do odczytania pliku PDF jest niewystarczający? Pytam, bo chciałym zrozumieć ten user case.


Znalazłem na stronie SUSE.org paczkę dla 15.2

https://software.opensuse.org/downlo...hod%3Arestored (https://software.opensuse.org/download/package?package=acroread&project=home%3Aithod%3Arestored)

ale nie może rozwiązać zależności a gdy próbuję ignorować twierdzi, że paczka nie zachowuje integralności.

Wybudowanie maszyny wirtualnej, z Leap 15.2, by poradzić sobie z zależnościami, jeżeli ta wersja tej paczki Ciebie satysfakcjonuje, nie jest złym rozwiązaniem.

Dyrszlak
21-Aug-2022, 13:39
Co to są rządowe pliki i o jakie wtyczki chodzi?

Dlaczego Evince do odczytania pliku PDF jest niewystarczający? Pytam, bo chciałym zrozumieć ten user case.

Otóż, żeby otworzyć i wypełnić formularz np PIT-36 pobrany ze strony US, być może Evince wystarczy. Jednak, żeby wysłać ten formularz do US poprzez serwer, który od razy zrobi sprawdzenie i potem wyśle potwierdzenie odbioru potrzebna jest wtyczka e-deklaracje do Adobe Readera. Nie wiem, bo nie próbowałem, czy da się taką operację przeprowadzić w Evince. Obawiam się, że dlatego jest zrobiona wtyczka e-deklaracje do Adobe, żeby nie było można z innych softów skorzystać. A wysyłanie tego papierowo jakoś mi się nie uśmiecha.


Wybudowanie maszyny wirtualnej, z Leap 15.2, by poradzić sobie z zależnościami, jeżeli ta wersja tej paczki Ciebie satysfakcjonuje, nie jest złym rozwiązaniem.

Oj... nie robiłem tego jeszcze. Może czas zacząć. NIe wiem, czy na pewno ta paczka da się zainstalować. Czy nie jest po prostu jakoś uszkodzona...


Nie znajdziesz żadnego aktualnego repo z Adobe reader, ponieważ wsparcie zakończyło się w 2014 roku! Jeśli uda Ci się zainstalować tę nieutrzymywaną wersję na swoim komputerze, rozerwiesz niezliczone luki w zabezpieczeniach. Adobe nie dostarcza już wersji linuxowej.

Przekonałeś mnie...



Aktualny Adobe Reader DC może być zainstalowany za pomocą PlayOnLinux.
https://www.adobe.com/acrobat/pdf-reader.html


Aktualny, czyli ten 2022? A ten PlayOnLinux to nie jest to samo, co ten nieszczęsny Wine? Wine sobie nie poradził z żadną wersją readera poczynając od tej najnowszej a na 7 skończywszy. Prawie cały dzień walczyłem ;)

pbojczuk
22-Aug-2022, 12:48
Powiem tak... właśnie mi się przytrafił pdf do wypełnienia. Evince nie działa, Adobe Readera zainstalować nie umiem (zaraz będę guglał, jak inni sobie z tym poradzili), a najlesze efekty mam aplołdując tego pdfa do Google Docs.

Chciałem polecić snapa, ale:
https://i.imgur.com/g3Eg9As.png
(https://i.imgur.com/g3Eg9As.png)
Mam na obu wersjach

latest/stable 2021.007.20091 18 September 2021
latest/edge 2022.001.20142 1 July 2022

Możesz spróbować, ale niczego nie obiecam :-( :
https://snapcraft.io/install/acrordrdc/opensuse

Podejrzewam, że nie masz sudo, dlatego poniższe polecenia wykonaj jako root, bez przedrostka sudo:

Wersję edge zainstalujesz:

sudo snap install acrordrdc --edge

Snapa usuwasz:

sudo snap remove acrordrdc

Dyrszlak
25-Aug-2022, 07:59
Witam!

No u mnie snap się zainstalował bez problemów. acrordrdc --edge też. Ale niestety nie chce się dać uruchomić. Nie ma żadnego komunikatu. Nic. Za pierwszym razem było coś o aktualizacji Wine i nic więcej się nie pokazało. Nie wiem, o co może chodzić. Zajrzę jeszcze w ustawienia Wine. Może coś mi wpadnie w oko...

Dziękuję za próby pomocy.

Mam właśnie problem z podpisanym pdf. Okular i Evince w Suse pokazują, że podpisy są prawidłowe, ale od czasu podpisania w dokumencie nastąpiły zmiany. Nie wiem, co to może oznaczać. Adobe Reader w Androidzie zachowuje się identycznie.

Ale Adobe Reader w Windzie pokazuje, że wszystko gra. Nie wiem co tu się może dziać. Pliki uruchamiane są z tego samego gwizdka, albo z poczty więc to są te same fizycznie pliki.

Pozdrawiam.

A jednak coś się więcej stało. To tylko moja niewiedza na temat snapów. Coś tam gdzieś kiedyś czytałem, ale już zapomniałem. Długo się nic nie działo, ale po kilku minutach wyskoczyła informacja o pobieraniu instalacji Readera Edge. No dobra. Pobrał się, coś tam jeszcze pogrzebał mi w moim Suse i czekam, co będzie dalej... Będę informować.

Pozdrawiam.

No i jednak zadziałało. Czyta mi podpisane pliki pdf. Jak będzie z wypełnianiem i wtyczką do e-deklaracji, zobaczę później. Jakby co, podzielę się zdobytą wiedzą.

Czy teraz po instalacji Readera DC powinienem odinstalować tego snapa acrordrdc?

Ogromnie dziękuję za pomoc!

pbojczuk
26-Aug-2022, 23:33
Czy teraz po instalacji Readera DC powinienem odinstalować tego snapa acrordrdc?


Odinstalowanie snapa odinstaluje wszystko. Być może będziesz chciał spróbować nowszej wersji, czyli snap install acrordrdc --edge. Po prostu sprawdź, czy któraś wersja zadziała z tą wtyczką.