PDA

View Full Version : OTHER VERSION Cubo dejó de funcionar en Leap 15.4



navarrete
22-Jul-2022, 12:43
Hola: Instalé Leap 15.4 desde cero en un SSd-PCIe (WD-SN570) en un mb "ASUS PRIME A320M" (con gráfica integrada).
Anteriormente, en la misma mb y con Leap 15.3 funcionaba el cubo de escritorio.

Salida de: lspci -vnn | grep VGA -A 12
08:00.0 Controlador compatible con VGA [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Picasso/Raven 2 [Radeon Vega Series/Radeon Vega Mobile Series] [1002:15d8] (rev c8) ( prog-if 00 [controlador VGA])
Subsistema: ASUSTeK Computer Inc. Dispositivo [1043:876b]
Marcas: bus master, fast devsel, latencia 0, IRQ 79
Memoria en e0000000 (64 bits, precargable) [tamaño=256M]
Memoria en f0000000 (64 bits, precargable) [tamaño=2M]
Puertos de E/S en e000 [tamaño=256]
Memoria en fcb00000 (32 bits, no recuperable) [tamaño=512K]
[virtual] ROM de expansión en 000c0000 [deshabilitado] [tamaño=128K]
Capacidades: [48] Información específica del proveedor: Len=08 <?>
Capacidades: [ 50] Power Management versión 3
Capacidades: [64] Express Legacy Endpoint, MSI 00
Capacidades: [a0] MSI: Enable- Count=1/4 Maskable- 64bit+
Capacidades: [c0] MSI-X: Enable+ Count=3 Masked-

Salida de: lshw -c vídeo | configuración de configuración grep
: profundidad = 32 controlador = amdgpu latencia = 0 resolución = 1920,1080

Salida de: lshw -numeric -C display
*-display
descripción: controlador compatible con VGA
producto: Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile Series] [1002:15D8]
proveedor: Advanced Micro Devices, Inc. [AMD/ATI] [1002]
identificación física: 0
información de bus : pci@0000:08 : 00.0
nombre lógico: /dev/fb0
versión: c8

Salida de: glxinfo | grep OpenGL
OpenGL cadena de proveedor: AMD
OpenGL renderer cadena: AMD Radeon(TM) Vega 11 Graphics (RAVEN, DRM 3.42.0, 5.14.21-150400.24.11-default, LLVM 11.0.1)
OpenGL core profile versión cadena: 4.6 (Perfil central) Mesa 21.2.4
Cadena de versión de lenguaje de sombreado de perfil central OpenGL: 4.60
OpenGL core profile indicadores de contexto: (ninguno)
OpenGL core profile máscara de perfil: perfil central
Extensiones de perfil principal de
OpenGL: Cadena de versión de OpenGL: 4.6 (Perfil de compatibilidad) Mesa 21.2.4
Cadena de versión de lenguaje de sombreado de OpenGL: 4.60 Indicadores de
contexto de OpenGL: (ninguno)
Máscara de perfil de
OpenGL: perfil de compatibilidad Extensiones de OpenGL:
Cadena de versión de perfil de OpenGL ES: OpenGL ES 3.2 Mesa 21.2.4
Versión del lenguaje de sombreado del perfil OpenGL ES cadena: OpenGL ES GLSL ES 3.20
Extensiones del perfil OpenGL ES:

Salida de: lsmod | grep amdgpu
amdgpu 7823360 70
drm_ttm_helper 16384 1 amdgpu
ttm 81920 2 amdgpu, drm_ttm_helper
mfd_core 20480 1 amdgpu
iommu_v2 24576 1 amdgpu
gpu_sched 49152 1 amdgpu
i2c_algo_bit 16384 1 amdgpu
drm_kms_helper 303104 1 amdgpu
drm 630784 21 gpu_sched,drm_kms_helper,amdgpu,drm_ttm_helper,ttm

En Preferencias >> "Preferencias de Sistema " >> "Pantalla y Monitor" no aparece la opción de referencia tampoco elección de "OpenGl", como aparece la opción "Cubo de Escritorio" en "Animación cambio de escritoriso".
Busqué por internet, pero no encontré nada al respecto. De antemano, gracias por V. tiempo.-

mikrios
22-Jul-2022, 16:28
Hola:

Es normal , así sale en la 15.4, y en 15.3 es distinto .

15.4 en WD AN-1500 2 x 1Tera de WD sn850 en raid 0



Startup finished in 7.166s (kernel) + 3.865s (initrd) + 13.003s (userspace) = 24.035s
graphical.target reached after 11.852s in userspace


mikrios-x299-II:~ # hdparm -tT /dev/nvme6n1

/dev/nvme6n1:
Timing cached reads: 22098 MB in 2.00 seconds = 11074.77 MB/sec
Timing buffered disk reads: 15558 MB in 3.00 seconds = 5185.49 MB/sec


mikrios:~ # inxi -xxxSMCGIz
System:
Kernel: 5.14.21-150400.22-default arch: x86_64 bits: 64 compiler: gcc
v: 7.5.0 Console: pty pts/1 wm: kwin_x11 DM: SDDM
Distro: openSUSE Leap 15.4
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME X299-DELUXE II v: Rev 1.xx
serial: <filter> UEFI: American Megatrends v: 3601 date: 09/24/2021
CPU:
Info: 12-core model: Intel Core i9-10920X bits: 64 type: MT MCP
smt: enabled arch: Cascade Lake rev: 7 cache: L1: 768 KiB L2: 12 MiB
L3: 19.2 MiB
Speed (MHz): avg: 1202 high: 1204 min/max: 1200/4800 volts: 1.6 V
ext-clock: 100 MHz cores: 1: 1203 2: 1202 3: 1201 4: 1203 5: 1203 6: 1203
7: 1202 8: 1203 9: 1202 10: 1202 11: 1202 12: 1201 13: 1204 14: 1202
15: 1199 16: 1203 17: 1203 18: 1203 19: 1202 20: 1202 21: 1203 22: 1202
23: 1203 24: 1202 bogomips: 167995
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nouveau
v: kernel arch: Pascal pcie: speed: 2.5 GT/s lanes: 16 ports:
active: HDMI-A-2 empty: DP-1, DP-2, DVI-D-1, HDMI-A-1 bus-ID: c1:00.0
chip-ID: 10de:1b81 class-ID: 0300
Display: x11 server: X.Org v: 1.20.3 with: Xwayland v: 21.1.4
compositor: kwin_x11 driver: X: loaded: nouveau
unloaded: fbdev,modesetting,vesa alternate: nv,nvidia gpu: nouveau
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (19.96x11.22")
s-diag: 582mm (22.9")
Monitor-1: HDMI-A-2 mapped: HDMI-2 model: LG (GoldStar) ULTRAFINE
serial: <filter> res: 1920x1080 hz: 60 dpi: 70
size: 697x392mm (27.44x15.43") diag: 806mm (31.7") modes: max: 3840x2160
min: 640x480
OpenGL: renderer: llvmpipe (LLVM 11.0.1 256 bits) v: 4.5 Mesa 21.2.4
compat-v: 3.1 direct render: Yes
Info:
Processes: 406 Uptime: 0h 18m wakeups: 0 Memory: 125.48 GiB
used: 2.98 GiB (2.4%) Init: systemd v: 249 target: graphical (5)
default: graphical Compilers: gcc: 7.5.0 alt: 7 Packages: N/A
note: see --pkg Shell: Bash (su) v: 4.4.23 running-in: konsole inxi: 3.3.19






mikrios:~ # glxinfo |grep OpenGL
libGL error: MESA-LOADER: failed to open nouveau: /usr/lib64/dri/nouveau_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib64/dri, suffix _d
ri)
libGL error: failed to load driver: nouveau
OpenGL vendor string: Mesa/X.org
OpenGL renderer string: llvmpipe (LLVM 11.0.1, 256 bits)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 21.2.4
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 21.2.4
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.2.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:



Sale mas o menos así (se parece algo a TW) :

https://paste.opensuse.org/images/72302820.jpg
Saludos cordiales.

navarrete
23-Jul-2022, 07:35
Hola mikrios: ¿significa que perdí mi cubo?, ¿en caso afirmativo, que tal va Compiz o instalar los drivers privativos de amdgpu?
¿Esto es por la SSD- PCIe, si entendí bien? La Captura que incluiste es idem a la mia.Gracias por contestar.